aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorosa <osa@FreeBSD.org>2010-05-25 01:17:17 +0800
committerosa <osa@FreeBSD.org>2010-05-25 01:17:17 +0800
commit5b1693e99c4c7396c0e295a42e4e45c9d816594a (patch)
treee447b9328e905fd9e9fe7fd6ffb4f15cbcb933ab /www
parent9be999ef096e1659b1d6ecf312387148d9b76193 (diff)
downloadfreebsd-ports-gnome-5b1693e99c4c7396c0e295a42e4e45c9d816594a.tar.gz
freebsd-ports-gnome-5b1693e99c4c7396c0e295a42e4e45c9d816594a.tar.zst
freebsd-ports-gnome-5b1693e99c4c7396c0e295a42e4e45c9d816594a.zip
Update from 0.8.37 to 0.8.38.
Add four hacks for third-party modules. <ChangeLog> *) Feature: the "proxy_no_cache" and "fastcgi_no_cache" directives. *) Feature: now the "rewrite" directive does a redirect automatically if the $scheme variable is used. Thanks to Piotr Sikora. *) Bugfix: now "limit_req" delay directive conforms to the described algorithm. Thanks to Maxim Dounin. *) Bugfix: the $uid_got variable might not be used in the SSI and perl modules. </ChangeLog>
Diffstat (limited to 'www')
-rw-r--r--www/nginx-devel/Makefile16
-rw-r--r--www/nginx-devel/distinfo6
-rw-r--r--www/nginx-devel/files/extra-patch-StaticContentHandler.c13
-rw-r--r--www/nginx-devel/files/extra-patch-ngx_http_fancyindex_module.c12
-rw-r--r--www/nginx-devel/files/extra-patch-ngx_http_slowfs_module.c13
-rw-r--r--www/nginx-devel/files/extra-patch-ngx_http_streaming_module.c13
6 files changed, 69 insertions, 4 deletions
diff --git a/www/nginx-devel/Makefile b/www/nginx-devel/Makefile
index 565e5c8a6be2..801114708b16 100644
--- a/www/nginx-devel/Makefile
+++ b/www/nginx-devel/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= nginx
-PORTVERSION= 0.8.37
+PORTVERSION= 0.8.38
CATEGORIES= www
MASTER_SITES= http://sysoev.ru/nginx/
MASTER_SITES+= ${MASTER_SITE_LOCAL}
@@ -466,6 +466,14 @@ post-patch:
's!$$HTTP_ACCESSKEY_MODULE!ngx_http_accesskey_module!' \
${WRKDIR}/nginx-accesskey-${NGINX_ACCESSKEY_MODULE_VERSION}/config
.endif
+.if defined(WITH_HTTP_FANCYINDEX_MODULE)
+ @${PATCH} ${PATCH_ARGS} < \
+ ${PATCHDIR}/extra-patch-ngx_http_fancyindex_module.c
+.endif
+.if defined(WITH_HTTP_MP4_H264_MODULE)
+ @${PATCH} ${PATCH_ARGS} < \
+ ${PATCHDIR}/extra-patch-ngx_http_streaming_module.c
+.endif
.if defined(WITH_HTTP_NOTICE_MODULE)
@${PATCH} ${PATCH_ARGS} < \
${PATCHDIR}/extra-patch-ngx_http_notice_module.c
@@ -476,11 +484,17 @@ post-patch:
@${REINPLACE_CMD} '377s!-g!${CXXFLAGS}!; \
s!-lpthread!${PTHREAD_LIBS}!g' \
${WRKDIR}/passenger-${PASSENGER_VERSION}/lib/phusion_passenger/platform_info.rb
+ @${PATCH} ${PATCH_ARGS} < \
+ ${PATCHDIR}/extra-patch-StaticContentHandler.c
.endif
.if defined(WITH_HTTP_UPSTREAM_HASH)
@${PATCH} ${PATCH_ARGS} < \
${PATCHDIR}/extra-patch-ngx_http_upstream.h
.endif
+.if defined(WITH_SLOWFS_CACHE_MODULE)
+ @${PATCH} ${PATCH_ARGS} < \
+ ${PATCHDIR}/extra-patch-ngx_http_slowfs_module.c
+.endif
.if defined(WITH_SUPERVISORD_MODULE)
( cd ${WRKDIR}/nginx_upstream_fair-${NGINX_UPSTREAM_FAIR_VERSION} && \
${PATCH} -p0 < \
diff --git a/www/nginx-devel/distinfo b/www/nginx-devel/distinfo
index e58fb321c212..5c5ea38194b7 100644
--- a/www/nginx-devel/distinfo
+++ b/www/nginx-devel/distinfo
@@ -1,6 +1,6 @@
-MD5 (nginx-0.8.37.tar.gz) = 19a7d830446a81800d69c1ff4dd727c3
-SHA256 (nginx-0.8.37.tar.gz) = b232ce4c9fe908733b3d558d6262443716606cf246af32483c5fa6c7e69c1646
-SIZE (nginx-0.8.37.tar.gz) = 624068
+MD5 (nginx-0.8.38.tar.gz) = 2eee984d0c5068dabd18fbebfb59a63f
+SHA256 (nginx-0.8.38.tar.gz) = a97241207e7060aa04571e313908f22e007df5b2667c42274420e6a961b2c8c5
+SIZE (nginx-0.8.38.tar.gz) = 623969
MD5 (nginx_accept_language_module.tar.gz) = 330a8d3b2376fb476b5d3111a7905ec3
SHA256 (nginx_accept_language_module.tar.gz) = 7a4c2d42a83c5b6efd2b7b13ad232850b6ab0ca4261df6b46fb7d2d2738b1c0a
SIZE (nginx_accept_language_module.tar.gz) = 3299
diff --git a/www/nginx-devel/files/extra-patch-StaticContentHandler.c b/www/nginx-devel/files/extra-patch-StaticContentHandler.c
new file mode 100644
index 000000000000..fd5e0b3822ec
--- /dev/null
+++ b/www/nginx-devel/files/extra-patch-StaticContentHandler.c
@@ -0,0 +1,13 @@
+--- ../passenger-2.2.11/ext/nginx/StaticContentHandler.c.orig 2010-05-24 20:19:23.000000000 +0400
++++ ../passenger-2.2.11/ext/nginx/StaticContentHandler.c 2010-05-24 20:20:17.000000000 +0400
+@@ -66,10 +66,6 @@
+ return NGX_DECLINED;
+ }
+
+- if (r->zero_in_uri) {
+- return NGX_DECLINED;
+- }
+-
+ log = r->connection->log;
+
+ ngx_log_debug1(NGX_LOG_DEBUG_HTTP, log, 0,
diff --git a/www/nginx-devel/files/extra-patch-ngx_http_fancyindex_module.c b/www/nginx-devel/files/extra-patch-ngx_http_fancyindex_module.c
new file mode 100644
index 000000000000..f37a86a094d7
--- /dev/null
+++ b/www/nginx-devel/files/extra-patch-ngx_http_fancyindex_module.c
@@ -0,0 +1,12 @@
+--- ../ngx-fancyindex-0.2.2/ngx_http_fancyindex_module.c.orig 2010-05-24 17:59:08.000000000 +0400
++++ ../ngx-fancyindex-0.2.2/ngx_http_fancyindex_module.c 2010-05-24 17:59:36.000000000 +0400
+@@ -591,9 +591,6 @@
+ }
+
+ /* TODO: Win32 */
+- if (r->zero_in_uri) {
+- return NGX_DECLINED;
+- }
+
+ if (!(r->method & (NGX_HTTP_GET|NGX_HTTP_HEAD))) {
+ return NGX_DECLINED;
diff --git a/www/nginx-devel/files/extra-patch-ngx_http_slowfs_module.c b/www/nginx-devel/files/extra-patch-ngx_http_slowfs_module.c
new file mode 100644
index 000000000000..8160f242a7cd
--- /dev/null
+++ b/www/nginx-devel/files/extra-patch-ngx_http_slowfs_module.c
@@ -0,0 +1,13 @@
+--- ../ngx_slowfs_cache-1.3/ngx_http_slowfs_module.c.orig 2010-05-24 20:27:47.000000000 +0400
++++ ../ngx_slowfs_cache-1.3/ngx_http_slowfs_module.c 2010-05-24 20:28:04.000000000 +0400
+@@ -809,10 +809,6 @@
+ return NGX_DECLINED;
+ }
+
+- if (r->zero_in_uri) {
+- return NGX_DECLINED;
+- }
+-
+ slowcf = ngx_http_get_module_loc_conf(r, ngx_http_slowfs_module);
+ if (!slowcf->enabled) {
+ return NGX_DECLINED;
diff --git a/www/nginx-devel/files/extra-patch-ngx_http_streaming_module.c b/www/nginx-devel/files/extra-patch-ngx_http_streaming_module.c
new file mode 100644
index 000000000000..3641090a9b5d
--- /dev/null
+++ b/www/nginx-devel/files/extra-patch-ngx_http_streaming_module.c
@@ -0,0 +1,13 @@
+--- ../nginx_mod_h264_streaming-2.2.7/src/ngx_http_streaming_module.c.orig 2010-05-24 18:04:43.000000000 +0400
++++ ../nginx_mod_h264_streaming-2.2.7/src/ngx_http_streaming_module.c 2010-05-24 18:05:02.000000000 +0400
+@@ -155,10 +155,6 @@
+ }
+
+ /* TODO: Win32 */
+- if (r->zero_in_uri)
+- {
+- return NGX_DECLINED;
+- }
+
+ rc = ngx_http_discard_request_body(r);
+