aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2007-07-23 22:45:19 +0800
committerdinoex <dinoex@FreeBSD.org>2007-07-23 22:45:19 +0800
commit6e93fd9ff61fcfa91a960838dbfa3a47cfee638c (patch)
tree87d8620b8d4989b18ffe353eb1b1f09191a8fbda /www
parentdc4c72353b74df8015167fb58f08b23df1f6fffb (diff)
downloadfreebsd-ports-gnome-6e93fd9ff61fcfa91a960838dbfa3a47cfee638c.tar.gz
freebsd-ports-gnome-6e93fd9ff61fcfa91a960838dbfa3a47cfee638c.tar.zst
freebsd-ports-gnome-6e93fd9ff61fcfa91a960838dbfa3a47cfee638c.zip
- drop confusing OPTIONS
- support build with heimdal from ports PR: 97385
Diffstat (limited to 'www')
-rw-r--r--www/mod_auth_kerb/Makefile20
-rw-r--r--www/mod_auth_kerb2/Makefile20
2 files changed, 18 insertions, 22 deletions
diff --git a/www/mod_auth_kerb/Makefile b/www/mod_auth_kerb/Makefile
index e95a413645f2..89d000a7af52 100644
--- a/www/mod_auth_kerb/Makefile
+++ b/www/mod_auth_kerb/Makefile
@@ -27,13 +27,6 @@ USE_GMAKE= yes
# Don't fsck with CFLAGS
CFLAGS:=
GNU_CONFIGURE= yes
-CONFIGURE_ARGS+=--with-krb5=${KRB5_HOME} --without-krb4
-OPTIONS+= BASE_KERBEROS5 "Use the base Kerberos 5 (Heimdal)"
-.if exists(/usr/lib/libkrb5.so)
-OPTIONS+= on
-.else
-OPTIONS+= off
-.endif
.include <bsd.port.pre.mk>
@@ -47,11 +40,16 @@ APACHE_MODULE_DIR!=${PREFIX}/sbin/apxs -q LIBEXECDIR
APACHE_MODULE_DIR=libexec/apache
.endif
PLIST_SUB+= APMODDIR=${APACHE_MODULE_DIR:S/^${PREFIX}\///}
-.if defined(WITH_BASE_KERBEROS5)
-KRB5_HOME= /usr
+
+.if defined(KRB5_HOME) && exists(${KRB5_HOME}/lib/libgssapi_krb5.a)
+CONFIGURE_ARGS+= --with-krb5=${KRB5_HOME} --without-krb4
+.elif defined(HEIMDAL_HOME) && exists(${HEIMDAL_HOME}/lib/libgssapi.a)
+CONFIGURE_ARGS+= --with-krb5=${HEIMDAL_HOME} --without-krb4
+.elif exists(${DESTDIR}/usr/lib/libkrb5.a) && exists(${DESTDIR}/usr/bin/krb5-config)
+CONFIGURE_ARGS+= --with-krb5=${DESTDIR}/usr --without-krb4
.else
-LIB_DEPENDS+= krb5.3:${PORTSDIR}/security/krb5
-KRB5_HOME= ${LOCALBASE}
+LIB_DEPENDS+= krb5:${PORTSDIR}/security/krb5
+CONFIGURE_ARGS+= --with-krb5=${LOCALBASE} --without-krb4
.endif
.include <bsd.port.post.mk>
diff --git a/www/mod_auth_kerb2/Makefile b/www/mod_auth_kerb2/Makefile
index e95a413645f2..89d000a7af52 100644
--- a/www/mod_auth_kerb2/Makefile
+++ b/www/mod_auth_kerb2/Makefile
@@ -27,13 +27,6 @@ USE_GMAKE= yes
# Don't fsck with CFLAGS
CFLAGS:=
GNU_CONFIGURE= yes
-CONFIGURE_ARGS+=--with-krb5=${KRB5_HOME} --without-krb4
-OPTIONS+= BASE_KERBEROS5 "Use the base Kerberos 5 (Heimdal)"
-.if exists(/usr/lib/libkrb5.so)
-OPTIONS+= on
-.else
-OPTIONS+= off
-.endif
.include <bsd.port.pre.mk>
@@ -47,11 +40,16 @@ APACHE_MODULE_DIR!=${PREFIX}/sbin/apxs -q LIBEXECDIR
APACHE_MODULE_DIR=libexec/apache
.endif
PLIST_SUB+= APMODDIR=${APACHE_MODULE_DIR:S/^${PREFIX}\///}
-.if defined(WITH_BASE_KERBEROS5)
-KRB5_HOME= /usr
+
+.if defined(KRB5_HOME) && exists(${KRB5_HOME}/lib/libgssapi_krb5.a)
+CONFIGURE_ARGS+= --with-krb5=${KRB5_HOME} --without-krb4
+.elif defined(HEIMDAL_HOME) && exists(${HEIMDAL_HOME}/lib/libgssapi.a)
+CONFIGURE_ARGS+= --with-krb5=${HEIMDAL_HOME} --without-krb4
+.elif exists(${DESTDIR}/usr/lib/libkrb5.a) && exists(${DESTDIR}/usr/bin/krb5-config)
+CONFIGURE_ARGS+= --with-krb5=${DESTDIR}/usr --without-krb4
.else
-LIB_DEPENDS+= krb5.3:${PORTSDIR}/security/krb5
-KRB5_HOME= ${LOCALBASE}
+LIB_DEPENDS+= krb5:${PORTSDIR}/security/krb5
+CONFIGURE_ARGS+= --with-krb5=${LOCALBASE} --without-krb4
.endif
.include <bsd.port.post.mk>