aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2011-08-15 09:04:42 +0800
committerswills <swills@FreeBSD.org>2011-08-15 09:04:42 +0800
commit6f2cc446e511af3d26b67f62b2f050a1d71f0ecc (patch)
treef6d17b15ab708034bb27abbbdbd23825377a2c71 /www
parent01f6be488b797a0583792d16100a72eae8a3158f (diff)
downloadfreebsd-ports-gnome-6f2cc446e511af3d26b67f62b2f050a1d71f0ecc.tar.gz
freebsd-ports-gnome-6f2cc446e511af3d26b67f62b2f050a1d71f0ecc.tar.zst
freebsd-ports-gnome-6f2cc446e511af3d26b67f62b2f050a1d71f0ecc.zip
Subsonic is a free, web-based media streamer, providing ubiquitous
access to your music. Use it to share your music with friends, or to listen to your own music while at work. You can stream to multiple players simultaneously, for instance to one player in your kitchen and another in your living room. PR: ports/159367 Submitted by: Nicole Reid <root@cooltrainer.org>
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/subsonic/Makefile83
-rw-r--r--www/subsonic/distinfo2
-rw-r--r--www/subsonic/files/pkg-message.in10
-rw-r--r--www/subsonic/pkg-descr6
-rw-r--r--www/subsonic/pkg-plist8
6 files changed, 110 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 359c1c0fe385..42fa6cccc09e 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1749,6 +1749,7 @@
SUBDIR += squirm
SUBDIR += squishdot
SUBDIR += srg
+ SUBDIR += subsonic
SUBDIR += suphp
SUBDIR += surf
SUBDIR += surfraw
diff --git a/www/subsonic/Makefile b/www/subsonic/Makefile
new file mode 100644
index 000000000000..441ae4b7cb88
--- /dev/null
+++ b/www/subsonic/Makefile
@@ -0,0 +1,83 @@
+# New ports collection makefile for: subsonic
+# Date created: 2011-02-01
+# Whom: Nicole Reid <root@cooltrainer.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= subsonic
+PORTVERSION= 4.4
+CATEGORIES= www java
+MASTER_SITES= SF
+DISTNAME= ${PORTNAME}-${PORTVERSION}-war
+
+MAINTAINER= root@cooltrainer.org
+COMMENT= Subsonic streaming media server
+
+BUILD_DEPENDS+= ${LOCALBASE}/apache-tomcat-6.0:${PORTSDIR}/www/tomcat6
+RUN_DEPENDS+= ${JAVAJARDIR}/servlet-api.jar:${PORTSDIR}/www/servlet-api
+
+OPTIONS= TRANSCODING "Enable transcoding with FFmpeg and LAME" On
+
+.include <bsd.port.options.mk>
+
+.if defined(WITH_TRANSCODING)
+RUN_DEPENDS+= ffmpeg:${PORTSDIR}/multimedia/ffmpeg \
+ lame:${PORTSDIR}/audio/lame
+.endif
+
+#Subsonic does not currently run on Tomcat 7
+SUB_FILES= pkg-message
+.if exists(${LOCALBASE}/apache-tomcat-6.0/webapps)
+WEBAPPDIR= ${PREFIX}/apache-tomcat-6.0/webapps
+BUILD_DEPENDS+= ${LOCALBASE}/apache-tomcat-6.0:${PORTSDIR}/www/tomcat6
+RUN_DEPENDS+= ${LOCALBASE}/apache-tomcat-6.0:${PORTSDIR}/www/tomcat6
+SUB_LIST= TOMCATOPTS="tomcat60_java_opts"
+.elif exists(${LOCALBASE}/tomcat5.5/webapps)
+WEBAPPDIR= ${PREFIX}/tomcat5.5/webapps
+BUILD_DEPENDS+= ${LOCALBASE}/tomcat5.5:${PORTSDIR}/www/tomcat55
+RUN_DEPENDS+= ${LOCALBASE}/tomcat5.5:${PORTSDIR}/www/tomcat55
+SUB_LIST= TOMCATOPTS="tomcat55_java_opts"
+.elif exists(${LOCALBASE}/apache-tomcat4.1/webapps)
+WEBAPPDIR= ${PREFIX}/apache-tomcat4.1/webapps
+BUILD_DEPENDS+= ${LOCALBASE}/apache-tomcat4.1:${PORTSDIR}/www/tomcat41
+RUN_DEPENDS+= ${LOCALBASE}/apache-tomcat4.1:${PORTSDIR}/www/tomcat41
+SUB_LIST= TOMCATOPTS="tomcat41_java_opts"
+.else
+WEBAPPDIR= ${PREFIX}/apache-tomcat-6.0/webapps
+BUILD_DEPENDS+= ${LOCALBASE}/apache-tomcat-6.0:${PORTSDIR}/www/tomcat6
+RUN_DEPENDS+= ${LOCALBASE}/apache-tomcat-6.0:${PORTSDIR}/www/tomcat6
+SUB_LIST= TOMCATOPTS="tomcat60_java_opts"
+.endif
+
+NO_BUILD= yes
+USE_JAVA= yes
+JAVA_VERSION= 1.5+
+USE_ZIP= yes
+USER= www
+GROUP= www
+SUBSONIC_HOME= /var/subsonic
+PLIST_SUB+= SUBSONIC_HOME="${SUBSONIC_HOME}"
+
+.if defined(WITH_TRANSCODING)
+PLIST_SUB+= TRANSCODING=""
+.else
+PLIST_SUB+= TRANSCODING="@comment "
+.endif
+
+PLIST_SUB+= WEBAPPS=${WEBAPPDIR:S|^${PREFIX}/||}
+
+do-install:
+ ${INSTALL_DATA} ${WRKDIR}/${PORTNAME}.war ${WEBAPPDIR}
+ @${MKDIR} ${SUBSONIC_HOME}
+ @${CHOWN} ${USER}:${GROUP} ${SUBSONIC_HOME}
+
+post-install:
+.if defined(WITH_TRANSCODING)
+ @${MKDIR} ${SUBSONIC_HOME}/transcode
+ @${LN} -sf ${PREFIX}/bin/ffmpeg ${SUBSONIC_HOME}/transcode/ffmpeg
+ @${LN} -sf ${PREFIX}/bin/lame ${SUBSONIC_HOME}/transcode/lame
+.endif
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/www/subsonic/distinfo b/www/subsonic/distinfo
new file mode 100644
index 000000000000..d07afac3d2da
--- /dev/null
+++ b/www/subsonic/distinfo
@@ -0,0 +1,2 @@
+SHA256 (subsonic-4.4-war.zip) = 6ad572f6e94620f03d2a39d84d56e790884c5100aa92b3ec7c7310e23ab684ca
+SIZE (subsonic-4.4-war.zip) = 18254238
diff --git a/www/subsonic/files/pkg-message.in b/www/subsonic/files/pkg-message.in
new file mode 100644
index 000000000000..f92b08289dbf
--- /dev/null
+++ b/www/subsonic/files/pkg-message.in
@@ -0,0 +1,10 @@
+
+========================================================================
+
+Access Subsonic at http://localhost:8180/subsonic/ (if using the default
+Tomcat HTTP port).
+
+If you encounter problems with thumbnails, start tomcat with
+%%TOMCATOPTS%%="-Djava.awt.headless=true"
+
+========================================================================
diff --git a/www/subsonic/pkg-descr b/www/subsonic/pkg-descr
new file mode 100644
index 000000000000..0865ebd49103
--- /dev/null
+++ b/www/subsonic/pkg-descr
@@ -0,0 +1,6 @@
+Subsonic is a free, web-based media streamer, providing ubiquitous
+access to your music. Use it to share your music with friends,
+or to listen to your own music while at work.
+You can stream to multiple players simultaneously,
+for instance to one player in your kitchen and another in your living
+room.
diff --git a/www/subsonic/pkg-plist b/www/subsonic/pkg-plist
new file mode 100644
index 000000000000..cdda1e7ec4b6
--- /dev/null
+++ b/www/subsonic/pkg-plist
@@ -0,0 +1,8 @@
+%%WEBAPPS%%/subsonic.war
+@unexec if [ ! -d %%WEBAPPS%%/subsonic ]; then rm -f %%WEBAPPS%%/subsonic; fi
+@unexec test -d %%SUBSONIC_HOME%% && (echo "Configuration information saved. If you will *NOT* use this package anymore," && echo "please remove %%SUBSONIC_HOME%% and its contents manually.")
+@exec mkdir -p %%SUBSONIC_HOME%%
+%%TRANSCODING%%@exec ln -sf %%PREFIX/bin/ffmpeg %%SUBSONIC_HOME%%/transcode/ffmpeg
+%%TRANSCODING%%@exec ln -sf %%PREFIX%%/bin/lame %%SUBSONIC_HOME%%/transcode/lame
+%%TRANSCODING%%@unexec rm -f %%SUBSONIC_HOME%%/transcode/ffmpeg
+%%TRANSCODING%%@unexec rm -f %%SUBSONIC_HOME%%/transcode/lame