aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorsem <sem@FreeBSD.org>2004-08-29 05:09:54 +0800
committersem <sem@FreeBSD.org>2004-08-29 05:09:54 +0800
commit7d465ead17ca9343817927ffeb23b34fd58751f2 (patch)
tree8e84f84d9c53c2c9407d00bf716cba8dc876d0ef /www
parentac85c357f362ff91ac806a7862f35efd13aa7b22 (diff)
downloadfreebsd-ports-gnome-7d465ead17ca9343817927ffeb23b34fd58751f2.tar.gz
freebsd-ports-gnome-7d465ead17ca9343817927ffeb23b34fd58751f2.tar.zst
freebsd-ports-gnome-7d465ead17ca9343817927ffeb23b34fd58751f2.zip
- Update to 0.1.9
Changes * Thumbnail support * Recent closed tabs * Toggle proxy use action * Options for history search * Undo/Redo * Fixed crash in attempting to search in the detailed preference PR: ports/71088 Submitted by: maintainer
Diffstat (limited to 'www')
-rw-r--r--www/kazehakase/Makefile31
-rw-r--r--www/kazehakase/distinfo4
-rw-r--r--www/kazehakase/files/patch-configure13
-rw-r--r--www/kazehakase/pkg-message4
-rw-r--r--www/kazehakase/pkg-plist7
5 files changed, 40 insertions, 19 deletions
diff --git a/www/kazehakase/Makefile b/www/kazehakase/Makefile
index 6b532416f444..d8cf593a0e00 100644
--- a/www/kazehakase/Makefile
+++ b/www/kazehakase/Makefile
@@ -6,10 +6,10 @@
#
PORTNAME= kazehakase
-PORTVERSION= 0.1.8.1
+PORTVERSION= 0.1.9
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_JP}
-MASTER_SITE_SUBDIR= ${PORTNAME}/10618/
+MASTER_SITE_SUBDIR= ${PORTNAME}/11115/
MAINTAINER= ahze@ahze.net
COMMENT= Kazehakase is a browser with gecko engine like Epiphany or Galeon
@@ -38,17 +38,33 @@ USE_X_PREFIX= yes
USE_GNOME= gnomehack intlhack gnomeprefix gtk20
USE_GMAKE= yes
USE_REINPLACE= yes
+
+.if defined(WITH_MIGEMO)
+USE_RUBY= yes
+.endif
+
CONFIGURE_ARGS= --with-mozilla-includes="${X11BASE}/include/mozilla${HEADERS_SUFX}" \
--with-mozilla-libs="${X11BASE}/lib/${MOZILLA}" \
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include ${PTHREAD_CFLAGS}" \
LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
-OPTIONS= MIGEMO "Enable Migemo (Japanese incremental search)" Off
+OPTIONS= MIGEMO "Enable Migemo (Japanese incremental search)" Off \
+ IMAGEMAGICK "Enable Thumbnail support (EXPERIMENTAL!)" Off
FLASHPLAYER= ${LOCALBASE}/lib/libflashplayer.so.1
.include <bsd.port.pre.mk>
+.if exists(${LOCALBASE}/bin/migemo)
+.if exists(${RUBY_SITEARCHLIBDIR}/uconv.so)
+WITH_MIGEMO= yes
+.endif
+.endif
+
+.if exists(${LOCALBASE}/bin/convert)
+WITH_IMAGEMAGICK=yes
+.endif
+
.if defined(WITH_MIGEMO)
.if ${ARCH} == "i386" || ${ARCH} == "sparc64"
RUN_DEPENDS+= migemo:${PORTSDIR}/japanese/migemo \
@@ -58,6 +74,10 @@ CONFIUGURE_ARGS+= --enable-migemo
.endif
.endif
+.if defined(WITH_IMAGEMAGICK)
+RUN_DEPENDS+= convert:${PORTSDIR}/graphics/ImageMagick
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|mozilla-gtkmozembed|mozilla-gtkmozembed${HEADERS_SUFX}|g' \
${WRKSRC}/configure
@@ -70,4 +90,9 @@ post-configure:
s|%%LOCALBASE%%|${LOCALBASE}|; s|%%MOZILLA%%|${MOZILLA}|' \
${WRKSRC}/src/kazehakase
+post-install:
+.if defined(WITH_IMAGEMAGICK)
+ @${CAT} ${PKGMESSAGE}
+.endif
+
.include <bsd.port.post.mk>
diff --git a/www/kazehakase/distinfo b/www/kazehakase/distinfo
index 46df9a38d243..370747952b03 100644
--- a/www/kazehakase/distinfo
+++ b/www/kazehakase/distinfo
@@ -1,2 +1,2 @@
-MD5 (kazehakase-0.1.8.1.tar.gz) = 1a4f67f125657e4f630e8418ca69f4cf
-SIZE (kazehakase-0.1.8.1.tar.gz) = 1007770
+MD5 (kazehakase-0.1.9.tar.gz) = 72a733327f0cdef740996b6f9efdfeba
+SIZE (kazehakase-0.1.9.tar.gz) = 1045767
diff --git a/www/kazehakase/files/patch-configure b/www/kazehakase/files/patch-configure
index 0bdbab59a233..e69de29bb2d1 100644
--- a/www/kazehakase/files/patch-configure
+++ b/www/kazehakase/files/patch-configure
@@ -1,13 +0,0 @@
---- configure.orig Fri Aug 27 12:36:22 2004
-+++ configure Fri Aug 27 12:37:21 2004
-@@ -19324,7 +19324,10 @@
- 1.7rc3) MOZILLA_SNAPSHOT=15 ;;
- 1.7) MOZILLA_SNAPSHOT=15 ;;
- 1.7.1) MOZILLA_SNAPSHOT=15 ;;
-+ 1.7.2) MOZILLA_SNAPSHOT=15 ;;
- 1.8a) MOZILLA_SNAPSHOT=16 ;;
-+ 1.8a2) MOZILLA_SNAPSHOT=16 ;;
-+ 1.8a3) MOZILLA_SNAPSHOT=16 ;;
- trunk) MOZILLA_SNAPSHOT=16 ;;
- *) { { echo "$as_me:$LINENO: error:
- *****************************************************************************
diff --git a/www/kazehakase/pkg-message b/www/kazehakase/pkg-message
new file mode 100644
index 000000000000..06f7daa4b7e0
--- /dev/null
+++ b/www/kazehakase/pkg-message
@@ -0,0 +1,4 @@
+===>
+===> Thumbnail support is in the experimental state, so it does not work by
+===> default. If you wish to use thumbnails, you have to write
+===> "create_thumbnail=true" in [Global] section in ~/.kazehakase/kzrc
diff --git a/www/kazehakase/pkg-plist b/www/kazehakase/pkg-plist
index 996f0a45d1da..49faaed75d47 100644
--- a/www/kazehakase/pkg-plist
+++ b/www/kazehakase/pkg-plist
@@ -1,6 +1,5 @@
bin/kazehakase
bin/kz
-bin/kzmigemo
etc/kazehakase/bookmarkbar.xml
etc/kazehakase/bookmarks.xml
etc/kazehakase/kz-ui-beginner.xml
@@ -12,6 +11,7 @@ etc/kazehakase/proxyrc
etc/kazehakase/smartbookmarks.xml
share/gnome/applications/kazehakase.desktop
share/gnome/kazehakase/icons/kz-anchor.png
+share/gnome/kazehakase/icons/kz-book-search.png
share/gnome/kazehakase/icons/kz-bookmark.png
share/gnome/kazehakase/icons/kz-closebackward.png
share/gnome/kazehakase/icons/kz-closeforward.png
@@ -20,6 +20,7 @@ share/gnome/kazehakase/icons/kz-copyimagelocation.png
share/gnome/kazehakase/icons/kz-copyurl.png
share/gnome/kazehakase/icons/kz-editor.png
share/gnome/kazehakase/icons/kz-folder-open.png
+share/gnome/kazehakase/icons/kz-folder-search.png
share/gnome/kazehakase/icons/kz-folder.png
share/gnome/kazehakase/icons/kz-google.png
share/gnome/kazehakase/icons/kz-gray.png
@@ -36,10 +37,14 @@ share/gnome/kazehakase/icons/kz-remote-bookmark.png
share/gnome/kazehakase/icons/kz-savelink.png
share/gnome/kazehakase/icons/kz-scrap-bookmark.png
share/gnome/kazehakase/icons/kz-search.png
+share/gnome/kazehakase/icons/kz-select-all.png
share/gnome/kazehakase/icons/kz-separator.png
share/gnome/kazehakase/icons/kz-smart-bookmark.png
share/gnome/kazehakase/icons/kz-tab-next.png
share/gnome/kazehakase/icons/kz-tab-prev.png
+share/gnome/kazehakase/icons/kz-view-source.png
+share/gnome/kazehakase/kz-no-thumbnail.png
+share/gnome/kazehakase/search-result.css
share/gnome/pixmaps/kazehakase-icon.png
share/locale/ja/LC_MESSAGES/kazehakase.mo
@dirrm share/gnome/kazehakase/icons