aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorkoobs <koobs@FreeBSD.org>2015-06-25 15:09:06 +0800
committerkoobs <koobs@FreeBSD.org>2015-06-25 15:09:06 +0800
commit883e0faa32f568bc4e4015172565de32807c16c2 (patch)
treebca7e565ca3318f149799a2a0dd2519d5e7f0ed5 /www
parent6af11782c17d4c79afb7bd36a3362db3c9d03904 (diff)
downloadfreebsd-ports-gnome-883e0faa32f568bc4e4015172565de32807c16c2.tar.gz
freebsd-ports-gnome-883e0faa32f568bc4e4015172565de32807c16c2.tar.zst
freebsd-ports-gnome-883e0faa32f568bc4e4015172565de32807c16c2.zip
www/py-django-mptt: Fix Django dependency causing conflicts
Tweak RUN_DEPENDS, switching to file-based django detection, instead of by package name. This ensures that if a port that depends on this one, also depends on a different django version, it will see and use the installed version, rather than attempting to install another one, which results in a conflict as all django ports conflict with each other. www/py-django-dpaste depends on py-django-mptt but is about to be limited to Django <= 1.6 (it does not currently support higher). Since py-django-mptt depends on www/py-django (currently 1.8.x), this results in the conflict described above. The same change will also be made in www/py-django-dpaste for any ports that may depend on *it* in the future. This change is a NOOP for other conditions. See r390184 [1] for another instance of this issue. [1] https://svnweb.freebsd.org/changeset/ports/390184 Approved by: portmgr (blanket: trivial, tested, build fixes)
Diffstat (limited to 'www')
-rw-r--r--www/py-django-mptt/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/www/py-django-mptt/Makefile b/www/py-django-mptt/Makefile
index c4fbb4fa3748..5f1071de65ca 100644
--- a/www/py-django-mptt/Makefile
+++ b/www/py-django-mptt/Makefile
@@ -11,7 +11,7 @@ COMMENT= Utilities for implementing a pre-order traversal tree in django
LICENSE= MIT
-BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}django>=1.4.2:${PORTSDIR}/www/py-django
+BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/django/bin/django-admin.py:${PORTSDIR}/www/py-django # >= 1.4.2
RUN_DEPENDS:= ${BUILD_DEPENDS}
USE_GITHUB= yes