aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorosa <osa@FreeBSD.org>2010-05-26 00:10:57 +0800
committerosa <osa@FreeBSD.org>2010-05-26 00:10:57 +0800
commit8efe410efb312c12a57fd85d7f85ee3e1319586a (patch)
tree6f7f3f543b2b37b38ba8e7cba8e124c10af9d206 /www
parentf27fa91daca614f92643094123c806e50fdd9b76 (diff)
downloadfreebsd-ports-gnome-8efe410efb312c12a57fd85d7f85ee3e1319586a.tar.gz
freebsd-ports-gnome-8efe410efb312c12a57fd85d7f85ee3e1319586a.tar.zst
freebsd-ports-gnome-8efe410efb312c12a57fd85d7f85ee3e1319586a.zip
Accordingly update third-party slowfs_cache module from 1.3 to 1.4.
Remove needless patch. Do not bump PORTREVISIONs.
Diffstat (limited to 'www')
-rw-r--r--www/nginx-devel/Makefile6
-rw-r--r--www/nginx-devel/distinfo6
-rw-r--r--www/nginx-devel/files/extra-patch-ngx_http_slowfs_module.c13
-rw-r--r--www/nginx/Makefile2
-rw-r--r--www/nginx/distinfo6
5 files changed, 8 insertions, 25 deletions
diff --git a/www/nginx-devel/Makefile b/www/nginx-devel/Makefile
index 801114708b16..3b92c8f4ef25 100644
--- a/www/nginx-devel/Makefile
+++ b/www/nginx-devel/Makefile
@@ -391,7 +391,7 @@ CONFIGURE_ARGS+=--add-module=${WRKDIR}/passenger-${PASSENGER_VERSION}/ext/nginx
.endif
.if defined(WITH_SLOWFS_CACHE_MODULE)
-NGINX_SLOWFS_CACHE_MODULE_VERSION= 1.3
+NGINX_SLOWFS_CACHE_MODULE_VERSION= 1.4
MASTER_SITES+= http://labs.frickle.com/files/:slowfs_cache
DISTFILES+= ngx_slowfs_cache-${NGINX_SLOWFS_CACHE_MODULE_VERSION}.tar.gz:slowfs_cache
CONFIGURE_ARGS+=--add-module=${WRKDIR}/ngx_slowfs_cache-${NGINX_SLOWFS_CACHE_MODULE_VERSION}
@@ -491,10 +491,6 @@ post-patch:
@${PATCH} ${PATCH_ARGS} < \
${PATCHDIR}/extra-patch-ngx_http_upstream.h
.endif
-.if defined(WITH_SLOWFS_CACHE_MODULE)
- @${PATCH} ${PATCH_ARGS} < \
- ${PATCHDIR}/extra-patch-ngx_http_slowfs_module.c
-.endif
.if defined(WITH_SUPERVISORD_MODULE)
( cd ${WRKDIR}/nginx_upstream_fair-${NGINX_UPSTREAM_FAIR_VERSION} && \
${PATCH} -p0 < \
diff --git a/www/nginx-devel/distinfo b/www/nginx-devel/distinfo
index 5c5ea38194b7..5a31fab9b8bf 100644
--- a/www/nginx-devel/distinfo
+++ b/www/nginx-devel/distinfo
@@ -73,9 +73,9 @@ SIZE (ngx_http_memc_module-0.08.tar.gz) = 92182
MD5 (passenger-2.2.11.tar.gz) = 3eb0aa6360c6f537d1eb6eb1f26cc8eb
SHA256 (passenger-2.2.11.tar.gz) = 9d4aa14a4dfe9daa713aa19a787e1a5bee0db9f3625e17ffebe1e5325aa20a88
SIZE (passenger-2.2.11.tar.gz) = 2058085
-MD5 (ngx_slowfs_cache-1.3.tar.gz) = 38823dbd8322ebc90f96d66b4a0501bf
-SHA256 (ngx_slowfs_cache-1.3.tar.gz) = 3e15447a467480800b3a08dcb4d893edc5c96a127c17c5c3359da10e683636dd
-SIZE (ngx_slowfs_cache-1.3.tar.gz) = 9680
+MD5 (ngx_slowfs_cache-1.4.tar.gz) = 0aafe80f856682a94f016fb4bb5dd3c6
+SHA256 (ngx_slowfs_cache-1.4.tar.gz) = 0e71a916832b1aa7586f973df1a731621c2bcb5198352525d95643615c9f422c
+SIZE (ngx_slowfs_cache-1.4.tar.gz) = 9741
MD5 (ngx_supervisord-1.4.tar.gz) = 57b9cc2835f5fb66fc65b2fd3cc3ed37
SHA256 (ngx_supervisord-1.4.tar.gz) = 0954a4efb1b955692acf523e169221146d6aa93ad1643c9f2482f75a1fbf9e3b
SIZE (ngx_supervisord-1.4.tar.gz) = 19351
diff --git a/www/nginx-devel/files/extra-patch-ngx_http_slowfs_module.c b/www/nginx-devel/files/extra-patch-ngx_http_slowfs_module.c
deleted file mode 100644
index 8160f242a7cd..000000000000
--- a/www/nginx-devel/files/extra-patch-ngx_http_slowfs_module.c
+++ /dev/null
@@ -1,13 +0,0 @@
---- ../ngx_slowfs_cache-1.3/ngx_http_slowfs_module.c.orig 2010-05-24 20:27:47.000000000 +0400
-+++ ../ngx_slowfs_cache-1.3/ngx_http_slowfs_module.c 2010-05-24 20:28:04.000000000 +0400
-@@ -809,10 +809,6 @@
- return NGX_DECLINED;
- }
-
-- if (r->zero_in_uri) {
-- return NGX_DECLINED;
-- }
--
- slowcf = ngx_http_get_module_loc_conf(r, ngx_http_slowfs_module);
- if (!slowcf->enabled) {
- return NGX_DECLINED;
diff --git a/www/nginx/Makefile b/www/nginx/Makefile
index 47646083e466..994a73c303a5 100644
--- a/www/nginx/Makefile
+++ b/www/nginx/Makefile
@@ -379,7 +379,7 @@ CONFIGURE_ARGS+=--add-module=${WRKDIR}/passenger-${PASSENGER_VERSION}/ext/nginx
.endif
.if defined(WITH_SLOWFS_CACHE_MODULE)
-NGINX_SLOWFS_CACHE_MODULE_VERSION= 1.3
+NGINX_SLOWFS_CACHE_MODULE_VERSION= 1.4
MASTER_SITES+= http://labs.frickle.com/files/:slowfs_cache
DISTFILES+= ngx_slowfs_cache-${NGINX_SLOWFS_CACHE_MODULE_VERSION}.tar.gz:slowfs_cache
CONFIGURE_ARGS+=--add-module=${WRKDIR}/ngx_slowfs_cache-${NGINX_SLOWFS_CACHE_MODULE_VERSION}
diff --git a/www/nginx/distinfo b/www/nginx/distinfo
index b85bb01d2513..4a3c3419dc4b 100644
--- a/www/nginx/distinfo
+++ b/www/nginx/distinfo
@@ -73,9 +73,9 @@ SIZE (ngx_http_memc_module-0.08.tar.gz) = 92182
MD5 (passenger-2.2.11.tar.gz) = 3eb0aa6360c6f537d1eb6eb1f26cc8eb
SHA256 (passenger-2.2.11.tar.gz) = 9d4aa14a4dfe9daa713aa19a787e1a5bee0db9f3625e17ffebe1e5325aa20a88
SIZE (passenger-2.2.11.tar.gz) = 2058085
-MD5 (ngx_slowfs_cache-1.3.tar.gz) = 38823dbd8322ebc90f96d66b4a0501bf
-SHA256 (ngx_slowfs_cache-1.3.tar.gz) = 3e15447a467480800b3a08dcb4d893edc5c96a127c17c5c3359da10e683636dd
-SIZE (ngx_slowfs_cache-1.3.tar.gz) = 9680
+MD5 (ngx_slowfs_cache-1.4.tar.gz) = 0aafe80f856682a94f016fb4bb5dd3c6
+SHA256 (ngx_slowfs_cache-1.4.tar.gz) = 0e71a916832b1aa7586f973df1a731621c2bcb5198352525d95643615c9f422c
+SIZE (ngx_slowfs_cache-1.4.tar.gz) = 9741
MD5 (ngx_supervisord-1.4.tar.gz) = 57b9cc2835f5fb66fc65b2fd3cc3ed37
SHA256 (ngx_supervisord-1.4.tar.gz) = 0954a4efb1b955692acf523e169221146d6aa93ad1643c9f2482f75a1fbf9e3b
SIZE (ngx_supervisord-1.4.tar.gz) = 19351