aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2016-09-12 10:30:43 +0800
committermarino <marino@FreeBSD.org>2016-09-12 10:30:43 +0800
commitb5920d227fb4169edad5328e1065801d62c708d1 (patch)
treefb24d69f8fadc20fd6965549346e4cac9295daac /www
parente30b7a1c76b9cf9d294cc89a48b1dc423cd09d97 (diff)
downloadfreebsd-ports-gnome-b5920d227fb4169edad5328e1065801d62c708d1.tar.gz
freebsd-ports-gnome-b5920d227fb4169edad5328e1065801d62c708d1.tar.zst
freebsd-ports-gnome-b5920d227fb4169edad5328e1065801d62c708d1.zip
www/httest: Document SSL requirement and support LibreSSL
Approved by: SSL blanket
Diffstat (limited to 'www')
-rw-r--r--www/httest/Makefile2
-rw-r--r--www/httest/files/patch-src_ssl__module.c46
2 files changed, 47 insertions, 1 deletions
diff --git a/www/httest/Makefile b/www/httest/Makefile
index 447e9e446527..3de2fe7726c7 100644
--- a/www/httest/Makefile
+++ b/www/httest/Makefile
@@ -27,7 +27,7 @@ CONFIGURE_ARGS= --enable-lua-module \
--with-ssl="${OPENSSLLIB}"
CPPFLAGS+= -I${LUA_INCDIR}
GNU_CONFIGURE= yes
-USES= iconv lua libtool bdb
+USES= iconv lua libtool bdb ssl
USE_OPENSSL= yes
USE_LDCONFIG= yes
diff --git a/www/httest/files/patch-src_ssl__module.c b/www/httest/files/patch-src_ssl__module.c
new file mode 100644
index 000000000000..d48f481b427e
--- /dev/null
+++ b/www/httest/files/patch-src_ssl__module.c
@@ -0,0 +1,46 @@
+--- src/ssl_module.c.orig 2015-03-16 15:46:05 UTC
++++ src/ssl_module.c
+@@ -349,7 +349,7 @@ static void ssl_message_trace(int write_
+ case DTLS1_VERSION:
+ str_version = "DTLS 1.0";
+ break;
+-#if (OPENSSL_VERSION_NUMBER >= 0x1000100fL)
++#if OPENSSL_VERSION_NUMBER >= 0x1000100fL && defined(DTLS1_BAD_VER)
+ case DTLS1_BAD_VER:
+ str_version = "DTLS 1.0 (bad)";
+ break;
+@@ -421,7 +421,7 @@ static void ssl_message_trace(int write_
+ version == TLS1_1_VERSION ||
+ #endif
+ version == DTLS1_VERSION
+-#if (OPENSSL_VERSION_NUMBER >= 0x1000100fL)
++#if OPENSSL_VERSION_NUMBER >= 0x1000100fL && defined(DTLS1_BAD_VER)
+ || version == DTLS1_BAD_VER
+ #endif
+ ) {
+@@ -740,10 +740,12 @@ static int worker_set_client_method(work
+ config->meth = SSLv2_client_method();
+ }
+ #endif
++#ifndef OPENSSL_NO_SSL3
+ else if (strcasecmp(sslstr, "SSL3") == 0) {
+ is_ssl = 1;
+ config->meth = SSLv3_client_method();
+ }
++#endif
+ else if (strcasecmp(sslstr, "TLS1") == 0) {
+ is_ssl = 1;
+ config->meth = TLSv1_client_method();
+@@ -787,10 +789,12 @@ static int worker_set_server_method(work
+ config->meth = SSLv2_server_method();
+ }
+ #endif
++#ifndef OPENSSL_NO_SSL3
+ else if (strcasecmp(sslstr, "SSL3") == 0) {
+ is_ssl = 1;
+ config->meth = SSLv3_server_method();
+ }
++#endif
+ else if (strcasecmp(sslstr, "TLS1") == 0) {
+ is_ssl = 1;
+ config->meth = TLSv1_server_method();