aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2017-10-11 05:31:30 +0800
committerlinimon <linimon@FreeBSD.org>2017-10-11 05:31:30 +0800
commitbc940feb08f69c198c2d6ba70142c26f6a35f8ff (patch)
treef3d89a0399e1e0896808a5ab7c804ecd549e47db /www
parent8be4719cfd2cb75c5c21d067453d3464fc2be7e7 (diff)
downloadfreebsd-ports-gnome-bc940feb08f69c198c2d6ba70142c26f6a35f8ff.tar.gz
freebsd-ports-gnome-bc940feb08f69c198c2d6ba70142c26f6a35f8ff.tar.zst
freebsd-ports-gnome-bc940feb08f69c198c2d6ba70142c26f6a35f8ff.zip
For ports that are explicitly enabled on armv6, also enable them
on armv7. This has not been tested with an -exp run but should "do no harm". PR: 221894 (partial)
Diffstat (limited to 'www')
-rw-r--r--www/node/Makefile4
-rw-r--r--www/node6/Makefile4
2 files changed, 4 insertions, 4 deletions
diff --git a/www/node/Makefile b/www/node/Makefile
index 7eea70417563..e4741b24b15b 100644
--- a/www/node/Makefile
+++ b/www/node/Makefile
@@ -44,7 +44,7 @@ USE_LDCONFIG= yes
CONFLICTS_INSTALL= node[456]-[0-9]* node01[02]-[0-9]* node-devel-[0-9]* iojs-[0-9]*
-ONLY_FOR_ARCHS= aarch64 amd64 armv6 i386
+ONLY_FOR_ARCHS= aarch64 amd64 armv6 armv7 i386
CONFIGURE_ARGS= --prefix=${PREFIX_RELDEST} \
--without-npm \
@@ -77,7 +77,7 @@ IGNORE= cannot build node.js with LibreSSL. You must enable BUNDLED_SSL
.include <bsd.port.pre.mk>
-.if ${ARCH} == "armv6"
+.if ${ARCH} == armv6 || ${ARCH} == armv7
CONFIGURE_ARGS+=--openssl-no-asm
.endif
diff --git a/www/node6/Makefile b/www/node6/Makefile
index 0fd01d83a169..211d6625a431 100644
--- a/www/node6/Makefile
+++ b/www/node6/Makefile
@@ -43,7 +43,7 @@ USE_LDCONFIG= yes
CONFLICTS_INSTALL= node[45]-[0-9]* node01[02]-[0-9]* node-[0-9]* node-devel-[0-9]* iojs-[0-9]*
-ONLY_FOR_ARCHS= amd64 armv6 i386
+ONLY_FOR_ARCHS= amd64 armv6 armv7 i386
CONFIGURE_ARGS= --prefix=${PREFIX_RELDEST} \
--without-npm \
@@ -76,7 +76,7 @@ IGNORE= cannot build node.js with LibreSSL. You must enable BUNDLED_SSL
.include <bsd.port.pre.mk>
-.if ${ARCH} == "armv6"
+.if ${ARCH} == armv6 || ${ARCH} == armv7
CONFIGURE_ARGS+=--openssl-no-asm
.endif