aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2014-06-27 22:18:36 +0800
committermiwi <miwi@FreeBSD.org>2014-06-27 22:18:36 +0800
commitcda26c046dd22feb6eb266b70647920b07dacdc3 (patch)
tree67c64b83149c0b67e2e8aedc9061a1a0bac94e25 /www
parent4299275a089263519d2b790527b983339da84b49 (diff)
downloadfreebsd-ports-gnome-cda26c046dd22feb6eb266b70647920b07dacdc3.tar.gz
freebsd-ports-gnome-cda26c046dd22feb6eb266b70647920b07dacdc3.tar.zst
freebsd-ports-gnome-cda26c046dd22feb6eb266b70647920b07dacdc3.zip
- Update to 3.108
- Change MASTER_SITES, use canonical and mirror [1] - Add Technical Documentation and UFO source files [1] - Add USES=zip - Change pkg-descr, pkg-plist and pkg-message PR: 190811
Diffstat (limited to 'www')
-rw-r--r--www/fira-webfont/Makefile59
-rw-r--r--www/fira-webfont/distinfo12
-rw-r--r--www/fira-webfont/files/pkg-message.in46
-rw-r--r--www/fira-webfont/pkg-descr15
-rw-r--r--www/fira-webfont/pkg-plist102
5 files changed, 148 insertions, 86 deletions
diff --git a/www/fira-webfont/Makefile b/www/fira-webfont/Makefile
index 6eae69196683..5910bb2a67d3 100644
--- a/www/fira-webfont/Makefile
+++ b/www/fira-webfont/Makefile
@@ -2,43 +2,64 @@
# $FreeBSD$
PORTNAME= fira
-PORTVERSION= 1.0
+PORTVERSION= 3.108
CATEGORIES= www
+MASTER_SITES= http://dev.carrois.com/wordpress/downloads/${PORTNAME}_3_1/ \
+ SF/horia/${CATEGORIES}/${PORTNAME}${PKGNAMESUFFIX}/ \
+ SF/horia/${CATEGORIES}/${PORTNAME}${PKGNAMESUFFIX}/:bp
PKGNAMESUFFIX= -webfont
+DISTNAME= ${PORTNAME:S|f|F|}Fonts${PORTVERSION:S|.||}
+DISTFILES= ${PORTNAME:S|f|F|}Boilerplate${PORTVERSION:S|.||}${EXTRACT_SUFX}:bp \
+ ${DISTNAME}${EXTRACT_SUFX} \
+ ${PORTNAME:S|f|F|}PDF${PORTVERSION:S|.||}${EXTRACT_SUFX} \
+ ${PORTNAME:S|f|F|}UFO_beta${PORTVERSION:S|.||}${EXTRACT_SUFX} \
+ Version_Report.rtf
+EXTRACT_ONLY= ${DISTFILES:C|Version.*||:S|:bp||}
MAINTAINER= horia@racoviceanu.com
COMMENT= Sans-serif and monospaced Web Font for small screens
LICENSE= OFL11
-USE_GITHUB= yes
-GH_ACCOUNT= mozilla
-GH_PROJECT= Fira
-GH_TAGNAME= ${GH_COMMIT}
-GH_COMMIT= 705ffff
-
+USES= zip
NO_BUILD= yes
-PORTDOCS= README.md
+SUB_FILES= pkg-message
+PLIST_SUB= WWWDIR_REL="${WWWDIR_REL}"
+
DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}${PKGNAMESUFFIX}
+PORTDOCS= Version_Report.rtf \
+ ${PORTNAME:S|f|F|}*.pdf
-OPTIONS_DEFINE= DOCS
+EXAMPLESDIR= ${PREFIX}/share/examples/${PORTNAME}${PKGNAMESUFFIX}
+PORTEXAMPLES= *
-SUB_FILES= pkg-message
-PLIST_SUB= WWWDIR_REL=${WWWDIR_REL}
+OPTIONS_DEFINE= DOCS EXAMPLES
+EXAMPLES_DESC= UFO source files
+
+.include <bsd.port.options.mk>
do-install:
@${MKDIR} ${STAGEDIR}${WWWDIR}
- ${INSTALL_DATA} ${WRKSRC}/index.html ${STAGEDIR}${WWWDIR}
- ${INSTALL_DATA} ${WRKSRC}/fira.css ${STAGEDIR}${WWWDIR}
- @${MKDIR} ${STAGEDIR}${WWWDIR}/eot
- ${INSTALL_DATA} ${WRKSRC}/eot/${GH_PROJECT}*.eot ${STAGEDIR}${WWWDIR}/eot/
- @${MKDIR} ${STAGEDIR}${WWWDIR}/ttf
- ${INSTALL_DATA} ${WRKSRC}/ttf/${GH_PROJECT}*.ttf ${STAGEDIR}${WWWDIR}/ttf/
- @${MKDIR} ${STAGEDIR}${WWWDIR}/woff
- ${INSTALL_DATA} ${WRKSRC}/woff/${GH_PROJECT}*.woff ${STAGEDIR}${WWWDIR}/woff/
+.for b in index.html fira.css
+ ${INSTALL_DATA} \
+ ${WRKDIR}/${PORTNAME:S|f|F|}Boilerplate${PORTVERSION:S|.||}/${b} \
+ ${STAGEDIR}${WWWDIR}
+.endfor
+
+.for w in eot ttf woff
+ @${MKDIR} ${STAGEDIR}${WWWDIR}/${w}
+ ${INSTALL_DATA} ${WRKSRC}/${PORTNAME:S|f|F|}*${PORTVERSION:S|.||}/WEB/${PORTNAME:S|f|F|}*.${w} \
+ ${STAGEDIR}${WWWDIR}/${w}/
+.endfor
@${MKDIR} ${STAGEDIR}${DOCSDIR}
+ @${CP} ${DISTDIR}/Version_Report.rtf ${WRKSRC}/
+ @${CP} ${WRKDIR}/${PORTNAME:S|f|F|}PDF${PORTVERSION:S|.||}/${PORTNAME:S|f|F|}*.pdf ${WRKSRC}/
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ (cd ${WRKDIR}/${PORTNAME:S|f|F|}UFO_beta${PORTVERSION:S|.||} && \
+ ${COPYTREE_SHARE} . ${STAGEDIR}${EXAMPLESDIR})
+
.include <bsd.port.mk>
diff --git a/www/fira-webfont/distinfo b/www/fira-webfont/distinfo
index 0a0c7df79646..1aa20bad0f9e 100644
--- a/www/fira-webfont/distinfo
+++ b/www/fira-webfont/distinfo
@@ -1,2 +1,10 @@
-SHA256 (fira-1.0.tar.gz) = f87bd7d1380e5a93a3743edd3d038b44c7460ea14c204b152b750f5551fd2531
-SIZE (fira-1.0.tar.gz) = 3973356
+SHA256 (FiraBoilerplate3108.zip) = a34e27deeebbb5b1c0fabf85fa61eb56e24cf8c720377a67bc6bd8556ddd06a8
+SIZE (FiraBoilerplate3108.zip) = 2345
+SHA256 (FiraFonts3108.zip) = 1276faad9079547d49e320acf30f2d35c569aa0a8dc4fbaed58535122efc1859
+SIZE (FiraFonts3108.zip) = 12452926
+SHA256 (FiraPDF3108.zip) = fb876e5271bfa4c06050e1854458be5eeaac897708e114481939332204c77159
+SIZE (FiraPDF3108.zip) = 18991895
+SHA256 (FiraUFO_beta3108.zip) = 8edd2f1a768055c949ccfb6f20aa4a900b327c8bd7e63bd1d261ab987f611f2a
+SIZE (FiraUFO_beta3108.zip) = 7088932
+SHA256 (Version_Report.rtf) = 6a32e9c54abf66a49adcb61223fb23465850bd8f48f1eb512f647eb4eb7bb71c
+SIZE (Version_Report.rtf) = 4671
diff --git a/www/fira-webfont/files/pkg-message.in b/www/fira-webfont/files/pkg-message.in
index 2ad6b3262443..35a08ae2e376 100644
--- a/www/fira-webfont/files/pkg-message.in
+++ b/www/fira-webfont/files/pkg-message.in
@@ -1,39 +1,13 @@
===============================================================================
-Fira has been installed.
-
-Example HTML and CSS have been installed in %%WWWDIR%%
-
-Fira Technical Documentation is currently available only by downloading the
-"Fira Open Type" archive from:
-
- https://www.mozilla.org/en-US/styleguide/products/firefox-os/typeface/
-
-Note: JavaScript must be enabled as box.com does not provide an URL for sharing
-
-Fira supports the following advanced Open Type typographic layout features:
-- Access All Alternates
-- Small Capitals
-- Small Capitals From Capitals
-- Contextual Alternates
-- Standard Ligatures
-- Discretionary Ligatures
-- Old Style Figures
-- Lining Figures
-- Proportional Figures
-- Tabular Figures
-- Slashed Zero
-- Numerators
-- Denominators
-- Fractions
-- Superscript
-- Subscript
-- Scientific Inferiors
-- Ordinals
-- Case-Sensitive Forms
-- Localized Forms
-- Mathematical Greek
-- Capital Spacing
+Fira has been installed in %%WWWDIR%%
+
+Get started right away with the provided boilerplate HTML and CSS.
+
+Fira has advanced Open Type typographic layout features and language support.
+Please refer to the Technical Documentation installed by this port or online at
+
+ http://dev.carrois.com/fira-3-1/
For details about OpenType Layout Features see the OpenType Layout tag registry
@@ -45,10 +19,10 @@ or
http://en.wikipedia.org/wiki/List_of_typographic_features
The font-feature-settings CSS property allows control over advanced typographic
-features in OpenType fonts:
+features in OpenType fonts
https://developer.mozilla.org/en-US/docs/Web/CSS/font-feature-settings
-For X11 Open Type and True Type font please use x11-fonts/fira port.
+For X11 Open Type font please use x11-fonts/fira port.
===============================================================================
diff --git a/www/fira-webfont/pkg-descr b/www/fira-webfont/pkg-descr
index 22503adaaace..40be2a9bf18f 100644
--- a/www/fira-webfont/pkg-descr
+++ b/www/fira-webfont/pkg-descr
@@ -1,9 +1,10 @@
-The Fira font family was designed to cover the legibility needs for a
-large range of handsets varying in screen quality and rendering. It
-comes in a Sans Serif with 4 weights (light, regular, medium and bold)
-all accompanied by italic styles. The package also includes a Mono
-Spaced variant with 2 weights (regular and bold).
+The Fira font family was designed to cover the legibility needs for a large
+range of handsets varying in screen quality and rendering. It comes in a
+Sans Serif with 16 weights all accompanied by italic styles. The package also
+includes a Mono Spaced variant with 3 weights (regular, medium and bold). The
+UFO source files are included in examples.
-Web Font: EOT, WOFF, TTF, and example HTML+CSS
+Web Font: EOT, WOFF, TTF, and boilerplate HTML+CSS
+*supports advanced Open Type typographic layout features and languages
-WWW: http://mozilla.github.io/Fira/
+WWW: http://dev.carrois.com/fira-3-1/
diff --git a/www/fira-webfont/pkg-plist b/www/fira-webfont/pkg-plist
index 15ba52b115dd..5616ec97dac3 100644
--- a/www/fira-webfont/pkg-plist
+++ b/www/fira-webfont/pkg-plist
@@ -1,53 +1,111 @@
%%WWWDIR_REL%%/eot/FiraMono-Bold.eot
+%%WWWDIR_REL%%/eot/FiraMono-Medium.eot
%%WWWDIR_REL%%/eot/FiraMono-Regular.eot
%%WWWDIR_REL%%/eot/FiraSans-Bold.eot
%%WWWDIR_REL%%/eot/FiraSans-BoldItalic.eot
+%%WWWDIR_REL%%/eot/FiraSans-Book.eot
+%%WWWDIR_REL%%/eot/FiraSans-BookItalic.eot
+%%WWWDIR_REL%%/eot/FiraSans-Eight.eot
+%%WWWDIR_REL%%/eot/FiraSans-EightItalic.eot
+%%WWWDIR_REL%%/eot/FiraSans-ExtraBold.eot
+%%WWWDIR_REL%%/eot/FiraSans-ExtraBoldItalic.eot
+%%WWWDIR_REL%%/eot/FiraSans-ExtraLight.eot
+%%WWWDIR_REL%%/eot/FiraSans-ExtraLightItalic.eot
+%%WWWDIR_REL%%/eot/FiraSans-Four.eot
+%%WWWDIR_REL%%/eot/FiraSans-FourItalic.eot
+%%WWWDIR_REL%%/eot/FiraSans-Hair.eot
+%%WWWDIR_REL%%/eot/FiraSans-HairItalic.eot
+%%WWWDIR_REL%%/eot/FiraSans-Heavy.eot
+%%WWWDIR_REL%%/eot/FiraSans-HeavyItalic.eot
+%%WWWDIR_REL%%/eot/FiraSans-Italic.eot
%%WWWDIR_REL%%/eot/FiraSans-Light.eot
%%WWWDIR_REL%%/eot/FiraSans-LightItalic.eot
%%WWWDIR_REL%%/eot/FiraSans-Medium.eot
%%WWWDIR_REL%%/eot/FiraSans-MediumItalic.eot
%%WWWDIR_REL%%/eot/FiraSans-Regular.eot
-%%WWWDIR_REL%%/eot/FiraSans-RegularItalic.eot
-%%WWWDIR_REL%%/eot/FiraSansSC-Bold.eot
-%%WWWDIR_REL%%/eot/FiraSansSC-BoldItalic.eot
-%%WWWDIR_REL%%/eot/FiraSansSC-Light.eot
-%%WWWDIR_REL%%/eot/FiraSansSC-LightItalic.eot
-%%WWWDIR_REL%%/eot/FiraSansSC-Medium.eot
-%%WWWDIR_REL%%/eot/FiraSansSC-MediumItalic.eot
-%%WWWDIR_REL%%/eot/FiraSansSC-Regular.eot
-%%WWWDIR_REL%%/eot/FiraSansSC-RegularItalic.eot
+%%WWWDIR_REL%%/eot/FiraSans-SemiBold.eot
+%%WWWDIR_REL%%/eot/FiraSans-SemiBoldItalic.eot
+%%WWWDIR_REL%%/eot/FiraSans-Thin.eot
+%%WWWDIR_REL%%/eot/FiraSans-ThinItalic.eot
+%%WWWDIR_REL%%/eot/FiraSans-Two.eot
+%%WWWDIR_REL%%/eot/FiraSans-TwoItalic.eot
+%%WWWDIR_REL%%/eot/FiraSans-Ultra.eot
+%%WWWDIR_REL%%/eot/FiraSans-UltraItalic.eot
+%%WWWDIR_REL%%/eot/FiraSans-UltraLight.eot
+%%WWWDIR_REL%%/eot/FiraSans-UltraLightItalic.eot
%%WWWDIR_REL%%/fira.css
%%WWWDIR_REL%%/index.html
%%WWWDIR_REL%%/ttf/FiraMono-Bold.ttf
+%%WWWDIR_REL%%/ttf/FiraMono-Medium.ttf
%%WWWDIR_REL%%/ttf/FiraMono-Regular.ttf
%%WWWDIR_REL%%/ttf/FiraSans-Bold.ttf
%%WWWDIR_REL%%/ttf/FiraSans-BoldItalic.ttf
+%%WWWDIR_REL%%/ttf/FiraSans-Book.ttf
+%%WWWDIR_REL%%/ttf/FiraSans-BookItalic.ttf
+%%WWWDIR_REL%%/ttf/FiraSans-Eight.ttf
+%%WWWDIR_REL%%/ttf/FiraSans-EightItalic.ttf
+%%WWWDIR_REL%%/ttf/FiraSans-ExtraBold.ttf
+%%WWWDIR_REL%%/ttf/FiraSans-ExtraBoldItalic.ttf
+%%WWWDIR_REL%%/ttf/FiraSans-ExtraLight.ttf
+%%WWWDIR_REL%%/ttf/FiraSans-ExtraLightItalic.ttf
+%%WWWDIR_REL%%/ttf/FiraSans-Four.ttf
+%%WWWDIR_REL%%/ttf/FiraSans-FourItalic.ttf
+%%WWWDIR_REL%%/ttf/FiraSans-Hair.ttf
+%%WWWDIR_REL%%/ttf/FiraSans-HairItalic.ttf
+%%WWWDIR_REL%%/ttf/FiraSans-Heavy.ttf
+%%WWWDIR_REL%%/ttf/FiraSans-HeavyItalic.ttf
+%%WWWDIR_REL%%/ttf/FiraSans-Italic.ttf
%%WWWDIR_REL%%/ttf/FiraSans-Light.ttf
%%WWWDIR_REL%%/ttf/FiraSans-LightItalic.ttf
%%WWWDIR_REL%%/ttf/FiraSans-Medium.ttf
%%WWWDIR_REL%%/ttf/FiraSans-MediumItalic.ttf
%%WWWDIR_REL%%/ttf/FiraSans-Regular.ttf
-%%WWWDIR_REL%%/ttf/FiraSans-RegularItalic.ttf
+%%WWWDIR_REL%%/ttf/FiraSans-SemiBold.ttf
+%%WWWDIR_REL%%/ttf/FiraSans-SemiBoldItalic.ttf
+%%WWWDIR_REL%%/ttf/FiraSans-Thin.ttf
+%%WWWDIR_REL%%/ttf/FiraSans-ThinItalic.ttf
+%%WWWDIR_REL%%/ttf/FiraSans-Two.ttf
+%%WWWDIR_REL%%/ttf/FiraSans-TwoItalic.ttf
+%%WWWDIR_REL%%/ttf/FiraSans-Ultra.ttf
+%%WWWDIR_REL%%/ttf/FiraSans-UltraItalic.ttf
+%%WWWDIR_REL%%/ttf/FiraSans-UltraLight.ttf
+%%WWWDIR_REL%%/ttf/FiraSans-UltraLightItalic.ttf
%%WWWDIR_REL%%/woff/FiraMono-Bold.woff
+%%WWWDIR_REL%%/woff/FiraMono-Medium.woff
%%WWWDIR_REL%%/woff/FiraMono-Regular.woff
%%WWWDIR_REL%%/woff/FiraSans-Bold.woff
%%WWWDIR_REL%%/woff/FiraSans-BoldItalic.woff
+%%WWWDIR_REL%%/woff/FiraSans-Book.woff
+%%WWWDIR_REL%%/woff/FiraSans-BookItalic.woff
+%%WWWDIR_REL%%/woff/FiraSans-Eight.woff
+%%WWWDIR_REL%%/woff/FiraSans-EightItalic.woff
+%%WWWDIR_REL%%/woff/FiraSans-ExtraBold.woff
+%%WWWDIR_REL%%/woff/FiraSans-ExtraBoldItalic.woff
+%%WWWDIR_REL%%/woff/FiraSans-ExtraLight.woff
+%%WWWDIR_REL%%/woff/FiraSans-ExtraLightItalic.woff
+%%WWWDIR_REL%%/woff/FiraSans-Four.woff
+%%WWWDIR_REL%%/woff/FiraSans-FourItalic.woff
+%%WWWDIR_REL%%/woff/FiraSans-Hair.woff
+%%WWWDIR_REL%%/woff/FiraSans-HairItalic.woff
+%%WWWDIR_REL%%/woff/FiraSans-Heavy.woff
+%%WWWDIR_REL%%/woff/FiraSans-HeavyItalic.woff
+%%WWWDIR_REL%%/woff/FiraSans-Italic.woff
%%WWWDIR_REL%%/woff/FiraSans-Light.woff
%%WWWDIR_REL%%/woff/FiraSans-LightItalic.woff
%%WWWDIR_REL%%/woff/FiraSans-Medium.woff
%%WWWDIR_REL%%/woff/FiraSans-MediumItalic.woff
%%WWWDIR_REL%%/woff/FiraSans-Regular.woff
-%%WWWDIR_REL%%/woff/FiraSans-RegularItalic.woff
-%%WWWDIR_REL%%/woff/FiraSansOT-Light.woff
-%%WWWDIR_REL%%/woff/FiraSansSC-Bold.woff
-%%WWWDIR_REL%%/woff/FiraSansSC-BoldItalic.woff
-%%WWWDIR_REL%%/woff/FiraSansSC-Light.woff
-%%WWWDIR_REL%%/woff/FiraSansSC-LightItalic.woff
-%%WWWDIR_REL%%/woff/FiraSansSC-Medium.woff
-%%WWWDIR_REL%%/woff/FiraSansSC-MediumItalic.woff
-%%WWWDIR_REL%%/woff/FiraSansSC-Regular.woff
-%%WWWDIR_REL%%/woff/FiraSansSC-RegularItalic.woff
-@dirrm %%WWWDIR_REL%%/woff
-@dirrm %%WWWDIR_REL%%/ttf
+%%WWWDIR_REL%%/woff/FiraSans-SemiBold.woff
+%%WWWDIR_REL%%/woff/FiraSans-SemiBoldItalic.woff
+%%WWWDIR_REL%%/woff/FiraSans-Thin.woff
+%%WWWDIR_REL%%/woff/FiraSans-ThinItalic.woff
+%%WWWDIR_REL%%/woff/FiraSans-Two.woff
+%%WWWDIR_REL%%/woff/FiraSans-TwoItalic.woff
+%%WWWDIR_REL%%/woff/FiraSans-Ultra.woff
+%%WWWDIR_REL%%/woff/FiraSans-UltraItalic.woff
+%%WWWDIR_REL%%/woff/FiraSans-UltraLight.woff
+%%WWWDIR_REL%%/woff/FiraSans-UltraLightItalic.woff
@dirrm %%WWWDIR_REL%%/eot
+@dirrm %%WWWDIR_REL%%/ttf
+@dirrm %%WWWDIR_REL%%/woff
@dirrm %%WWWDIR_REL%%