aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorkuriyama <kuriyama@FreeBSD.org>2010-04-02 12:52:05 +0800
committerkuriyama <kuriyama@FreeBSD.org>2010-04-02 12:52:05 +0800
commitd57b83bb3e1439e4d6ed03129bbae4dccb9f505c (patch)
tree5fa16ec5796065c1fca1cb2929793349f6129dcb /www
parent88cce94abc15db5c4eb8bb865ca3c90013d06aa4 (diff)
downloadfreebsd-ports-gnome-d57b83bb3e1439e4d6ed03129bbae4dccb9f505c.tar.gz
freebsd-ports-gnome-d57b83bb3e1439e4d6ed03129bbae4dccb9f505c.tar.zst
freebsd-ports-gnome-d57b83bb3e1439e4d6ed03129bbae4dccb9f505c.zip
Net::FastCGI module.
WWW: http://search.cpan.org/dist/Net-FastCGI/
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-Net-FastCGI/Makefile23
-rw-r--r--www/p5-Net-FastCGI/distinfo3
-rw-r--r--www/p5-Net-FastCGI/pkg-descr3
-rw-r--r--www/p5-Net-FastCGI/pkg-plist13
5 files changed, 43 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 71ab7466ec33..333c3801915b 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1056,6 +1056,7 @@
SUBDIR += p5-MojoMojo
SUBDIR += p5-Net-Akismet
SUBDIR += p5-Net-Amazon-AWIS
+ SUBDIR += p5-Net-FastCGI
SUBDIR += p5-Net-FireEagle
SUBDIR += p5-Net-Flickr-API
SUBDIR += p5-Net-Flickr-Backup
diff --git a/www/p5-Net-FastCGI/Makefile b/www/p5-Net-FastCGI/Makefile
new file mode 100644
index 000000000000..d71fcea64cc8
--- /dev/null
+++ b/www/p5-Net-FastCGI/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: Net::FastCGI
+# Date created: 02 Apr 2010
+# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-FastCGI
+PORTVERSION= 0.09
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kuriyama@FreeBSD.org
+COMMENT= Perl extension for FastCGI
+
+PERL_CONFIGURE= yes
+
+MAN3= Net::FastCGI.3 \
+ Net::FastCGI::Constant.3 \
+ Net::FastCGI::Protocol.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-Net-FastCGI/distinfo b/www/p5-Net-FastCGI/distinfo
new file mode 100644
index 000000000000..45340cb1000b
--- /dev/null
+++ b/www/p5-Net-FastCGI/distinfo
@@ -0,0 +1,3 @@
+MD5 (Net-FastCGI-0.09.tar.gz) = 23d0ca90f6aacac66df2a226c968df5f
+SHA256 (Net-FastCGI-0.09.tar.gz) = aa7844fb627d0bbf9e16faafcf383376ccffb874434a404169d3a94495432bf8
+SIZE (Net-FastCGI-0.09.tar.gz) = 31308
diff --git a/www/p5-Net-FastCGI/pkg-descr b/www/p5-Net-FastCGI/pkg-descr
new file mode 100644
index 000000000000..09ea72ba0e87
--- /dev/null
+++ b/www/p5-Net-FastCGI/pkg-descr
@@ -0,0 +1,3 @@
+Net::FastCGI module.
+
+WWW: http://search.cpan.org/dist/Net-FastCGI/
diff --git a/www/p5-Net-FastCGI/pkg-plist b/www/p5-Net-FastCGI/pkg-plist
new file mode 100644
index 000000000000..54e05c0fe1f4
--- /dev/null
+++ b/www/p5-Net-FastCGI/pkg-plist
@@ -0,0 +1,13 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/FastCGI/.packlist
+%%SITE_PERL%%/Net/FastCGI.pm
+%%SITE_PERL%%/Net/FastCGI.pod
+%%SITE_PERL%%/Net/FastCGI/Constant.pm
+%%SITE_PERL%%/Net/FastCGI/Constant.pod
+%%SITE_PERL%%/Net/FastCGI/Protocol.pm
+%%SITE_PERL%%/Net/FastCGI/Protocol.pod
+%%SITE_PERL%%/Net/FastCGI/Protocol/PP.pm
+@dirrmtry %%SITE_PERL%%/Net/FastCGI/Protocol
+@dirrmtry %%SITE_PERL%%/Net/FastCGI
+@dirrmtry %%SITE_PERL%%/Net
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/FastCGI
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net