aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorrm <rm@FreeBSD.org>2015-06-24 02:12:46 +0800
committerrm <rm@FreeBSD.org>2015-06-24 02:12:46 +0800
commitf3864e77eebbac60e290768f6e6175af4694c1e0 (patch)
tree1e9cef2d91c4702622b17edabba9291b6e0659b1 /www
parentdf562e943e96db5b6830047508bec0f83cb0ef98 (diff)
downloadfreebsd-ports-gnome-f3864e77eebbac60e290768f6e6175af4694c1e0.tar.gz
freebsd-ports-gnome-f3864e77eebbac60e290768f6e6175af4694c1e0.tar.zst
freebsd-ports-gnome-f3864e77eebbac60e290768f6e6175af4694c1e0.zip
www/py-funkload: update to 1.17.1
- update to 1.17.1 - remove bogus py-xml dependency - shorten COMMENT - limit python version to 2.x - update patch to setup.py to make it build (there is upstream issue [1]) [1] https://github.com/nuxeo/FunkLoad/issues/145 Approved by: lwhsu (maintainer, by email)
Diffstat (limited to 'www')
-rw-r--r--www/py-funkload/Makefile12
-rw-r--r--www/py-funkload/distinfo4
-rw-r--r--www/py-funkload/files/patch-setup.py32
3 files changed, 27 insertions, 21 deletions
diff --git a/www/py-funkload/Makefile b/www/py-funkload/Makefile
index 057b0aab6084..63c839aa2cf2 100644
--- a/www/py-funkload/Makefile
+++ b/www/py-funkload/Makefile
@@ -2,24 +2,22 @@
# $FreeBSD$
PORTNAME= funkload
-PORTVERSION= 1.16.1
-PORTREVISION= 1
+PORTVERSION= 1.17.1
CATEGORIES= www python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= lwhsu@FreeBSD.org
-COMMENT= FunkLoad is a functional and load web tester
+COMMENT= Functional and load web tester
LICENSE= GPLv2
-RUN_DEPENDS= ${PYTHON_SITELIBDIR}/docutils/__init__.py:${PORTSDIR}/textproc/py-docutils \
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}docutils>0:${PORTSDIR}/textproc/py-docutils \
${LOCALBASE}/bin/gnuplot:${PORTSDIR}/math/gnuplot \
${PYTHON_PKGNAMEPREFIX}webunit>=1.3.8:${PORTSDIR}/www/py-webunit \
- ${PYXML} \
tcpwatch.py:${PORTSDIR}/net/tcpwatch
-USES= python
-USE_PYTHON= distutils autoplist
+USES= python:2
+USE_PYTHON= autoplist distutils
.include <bsd.port.mk>
diff --git a/www/py-funkload/distinfo b/www/py-funkload/distinfo
index d4a80998bd10..21743912e754 100644
--- a/www/py-funkload/distinfo
+++ b/www/py-funkload/distinfo
@@ -1,2 +1,2 @@
-SHA256 (funkload-1.16.1.tar.gz) = e268a6209e3c225b1af7474031c10c3f92cd28ea8a1226facb5987cde026fb58
-SIZE (funkload-1.16.1.tar.gz) = 186031
+SHA256 (funkload-1.17.1.tar.gz) = f0518e9a306443cd03e573f80532bf4cbb014720c925403b6010a804783594da
+SIZE (funkload-1.17.1.tar.gz) = 107796
diff --git a/www/py-funkload/files/patch-setup.py b/www/py-funkload/files/patch-setup.py
index 39355c49489a..4d0f34d1c4c4 100644
--- a/www/py-funkload/files/patch-setup.py
+++ b/www/py-funkload/files/patch-setup.py
@@ -1,12 +1,20 @@
---- setup.py.orig 2010-01-30 02:16:39.051847143 +0800
-+++ setup.py 2010-01-30 02:16:50.065356904 +0800
-@@ -149,9 +149,6 @@
- 'Topic :: System :: Monitoring',
- ],
- # setuptools specific keywords
-- install_requires = ['webunit >= 1.3.8',
-- 'docutils >= 0.3.7',
-- 'setuptools'],
- zip_safe=True,
- package_data={'funkload': ['data/*',
- 'demo/simple/*', 'demo/zope/*',
+--- setup.py.orig 2015-05-06 10:37:24 UTC
++++ setup.py
+@@ -21,8 +21,6 @@
+ """FunkLoad package setup
+
+ """
+-import ez_setup
+-ez_setup.use_setuptools()
+ from setuptools import setup, find_packages
+ __version__ = '1.17.1'
+
+@@ -30,7 +28,7 @@ setup(
+ name="funkload",
+ version=__version__,
+ description="Functional and load web tester.",
+- long_description=''.join(open('README.txt').readlines()),
++ long_description='',
+ author="Benoit Delbosc",
+ author_email="bdelbosc@nuxeo.com",
+ url="http://funkload.nuxeo.org/",