aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorclsung <clsung@FreeBSD.org>2006-07-10 23:23:19 +0800
committerclsung <clsung@FreeBSD.org>2006-07-10 23:23:19 +0800
commit020c48c5aba4b6f98c3142b31017d455bf5e67a3 (patch)
treea5e4378a910e0fa5c9ff44973ec65ca7a87180d7 /www
parent1db1e903aae2502c8b3e14e8b144e14f48a7f5b7 (diff)
downloadfreebsd-ports-gnome-020c48c5aba4b6f98c3142b31017d455bf5e67a3.tar.gz
freebsd-ports-gnome-020c48c5aba4b6f98c3142b31017d455bf5e67a3.tar.zst
freebsd-ports-gnome-020c48c5aba4b6f98c3142b31017d455bf5e67a3.zip
Add p5-HTML-ResolveLink 0.02, resolve relative links in (X)HTML into
absolute URI. PR: ports/99977 Submitted by: Gea-Suan Lin <gslin at gslin.org>
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-HTML-ResolveLink/Makefile31
-rw-r--r--www/p5-HTML-ResolveLink/distinfo3
-rw-r--r--www/p5-HTML-ResolveLink/pkg-descr5
-rw-r--r--www/p5-HTML-ResolveLink/pkg-plist6
5 files changed, 46 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index aee62a13a060..2cd2cb2aaa53 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -598,6 +598,7 @@
SUBDIR += p5-HTML-PrettyPrinter
SUBDIR += p5-HTML-Prototype
SUBDIR += p5-HTML-QuickCheck
+ SUBDIR += p5-HTML-ResolveLink
SUBDIR += p5-HTML-Scrubber
SUBDIR += p5-HTML-SimpleLinkExtor
SUBDIR += p5-HTML-SimpleParse
diff --git a/www/p5-HTML-ResolveLink/Makefile b/www/p5-HTML-ResolveLink/Makefile
new file mode 100644
index 000000000000..572ae77124a5
--- /dev/null
+++ b/www/p5-HTML-ResolveLink/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: p5-HTML-ResolveLink
+# Date created: 2006-07-10
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= HTML-ResolveLink
+PORTVERSION= 0.02
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= HTML
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Resolve relative links in (X)HTML into absolute URI
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/HTML/Parser.pm:${PORTSDIR}/www/p5-HTML-Parser
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= HTML::ResolveLink.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600 # inherited from www/p5-HTML-Parser
+IGNORE= requires perl 5.6.0 or later. Install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/www/p5-HTML-ResolveLink/distinfo b/www/p5-HTML-ResolveLink/distinfo
new file mode 100644
index 000000000000..0f2c771903db
--- /dev/null
+++ b/www/p5-HTML-ResolveLink/distinfo
@@ -0,0 +1,3 @@
+MD5 (HTML-ResolveLink-0.02.tar.gz) = d4c4d139eaee72ee269d31d8a70ce9f4
+SHA256 (HTML-ResolveLink-0.02.tar.gz) = 51649165d434d0703cb01af6258dc5404968f62461735111c4f1556b6cd09e63
+SIZE (HTML-ResolveLink-0.02.tar.gz) = 2596
diff --git a/www/p5-HTML-ResolveLink/pkg-descr b/www/p5-HTML-ResolveLink/pkg-descr
new file mode 100644
index 000000000000..d527a468c941
--- /dev/null
+++ b/www/p5-HTML-ResolveLink/pkg-descr
@@ -0,0 +1,5 @@
+HTML::ResolveLink is a module to rewrite relative links in XHTML or
+HTML into absolute URI.
+
+Author: Tatsuhiko Miyagawa <miyagawa@bulknews.net>
+WWW: http://search.cpan.org/dist/HTML-ResolveLink/
diff --git a/www/p5-HTML-ResolveLink/pkg-plist b/www/p5-HTML-ResolveLink/pkg-plist
new file mode 100644
index 000000000000..9087067ce574
--- /dev/null
+++ b/www/p5-HTML-ResolveLink/pkg-plist
@@ -0,0 +1,6 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/HTML/ResolveLink/.packlist
+%%SITE_PERL%%/HTML/ResolveLink.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/HTML/ResolveLink
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/HTML
+@dirrmtry %%SITE_PERL%%/HTML