aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2016-09-24 19:06:57 +0800
committertijl <tijl@FreeBSD.org>2016-09-24 19:06:57 +0800
commit066998172e46dd08df392ecd35af710e3dd3da2a (patch)
treee47126c6c357762b62f9e5736c3d27d12948e676 /www
parent49712f6fc0b0b344ad61319c9fe1eefaae4bc422 (diff)
downloadfreebsd-ports-gnome-066998172e46dd08df392ecd35af710e3dd3da2a.tar.gz
freebsd-ports-gnome-066998172e46dd08df392ecd35af710e3dd3da2a.tar.zst
freebsd-ports-gnome-066998172e46dd08df392ecd35af710e3dd3da2a.zip
- Update devel/icu to 57.1.
- Clean up the Makefile. - Follow some upstream recommendations (--with-data-packaging=archive, --disable-renaming, -DICU_NO_USER_DATA_OVERRIDE). - Patch makefiles to install static libraries with INSTALL_DATA so they aren't stripped. - Patch config/mh-bsd-gcc to sync with config/mh-linux-gcc. - Fix endianness detection in ICU. The code wanted to use BYTE_ORDER defined in machine/endian.h, but this isn't visible because ICU is compiled with _XOPEN_SOURCE. Patch the code to use _BYTE_ORDER instead. - Compile ICU with C++11 compiler to enable move constructors. - Patch ICU to fix a problem with atomics in the case of a C++11 compiler without C++11 header <atomic> (like Clang on FreeBSD 9). - Bump all ports that depend on it due to library version change. - Add USES=compiler:c++0x to some ports that pick up -std=c++0x from ICU pkgconfig files. - Add USES=compiler:c++11-lib to graphics/libcdr01 because it also needs a C++11 runtime library now. Add this to all ports that depend on it so their executables load the right libstdc++.so on FreeBSD 9. PR: 205120 Exp-run by: antoine Approved by: portmgr (antoine)
Diffstat (limited to 'www')
-rw-r--r--www/chromium/Makefile1
-rw-r--r--www/cppcms/Makefile2
-rw-r--r--www/firefox-esr/Makefile2
-rw-r--r--www/firefox/Makefile2
-rw-r--r--www/libxul/Makefile2
-rw-r--r--www/node/Makefile1
-rw-r--r--www/node4/Makefile1
-rw-r--r--www/seamonkey/Makefile2
-rw-r--r--www/webkit-gtk2/Makefile2
-rw-r--r--www/webkit-gtk3/Makefile2
-rw-r--r--www/webkit-qt5/Makefile1
-rw-r--r--www/webkit2-gtk3/Makefile2
12 files changed, 12 insertions, 8 deletions
diff --git a/www/chromium/Makefile b/www/chromium/Makefile
index 13559a95cc2d..3e09e91f8afb 100644
--- a/www/chromium/Makefile
+++ b/www/chromium/Makefile
@@ -3,6 +3,7 @@
PORTNAME= chromium
PORTVERSION= 52.0.2743.116
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= http://commondatastorage.googleapis.com/chromium-browser-official/
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} # default, but needed to get distinfo correct if TEST is on
diff --git a/www/cppcms/Makefile b/www/cppcms/Makefile
index 66b06651c94a..7a7bc9a326aa 100644
--- a/www/cppcms/Makefile
+++ b/www/cppcms/Makefile
@@ -2,7 +2,7 @@
PORTNAME= cppcms
PORTVERSION= 1.0.5
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= www
MASTER_SITES= SF/cppcms/${PORTNAME}/${PORTVERSION}
diff --git a/www/firefox-esr/Makefile b/www/firefox-esr/Makefile
index 0c211d09823c..6326249fee9c 100644
--- a/www/firefox-esr/Makefile
+++ b/www/firefox-esr/Makefile
@@ -4,7 +4,7 @@
PORTNAME= firefox
DISTVERSION= 45.4.0
DISTVERSIONSUFFIX=esr.source
-PORTREVISION= 3
+PORTREVISION= 4
PORTEPOCH= 1
CATEGORIES= www ipv6
MASTER_SITES= MOZILLA/${PORTNAME}/releases/${DISTVERSION}esr/source \
diff --git a/www/firefox/Makefile b/www/firefox/Makefile
index ddc5b0dfdeeb..6322e97dde37 100644
--- a/www/firefox/Makefile
+++ b/www/firefox/Makefile
@@ -4,7 +4,7 @@
PORTNAME= firefox
DISTVERSION= 49.0
DISTVERSIONSUFFIX=.source
-PORTREVISION= 5
+PORTREVISION= 6
PORTEPOCH= 1
CATEGORIES= www ipv6
MASTER_SITES= MOZILLA/${PORTNAME}/releases/${DISTVERSION}/source \
diff --git a/www/libxul/Makefile b/www/libxul/Makefile
index a067620e0c0d..bef677e30d54 100644
--- a/www/libxul/Makefile
+++ b/www/libxul/Makefile
@@ -3,7 +3,7 @@
PORTNAME= libxul
DISTVERSION= 45.4.0
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES?= www devel
MASTER_SITES= MOZILLA/firefox/releases/${DISTVERSION}esr/source \
MOZILLA/firefox/candidates/${DISTVERSION}esr-candidates/build2/source
diff --git a/www/node/Makefile b/www/node/Makefile
index 2f323c378e6b..50c3f0677b9a 100644
--- a/www/node/Makefile
+++ b/www/node/Makefile
@@ -3,6 +3,7 @@
PORTNAME= node
PORTVERSION= 6.6.0
DISTVERSIONPREFIX= v
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= http://nodejs.org/dist/v${PORTVERSION}/
diff --git a/www/node4/Makefile b/www/node4/Makefile
index f8d78d277a45..279957ae2f49 100644
--- a/www/node4/Makefile
+++ b/www/node4/Makefile
@@ -4,6 +4,7 @@
PORTNAME= node
PORTVERSION= 4.5.0
DISTVERSIONPREFIX= v
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= http://nodejs.org/dist/v${PORTVERSION}/
PKGNAMESUFFIX= 4
diff --git a/www/seamonkey/Makefile b/www/seamonkey/Makefile
index c3c82b9d4504..4e6b2b69b270 100644
--- a/www/seamonkey/Makefile
+++ b/www/seamonkey/Makefile
@@ -4,7 +4,7 @@
PORTNAME= seamonkey
DISTVERSION= 2.39
MOZILLA_VER= 42 # above + 3
-PORTREVISION= 13
+PORTREVISION= 14
CATEGORIES?= www mail news editors irc ipv6
MASTER_SITES= MOZILLA/${PORTNAME}/releases/${DISTVERSION}/source \
MOZILLA/${PORTNAME}/candidates/${DISTVERSION}-candidates/build1/source
diff --git a/www/webkit-gtk2/Makefile b/www/webkit-gtk2/Makefile
index f1e45f6439ef..c828c0707911 100644
--- a/www/webkit-gtk2/Makefile
+++ b/www/webkit-gtk2/Makefile
@@ -3,7 +3,7 @@
PORTNAME= webkit
PORTVERSION= 2.4.11
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= www
MASTER_SITES= http://webkitgtk.org/releases/
PKGNAMESUFFIX= -gtk2
diff --git a/www/webkit-gtk3/Makefile b/www/webkit-gtk3/Makefile
index 286ece863515..36d615d82e9c 100644
--- a/www/webkit-gtk3/Makefile
+++ b/www/webkit-gtk3/Makefile
@@ -3,7 +3,7 @@
PORTNAME= webkit
PORTVERSION= 2.4.11
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= www
MASTER_SITES= http://webkitgtk.org/releases/
PKGNAMESUFFIX= -gtk3
diff --git a/www/webkit-qt5/Makefile b/www/webkit-qt5/Makefile
index 3255fe1f98b6..d005f2a3ca27 100644
--- a/www/webkit-qt5/Makefile
+++ b/www/webkit-qt5/Makefile
@@ -2,6 +2,7 @@
PORTNAME= webkit
DISTVERSION= ${QT5_VERSION}
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITE_SUBDIR= community_releases/${QT5_VERSION:R}/${QT5_VERSION}/
PKGNAMEPREFIX= qt5-
diff --git a/www/webkit2-gtk3/Makefile b/www/webkit2-gtk3/Makefile
index 6f224f1c38ed..2c2695244e24 100644
--- a/www/webkit2-gtk3/Makefile
+++ b/www/webkit2-gtk3/Makefile
@@ -3,7 +3,7 @@
PORTNAME= webkit
PORTVERSION= 2.8.5
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= www
MASTER_SITES= http://webkitgtk.org/releases/
PKGNAMESUFFIX= 2-gtk3