aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2007-08-08 10:17:28 +0800
committerijliao <ijliao@FreeBSD.org>2007-08-08 10:17:28 +0800
commit0b8891c5f89ce952de5952c6a557c8a2abb29cd4 (patch)
treed6d9b8af9f6eadceb1b7f91de776b70dd3925ed6 /www
parent2dc6225a76f7b60e387aa2ce4f24124e4dcef434 (diff)
downloadfreebsd-ports-gnome-0b8891c5f89ce952de5952c6a557c8a2abb29cd4.tar.gz
freebsd-ports-gnome-0b8891c5f89ce952de5952c6a557c8a2abb29cd4.tar.zst
freebsd-ports-gnome-0b8891c5f89ce952de5952c6a557c8a2abb29cd4.zip
add py-html5lib 0.9
A Python based HTML parser based on the HTML5 spec
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/py-html5lib/Makefile23
-rw-r--r--www/py-html5lib/distinfo3
-rw-r--r--www/py-html5lib/pkg-descr9
-rw-r--r--www/py-html5lib/pkg-plist41
5 files changed, 77 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index d17467517268..a22d63b5d1c6 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1009,6 +1009,7 @@
SUBDIR += py-forgethtml
SUBDIR += py-formencode
SUBDIR += py-funkload
+ SUBDIR += py-html5lib
SUBDIR += py-httplib2
SUBDIR += py-imdbpy
SUBDIR += py-jonpy
diff --git a/www/py-html5lib/Makefile b/www/py-html5lib/Makefile
new file mode 100644
index 000000000000..6b0b4532fb57
--- /dev/null
+++ b/www/py-html5lib/Makefile
@@ -0,0 +1,23 @@
+# ex:ts=8
+# Ports collection makefile for: html5lib
+# Date created: Aug 8, 2007
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= html5lib
+PORTVERSION= 0.9
+CATEGORIES= www python
+MASTER_SITES= http://${PORTNAME}.googlecode.com/files/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= ijliao@FreeBSD.org
+COMMENT= A Python based HTML parser based on the HTML5 spec
+
+USE_ZIP= yes
+NO_WRKSUBDIR= yes
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+
+.include <bsd.port.mk>
diff --git a/www/py-html5lib/distinfo b/www/py-html5lib/distinfo
new file mode 100644
index 000000000000..9035f3717329
--- /dev/null
+++ b/www/py-html5lib/distinfo
@@ -0,0 +1,3 @@
+MD5 (html5lib-0.9.zip) = 8572c4f16491a7ee6f5e00c5e5fa83fd
+SHA256 (html5lib-0.9.zip) = c15bcd4ef248cbe7068f8d87eb0c1ae8207f615b3c666e29250a409d72ce4af4
+SIZE (html5lib-0.9.zip) = 330354
diff --git a/www/py-html5lib/pkg-descr b/www/py-html5lib/pkg-descr
new file mode 100644
index 000000000000..5f37548dcc05
--- /dev/null
+++ b/www/py-html5lib/pkg-descr
@@ -0,0 +1,9 @@
+HTML parser designed to follow the WHATWG HTML5 specification. The parser is
+designed to handle all flavours of HTML and parses invalid documents using
+well-defined error handling rules compatible with the behaviour of major
+desktop web browsers.
+
+Output is to a tree structure; the current release supports output to a custom
+tree similar to DOM and to ElementTree.
+
+WWW: http://code.google.com/p/html5lib/
diff --git a/www/py-html5lib/pkg-plist b/www/py-html5lib/pkg-plist
new file mode 100644
index 000000000000..7becacc9c568
--- /dev/null
+++ b/www/py-html5lib/pkg-plist
@@ -0,0 +1,41 @@
+%%PYTHON_SITELIBDIR%%/html5lib/__init__.py
+%%PYTHON_SITELIBDIR%%/html5lib/__init__.pyc
+%%PYTHON_SITELIBDIR%%/html5lib/__init__.pyo
+%%PYTHON_SITELIBDIR%%/html5lib/constants.py
+%%PYTHON_SITELIBDIR%%/html5lib/constants.pyc
+%%PYTHON_SITELIBDIR%%/html5lib/constants.pyo
+%%PYTHON_SITELIBDIR%%/html5lib/html5parser.py
+%%PYTHON_SITELIBDIR%%/html5lib/html5parser.pyc
+%%PYTHON_SITELIBDIR%%/html5lib/html5parser.pyo
+%%PYTHON_SITELIBDIR%%/html5lib/inputstream.py
+%%PYTHON_SITELIBDIR%%/html5lib/inputstream.pyc
+%%PYTHON_SITELIBDIR%%/html5lib/inputstream.pyo
+%%PYTHON_SITELIBDIR%%/html5lib/liberalxmlparser.py
+%%PYTHON_SITELIBDIR%%/html5lib/liberalxmlparser.pyc
+%%PYTHON_SITELIBDIR%%/html5lib/liberalxmlparser.pyo
+%%PYTHON_SITELIBDIR%%/html5lib/tokenizer.py
+%%PYTHON_SITELIBDIR%%/html5lib/tokenizer.pyc
+%%PYTHON_SITELIBDIR%%/html5lib/tokenizer.pyo
+%%PYTHON_SITELIBDIR%%/html5lib/treebuilders/__init__.py
+%%PYTHON_SITELIBDIR%%/html5lib/treebuilders/__init__.pyc
+%%PYTHON_SITELIBDIR%%/html5lib/treebuilders/__init__.pyo
+%%PYTHON_SITELIBDIR%%/html5lib/treebuilders/_base.py
+%%PYTHON_SITELIBDIR%%/html5lib/treebuilders/_base.pyc
+%%PYTHON_SITELIBDIR%%/html5lib/treebuilders/_base.pyo
+%%PYTHON_SITELIBDIR%%/html5lib/treebuilders/dom.py
+%%PYTHON_SITELIBDIR%%/html5lib/treebuilders/dom.pyc
+%%PYTHON_SITELIBDIR%%/html5lib/treebuilders/dom.pyo
+%%PYTHON_SITELIBDIR%%/html5lib/treebuilders/etree.py
+%%PYTHON_SITELIBDIR%%/html5lib/treebuilders/etree.pyc
+%%PYTHON_SITELIBDIR%%/html5lib/treebuilders/etree.pyo
+%%PYTHON_SITELIBDIR%%/html5lib/treebuilders/etreefull.py
+%%PYTHON_SITELIBDIR%%/html5lib/treebuilders/etreefull.pyc
+%%PYTHON_SITELIBDIR%%/html5lib/treebuilders/etreefull.pyo
+%%PYTHON_SITELIBDIR%%/html5lib/treebuilders/simpletree.py
+%%PYTHON_SITELIBDIR%%/html5lib/treebuilders/simpletree.pyc
+%%PYTHON_SITELIBDIR%%/html5lib/treebuilders/simpletree.pyo
+%%PYTHON_SITELIBDIR%%/html5lib/utils.py
+%%PYTHON_SITELIBDIR%%/html5lib/utils.pyc
+%%PYTHON_SITELIBDIR%%/html5lib/utils.pyo
+@dirrm %%PYTHON_SITELIBDIR%%/html5lib/treebuilders
+@dirrm %%PYTHON_SITELIBDIR%%/html5lib