aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2003-12-08 13:39:35 +0800
committerijliao <ijliao@FreeBSD.org>2003-12-08 13:39:35 +0800
commit0c139ab470027f5c0335e16f8d8254f3ad08659f (patch)
treee2a71399f4487d5d86c00976b384b0e0f2c45dbb /www
parentcbb49e5c0e5869863cf69126b6fbb288ad6e40d9 (diff)
downloadfreebsd-ports-gnome-0c139ab470027f5c0335e16f8d8254f3ad08659f.tar.gz
freebsd-ports-gnome-0c139ab470027f5c0335e16f8d8254f3ad08659f.tar.zst
freebsd-ports-gnome-0c139ab470027f5c0335e16f8d8254f3ad08659f.zip
add py-mt 1.0
A Python module which provides Movable Type XML-RPC connectivity
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/py-mt/Makefile26
-rw-r--r--www/py-mt/distinfo1
-rw-r--r--www/py-mt/pkg-descr12
-rw-r--r--www/py-mt/pkg-plist1
5 files changed, 41 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index e9797980ca9a..e9988abf2067 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -461,6 +461,7 @@
SUBDIR += py-HTMLgen
SUBDIR += py-albatross
SUBDIR += py-fcgi
+ SUBDIR += py-mt
SUBDIR += py-scgi
SUBDIR += py-websvcs
SUBDIR += pyweblib
diff --git a/www/py-mt/Makefile b/www/py-mt/Makefile
new file mode 100644
index 000000000000..a37b05a9f637
--- /dev/null
+++ b/www/py-mt/Makefile
@@ -0,0 +1,26 @@
+# ex:ts=8
+# Ports collection makefile for: PyMT
+# Date created: Dec 8, 2003
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= mt
+PORTVERSION= 1.0
+CATEGORIES= www python
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= pymt
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= PyMT-${PORTVERSION}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= A Python module which provides Movable Type XML-RPC connectivity
+
+USE_PYTHON= yes
+NO_BUILD= yes
+
+do-install:
+ @${INSTALL_DATA} ${WRKSRC}/PyMT.py ${PYTHON_SITELIBDIR}
+
+.include <bsd.port.mk>
diff --git a/www/py-mt/distinfo b/www/py-mt/distinfo
new file mode 100644
index 000000000000..24693be9734d
--- /dev/null
+++ b/www/py-mt/distinfo
@@ -0,0 +1 @@
+MD5 (PyMT-1.0.tar.gz) = 9f3bf3c2f5b70c52a02f5a849c134b6e
diff --git a/www/py-mt/pkg-descr b/www/py-mt/pkg-descr
new file mode 100644
index 000000000000..be752fa83ac6
--- /dev/null
+++ b/www/py-mt/pkg-descr
@@ -0,0 +1,12 @@
+PyMT is a simple Python module which allows you to easily connect to a Movable
+Type weblog, using it's built in XML-RPC API. PyMT is capable of handling every
+MT call available.
+
+This interface allows you to access most of the core functionality of Movable
+Type, including the ability to view, post, delete and edit weblog entries,
+fetch user information, apply categories to your posts and get information
+about trackback pings. Every XML-RPC method is accessed using a PyMT method
+with exactly the same name. PyMT is basically just a light wrapper, which
+hides the xml-rpc part of the work.
+
+WWW: http://pymt.sourceforge.net/
diff --git a/www/py-mt/pkg-plist b/www/py-mt/pkg-plist
new file mode 100644
index 000000000000..dd6a4e60a05b
--- /dev/null
+++ b/www/py-mt/pkg-plist
@@ -0,0 +1 @@
+%%PYTHON_SITELIBDIR%%/PyMT.py