aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2018-02-19 22:01:41 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2018-02-19 22:01:41 +0800
commit27c63cb5e57dc272aba6e669d90c20cc5ab22b3a (patch)
treef6b80cf70664c939dd4ccf1368d6d5352754ef10 /www
parentb426f3c4aef7b8080c33f1f358d987e3d1f26f7e (diff)
downloadfreebsd-ports-gnome-27c63cb5e57dc272aba6e669d90c20cc5ab22b3a.tar.gz
freebsd-ports-gnome-27c63cb5e57dc272aba6e669d90c20cc5ab22b3a.tar.zst
freebsd-ports-gnome-27c63cb5e57dc272aba6e669d90c20cc5ab22b3a.zip
Fix bunch of ports by TundraWare, which share a common set of problems
- Add LICENSE It explicitly requires user agreement (thus no-auto-accept) and forbids distribution for a fee `beyond reasonable duplication charges` which is too vague I don't think can be guaranteed in any case (thus no-*-sell) tdir port uses another variant of license, which also forbids modification, and since the port requires shebangfix and Makefile patching, also mark it no-pkg-mirror and BROKEN. - Don't install licenses with documentation, since our license framework already handles this - Fix python shebangs - Limit python version to 2.7, as no port is compatible with python3 - Add NO_ARCH - User options targets helpers - Simplify installation in a few cases Approved by: portmgr blanket
Diffstat (limited to 'www')
-rw-r--r--www/mkapachepw/Makefile10
-rw-r--r--www/mkapachepw/pkg-plist1
-rw-r--r--www/waccess/Makefile12
-rw-r--r--www/waccess/pkg-plist1
4 files changed, 15 insertions, 9 deletions
diff --git a/www/mkapachepw/Makefile b/www/mkapachepw/Makefile
index e7286bf97425..6ded65b7ec38 100644
--- a/www/mkapachepw/Makefile
+++ b/www/mkapachepw/Makefile
@@ -3,23 +3,27 @@
PORTNAME= mkapachepw
PORTVERSION= 1.121
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www
MASTER_SITES= http://www.tundraware.com/Software/mkapachepw/
MAINTAINER= mkapachepw@tundraware.com
COMMENT= Group & Password Management Tool For Apache
+LICENSE= TundraWare
+LICENSE_NAME= TundraWare license
+LICENSE_FILE= ${WRKSRC}/mkapachepw-license.txt
+LICENSE_PERMS= dist-mirror no-dist-sell pkg-mirror no-pkg-sell no-auto-accept
+
USES= python:2.7,run shebangfix
SHEBANG_FILES= mkapachepw.py
-NO_BUILD= yes
NO_ARCH= yes
OPTIONS_DEFINE= DOCS
post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
-.for f in WHATSNEW.txt mkapachepw-license.txt mkapachepw.html mkapachepw.pdf mkapachepw.ps mkapachepw.txt
+.for f in WHATSNEW.txt mkapachepw.html mkapachepw.pdf mkapachepw.ps mkapachepw.txt
${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}
.endfor
diff --git a/www/mkapachepw/pkg-plist b/www/mkapachepw/pkg-plist
index 70e2ae64f757..fdfcabc6e706 100644
--- a/www/mkapachepw/pkg-plist
+++ b/www/mkapachepw/pkg-plist
@@ -1,7 +1,6 @@
bin/mkapachepw.py
man/man1/mkapachepw.1.gz
%%PORTDOCS%%%%DOCSDIR%%/WHATSNEW.txt
-%%PORTDOCS%%%%DOCSDIR%%/mkapachepw-license.txt
%%PORTDOCS%%%%DOCSDIR%%/mkapachepw.html
%%PORTDOCS%%%%DOCSDIR%%/mkapachepw.pdf
%%PORTDOCS%%%%DOCSDIR%%/mkapachepw.ps
diff --git a/www/waccess/Makefile b/www/waccess/Makefile
index f922526b8094..0fb4d68024fd 100644
--- a/www/waccess/Makefile
+++ b/www/waccess/Makefile
@@ -3,20 +3,24 @@
PORTNAME= waccess
PORTVERSION= 2.0
+PORTREVISION= 1
CATEGORIES= www textproc
MASTER_SITES= http://www.tundraware.com/Software/waccess/
MAINTAINER= tundra@tundraware.com
COMMENT= Quick-N-Dirty Web Access Log Analyzer
-USES= python
+LICENSE= TundraWare
+LICENSE_NAME= TundraWare license
+LICENSE_FILE= ${WRKSRC}/waccess-license.txt
+LICENSE_PERMS= dist-mirror no-dist-sell pkg-mirror no-pkg-sell no-auto-accept
-OPTIONS_DEFINE= DOCS
+USES= python:2.7,run shebangfix
+SHEBANG_FILES= waccess
+NO_ARCH= yes
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/waccess ${STAGEDIR}${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/waccess.1.gz ${STAGEDIR}${PREFIX}/man/man1
- @${MKDIR} ${STAGEDIR}${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/waccess-license.txt ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
diff --git a/www/waccess/pkg-plist b/www/waccess/pkg-plist
index 65f5178fb774..0af53bb090e2 100644
--- a/www/waccess/pkg-plist
+++ b/www/waccess/pkg-plist
@@ -1,3 +1,2 @@
bin/waccess
man/man1/waccess.1.gz
-%%PORTDOCS%%%%DOCSDIR%%/waccess-license.txt