aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorrm <rm@FreeBSD.org>2012-07-26 00:58:19 +0800
committerrm <rm@FreeBSD.org>2012-07-26 00:58:19 +0800
commit2d0a8dff2b3161153f2befe2522522bf2e877b54 (patch)
treef9582bdbf0f38efaf18775abf0df5ca17b3d5a8e /www
parent279f3389cfad6cf0f47d6305f13a01a71d318bd4 (diff)
downloadfreebsd-ports-gnome-2d0a8dff2b3161153f2befe2522522bf2e877b54.tar.gz
freebsd-ports-gnome-2d0a8dff2b3161153f2befe2522522bf2e877b54.tar.zst
freebsd-ports-gnome-2d0a8dff2b3161153f2befe2522522bf2e877b54.zip
- copy py-beautyfulsoup 3.2.0 to py-beautyfulsoup32
- update py-beautyfulsoup to current stable branch (4.1.1) - pass maintainership of this new port to submitter - set USE_PYTHON to 2.7, because it doesn't packages with python3 (port modification needed) - chase dependency update to deskutils/calibre - add UPDATING entry PR: 168372 (based on) Submitted by: William Grzybowski <william88 at gmail dot com> Approved by: Mike Meyer <mwm at mired dot org> (maintainer)
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/py-beautifulsoup/Makefile18
-rw-r--r--www/py-beautifulsoup/distinfo4
-rw-r--r--www/py-beautifulsoup/pkg-plist57
-rw-r--r--www/py-beautifulsoup32/Makefile24
-rw-r--r--www/py-beautifulsoup32/distinfo2
-rw-r--r--www/py-beautifulsoup32/pkg-descr12
-rw-r--r--www/py-beautifulsoup32/pkg-plist6
8 files changed, 107 insertions, 17 deletions
diff --git a/www/Makefile b/www/Makefile
index b06afa8c9c04..eeebe7e2e3ea 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1444,6 +1444,7 @@
SUBDIR += py-beaker
SUBDIR += py-beautifulsoup
SUBDIR += py-beautifulsoup30
+ SUBDIR += py-beautifulsoup32
SUBDIR += py-bjoern
SUBDIR += py-bleach
SUBDIR += py-blogofile
diff --git a/www/py-beautifulsoup/Makefile b/www/py-beautifulsoup/Makefile
index f92415ee70b3..57851b3f5894 100644
--- a/www/py-beautifulsoup/Makefile
+++ b/www/py-beautifulsoup/Makefile
@@ -1,24 +1,24 @@
# New ports collection makefile for: beautifulsoup
-# Date created: 15 July 2005
-# Whom: Mike Meyer <mwm@mired.org>
+# Date created: 25 July 2012
+# Whom: Mike Meyer
#
# $FreeBSD$
#
PORTNAME= beautifulsoup
-PORTVERSION= 3.2.0
+PORTVERSION= 4.1.1
CATEGORIES= www python
-MASTER_SITES= http://www.crummy.com/software/BeautifulSoup/download/3.x/
+MASTER_SITES= http://www.crummy.com/software/BeautifulSoup/bs4/download/4.1/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
-DISTNAME= BeautifulSoup-${PORTVERSION}
+DISTNAME= beautifulsoup4-${PORTVERSION}
-MAINTAINER= mwm@mired.org
+MAINTAINER= william88@gmail.com
COMMENT= HTML/XML Parser for Python
-USE_PYTHON= yes
+USE_PYTHON= 2.7
USE_PYDISTUTILS= yes
-PYDISTUTILS_PKGNAME= BeautifulSoup
+PYDISTUTILS_PKGNAME= beautifulsoup4
-CONFLICTS= py[0-9]*-beautifulsoup-3.0.*
+CONFLICTS= py[0-9]*-beautifulsoup-3.*
.include <bsd.port.mk>
diff --git a/www/py-beautifulsoup/distinfo b/www/py-beautifulsoup/distinfo
index d787ba31ac70..0cf26110f1cb 100644
--- a/www/py-beautifulsoup/distinfo
+++ b/www/py-beautifulsoup/distinfo
@@ -1,2 +1,2 @@
-SHA256 (BeautifulSoup-3.2.0.tar.gz) = a0ea3377a1055bf2e17594c0808414afb65e11f25ce8998f1ed3e9b871de6ff6
-SIZE (BeautifulSoup-3.2.0.tar.gz) = 31056
+SHA256 (beautifulsoup4-4.1.1.tar.gz) = a8b1b59a105c07cf5a4912efd77294b3f86c4e3623fee773c8ca764c29d507ed
+SIZE (beautifulsoup4-4.1.1.tar.gz) = 129632
diff --git a/www/py-beautifulsoup/pkg-plist b/www/py-beautifulsoup/pkg-plist
index 2ff917b1a4f0..317afa901afe 100644
--- a/www/py-beautifulsoup/pkg-plist
+++ b/www/py-beautifulsoup/pkg-plist
@@ -1,6 +1,51 @@
-%%PYTHON_SITELIBDIR%%/BeautifulSoup.py
-%%PYTHON_SITELIBDIR%%/BeautifulSoup.pyc
-%%PYTHON_SITELIBDIR%%/BeautifulSoup.pyo
-%%PYTHON_SITELIBDIR%%/BeautifulSoupTests.py
-%%PYTHON_SITELIBDIR%%/BeautifulSoupTests.pyc
-%%PYTHON_SITELIBDIR%%/BeautifulSoupTests.pyo
+%%PYTHON_SITELIBDIR%%/bs4/dammit.pyc
+%%PYTHON_SITELIBDIR%%/bs4/__init__.pyo
+%%PYTHON_SITELIBDIR%%/bs4/dammit.py
+%%PYTHON_SITELIBDIR%%/bs4/element.pyo
+%%PYTHON_SITELIBDIR%%/bs4/testing.pyc
+%%PYTHON_SITELIBDIR%%/bs4/testing.py
+%%PYTHON_SITELIBDIR%%/bs4/__init__.py
+%%PYTHON_SITELIBDIR%%/bs4/dammit.pyo
+%%PYTHON_SITELIBDIR%%/bs4/__init__.pyc
+%%PYTHON_SITELIBDIR%%/bs4/element.py
+%%PYTHON_SITELIBDIR%%/bs4/testing.pyo
+%%PYTHON_SITELIBDIR%%/bs4/element.pyc
+%%PYTHON_SITELIBDIR%%/bs4/tests/test_tree.py
+%%PYTHON_SITELIBDIR%%/bs4/tests/test_builder_registry.pyc
+%%PYTHON_SITELIBDIR%%/bs4/tests/test_lxml.pyo
+%%PYTHON_SITELIBDIR%%/bs4/tests/test_soup.pyc
+%%PYTHON_SITELIBDIR%%/bs4/tests/test_htmlparser.pyo
+%%PYTHON_SITELIBDIR%%/bs4/tests/test_htmlparser.py
+%%PYTHON_SITELIBDIR%%/bs4/tests/test_lxml.py
+%%PYTHON_SITELIBDIR%%/bs4/tests/__init__.pyc
+%%PYTHON_SITELIBDIR%%/bs4/tests/test_tree.pyc
+%%PYTHON_SITELIBDIR%%/bs4/tests/__init__.py
+%%PYTHON_SITELIBDIR%%/bs4/tests/test_html5lib.pyo
+%%PYTHON_SITELIBDIR%%/bs4/tests/test_docs.pyc
+%%PYTHON_SITELIBDIR%%/bs4/tests/test_soup.py
+%%PYTHON_SITELIBDIR%%/bs4/tests/test_lxml.pyc
+%%PYTHON_SITELIBDIR%%/bs4/tests/test_builder_registry.pyo
+%%PYTHON_SITELIBDIR%%/bs4/tests/test_builder_registry.py
+%%PYTHON_SITELIBDIR%%/bs4/tests/test_htmlparser.pyc
+%%PYTHON_SITELIBDIR%%/bs4/tests/test_soup.pyo
+%%PYTHON_SITELIBDIR%%/bs4/tests/test_html5lib.py
+%%PYTHON_SITELIBDIR%%/bs4/tests/test_docs.py
+%%PYTHON_SITELIBDIR%%/bs4/tests/__init__.pyo
+%%PYTHON_SITELIBDIR%%/bs4/tests/test_tree.pyo
+%%PYTHON_SITELIBDIR%%/bs4/tests/test_docs.pyo
+%%PYTHON_SITELIBDIR%%/bs4/tests/test_html5lib.pyc
+%%PYTHON_SITELIBDIR%%/bs4/builder/_html5lib.pyo
+%%PYTHON_SITELIBDIR%%/bs4/builder/_htmlparser.pyo
+%%PYTHON_SITELIBDIR%%/bs4/builder/_lxml.pyc
+%%PYTHON_SITELIBDIR%%/bs4/builder/_htmlparser.py
+%%PYTHON_SITELIBDIR%%/bs4/builder/__init__.py
+%%PYTHON_SITELIBDIR%%/bs4/builder/__init__.pyc
+%%PYTHON_SITELIBDIR%%/bs4/builder/_lxml.py
+%%PYTHON_SITELIBDIR%%/bs4/builder/_html5lib.py
+%%PYTHON_SITELIBDIR%%/bs4/builder/_html5lib.pyc
+%%PYTHON_SITELIBDIR%%/bs4/builder/_lxml.pyo
+%%PYTHON_SITELIBDIR%%/bs4/builder/_htmlparser.pyc
+%%PYTHON_SITELIBDIR%%/bs4/builder/__init__.pyo
+@dirrm %%PYTHON_SITELIBDIR%%/bs4/builder
+@dirrm %%PYTHON_SITELIBDIR%%/bs4/tests
+@dirrm %%PYTHON_SITELIBDIR%%/bs4
diff --git a/www/py-beautifulsoup32/Makefile b/www/py-beautifulsoup32/Makefile
new file mode 100644
index 000000000000..f92415ee70b3
--- /dev/null
+++ b/www/py-beautifulsoup32/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: beautifulsoup
+# Date created: 15 July 2005
+# Whom: Mike Meyer <mwm@mired.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= beautifulsoup
+PORTVERSION= 3.2.0
+CATEGORIES= www python
+MASTER_SITES= http://www.crummy.com/software/BeautifulSoup/download/3.x/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= BeautifulSoup-${PORTVERSION}
+
+MAINTAINER= mwm@mired.org
+COMMENT= HTML/XML Parser for Python
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+PYDISTUTILS_PKGNAME= BeautifulSoup
+
+CONFLICTS= py[0-9]*-beautifulsoup-3.0.*
+
+.include <bsd.port.mk>
diff --git a/www/py-beautifulsoup32/distinfo b/www/py-beautifulsoup32/distinfo
new file mode 100644
index 000000000000..d787ba31ac70
--- /dev/null
+++ b/www/py-beautifulsoup32/distinfo
@@ -0,0 +1,2 @@
+SHA256 (BeautifulSoup-3.2.0.tar.gz) = a0ea3377a1055bf2e17594c0808414afb65e11f25ce8998f1ed3e9b871de6ff6
+SIZE (BeautifulSoup-3.2.0.tar.gz) = 31056
diff --git a/www/py-beautifulsoup32/pkg-descr b/www/py-beautifulsoup32/pkg-descr
new file mode 100644
index 000000000000..eb0ab5affd47
--- /dev/null
+++ b/www/py-beautifulsoup32/pkg-descr
@@ -0,0 +1,12 @@
+Beautiful Soup parses arbitrarily invalid XML- or HTML-like substance
+into a tree representation. It provides methods and Pythonic idioms
+that make it easy to search and modify the tree.
+
+A well-formed XML/HTML document will yield a well-formed data
+structure. An ill-formed XML/HTML document will yield a
+correspondingly ill-formed data structure. If your document is only
+locally well-formed, you can use this library to find and process the
+well-formed part of it. The BeautifulSoup class has heuristics for
+obtaining a sensible parse tree in the face of common HTML errors.
+
+WWW: http://www.crummy.com/software/BeautifulSoup/
diff --git a/www/py-beautifulsoup32/pkg-plist b/www/py-beautifulsoup32/pkg-plist
new file mode 100644
index 000000000000..2ff917b1a4f0
--- /dev/null
+++ b/www/py-beautifulsoup32/pkg-plist
@@ -0,0 +1,6 @@
+%%PYTHON_SITELIBDIR%%/BeautifulSoup.py
+%%PYTHON_SITELIBDIR%%/BeautifulSoup.pyc
+%%PYTHON_SITELIBDIR%%/BeautifulSoup.pyo
+%%PYTHON_SITELIBDIR%%/BeautifulSoupTests.py
+%%PYTHON_SITELIBDIR%%/BeautifulSoupTests.pyc
+%%PYTHON_SITELIBDIR%%/BeautifulSoupTests.pyo