aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorroam <roam@FreeBSD.org>2003-10-07 18:34:59 +0800
committerroam <roam@FreeBSD.org>2003-10-07 18:34:59 +0800
commit2d1ba48111a623c0a191c2682a37117eba61db51 (patch)
tree9b5bb3382b8dac9123e977ec3ec319d481a1355a /www
parentc5ecae5991b30a8645d54aba7bc87423fdd70f49 (diff)
downloadfreebsd-ports-gnome-2d1ba48111a623c0a191c2682a37117eba61db51.tar.gz
freebsd-ports-gnome-2d1ba48111a623c0a191c2682a37117eba61db51.tar.zst
freebsd-ports-gnome-2d1ba48111a623c0a191c2682a37117eba61db51.zip
Add mod_auth_pam 1.1.1 - an Apache 2 module for authentication against
the system's PAM framework. PR: 57654 Submitted by: Clement Laforet <sheepkiller@cultdeadsheep.org>
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/mod_auth_pam2/Makefile35
-rw-r--r--www/mod_auth_pam2/distinfo1
-rw-r--r--www/mod_auth_pam2/files/patch-Makefile18
-rw-r--r--www/mod_auth_pam2/pkg-descr6
-rw-r--r--www/mod_auth_pam2/pkg-plist11
6 files changed, 72 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 8670f37d4b0c..3dab014e0aac 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -190,6 +190,7 @@
SUBDIR += mod_auth_mysql
SUBDIR += mod_auth_mysql_another
SUBDIR += mod_auth_pam
+ SUBDIR += mod_auth_pam2
SUBDIR += mod_auth_pgsql
SUBDIR += mod_auth_pgsql2
SUBDIR += mod_auth_pwcheck
diff --git a/www/mod_auth_pam2/Makefile b/www/mod_auth_pam2/Makefile
new file mode 100644
index 000000000000..1b953a048c09
--- /dev/null
+++ b/www/mod_auth_pam2/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: mod_auth_pam2
+# Date created: Sun Oct 5
+# Whom: Clement Laforet <sheepkiller@cultdeadsheep.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mod_auth_pam
+PORTVERSION= 1.1.1
+CATEGORIES= www
+MASTER_SITES= http://pam.sourceforge.net/mod_auth_pam/dist/
+DISTNAME= ${PORTNAME}-2.0-${PORTVERSION}
+
+MAINTAINER= sheepkiller@cotds.org
+COMMENT= Allows users to use PAM modules for user authentication
+
+BUILD_DEPENDS= ${LOCALBASE}/sbin/apxs:${PORTSDIR}/www/apache2
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+LATEST_LINK= mod_auth_pam2
+
+USE_GMAKE= YES
+MAKE_ENV+= APXS=${APXS}
+WRKSRC= ${WRKDIR}/${PORTNAME}
+APXS?= ${LOCALBASE}/sbin/apxs
+
+post-install:
+ ${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/samples/httpd ${EXAMPLESDIR}/pam-httpd.sample
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/*.html ${DOCSDIR}/
+.endif
+
+.include <bsd.port.mk>
diff --git a/www/mod_auth_pam2/distinfo b/www/mod_auth_pam2/distinfo
new file mode 100644
index 000000000000..ba6eb814d4a8
--- /dev/null
+++ b/www/mod_auth_pam2/distinfo
@@ -0,0 +1 @@
+MD5 (mod_auth_pam-2.0-1.1.1.tar.gz) = ab873520ddd2fee7d480dfd53e464e0a
diff --git a/www/mod_auth_pam2/files/patch-Makefile b/www/mod_auth_pam2/files/patch-Makefile
new file mode 100644
index 000000000000..4e87186eebfa
--- /dev/null
+++ b/www/mod_auth_pam2/files/patch-Makefile
@@ -0,0 +1,18 @@
+--- Makefile.orig Sat Aug 24 15:33:12 2002
++++ Makefile Sun Oct 5 20:41:52 2003
+@@ -1,5 +1,4 @@
+ LIBS=-lpam
+-APXS=apxs
+ # try this, if you're not root and apxs is in the standard place
+ #APXS=/usr/sbin/apxs
+
+@@ -14,8 +13,7 @@
+ $(APXS) -c $< $(LIBS)
+
+ install: $(TARGETS)
+- $(APXS) -i $(TARGETS)
+- [ -d /etc/pam.d/ -a ! -f /etc/pam.d/httpd ] && install -m 644 -o root -g root samples/httpd /etc/pam.d/
++ $(APXS) -i -A $(TARGETS)
+
+ clean:
+ -rm -f $(TARGETS) *~ $(SOURCES:.c=.slo) $(SOURCES:.c=.lo) $(SOURCES:.c=.so) $(SOURCES:.c=.o)
diff --git a/www/mod_auth_pam2/pkg-descr b/www/mod_auth_pam2/pkg-descr
new file mode 100644
index 000000000000..d884b677a046
--- /dev/null
+++ b/www/mod_auth_pam2/pkg-descr
@@ -0,0 +1,6 @@
+The PAM authentication module implements Basic authentication on top of the
+Pluggable Authentication Module library. Thereby it supports whatever
+authentication method your PAM subsystem has specific support installed &
+configured for.
+
+WWW: http://pam.sourceforge.net/mod_auth_pam/
diff --git a/www/mod_auth_pam2/pkg-plist b/www/mod_auth_pam2/pkg-plist
new file mode 100644
index 000000000000..f6e0eb0bc103
--- /dev/null
+++ b/www/mod_auth_pam2/pkg-plist
@@ -0,0 +1,11 @@
+%%PORTDOCS%%%%DOCSDIR%%/configure.html
+%%PORTDOCS%%%%DOCSDIR%%/faq.html
+%%PORTDOCS%%%%DOCSDIR%%/install.html
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+libexec/apache2/mod_auth_pam.so
+@exec %D/sbin/apxs -e -A -n auth_pam %D/%f
+libexec/apache2/mod_auth_sys_group.so
+@exec %D/sbin/apxs -e -A -n auth_sys_group %D/%f
+%%EXAMPLESDIR%%/pam-httpd.sample
+@dirrm %%EXAMPLESDIR%%
+@unexec echo "===> If you do not plan on reinstalling mod_auth_pam, you must manually remove"; echo "===> references to it in httpd.conf."