aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authormm <mm@FreeBSD.org>2007-08-13 19:16:24 +0800
committermm <mm@FreeBSD.org>2007-08-13 19:16:24 +0800
commit2eed235415fc2f08705fc04f960de73e52f90439 (patch)
tree8268cb75e958d2f031fff297cebe9142f1c72ff5 /www
parentd8f2c2ee39b845a85738a6434e64699f9875aa05 (diff)
downloadfreebsd-ports-gnome-2eed235415fc2f08705fc04f960de73e52f90439.tar.gz
freebsd-ports-gnome-2eed235415fc2f08705fc04f960de73e52f90439.tar.zst
freebsd-ports-gnome-2eed235415fc2f08705fc04f960de73e52f90439.zip
- Introduce lynx.cfg.sample and lynx.lss.sample
- Do not delete/overwrite lynx.lss if changed PR: ports/112863 Patch by: mm Approved by: maintainer (timeout), garga (mentor, implicit)
Diffstat (limited to 'www')
-rw-r--r--www/lynx/Makefile1
-rw-r--r--www/lynx/files/patch-aa37
-rw-r--r--www/lynx/pkg-plist8
3 files changed, 32 insertions, 14 deletions
diff --git a/www/lynx/Makefile b/www/lynx/Makefile
index ac071aa7ebb9..674a1d7c1322 100644
--- a/www/lynx/Makefile
+++ b/www/lynx/Makefile
@@ -7,6 +7,7 @@
PORTNAME= lynx
PORTVERSION= 2.8.6.5
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= www ipv6
MASTER_SITES= http://lynx.isc.org/current/ \
diff --git a/www/lynx/files/patch-aa b/www/lynx/files/patch-aa
index af908632ba11..5e713ecc7a63 100644
--- a/www/lynx/files/patch-aa
+++ b/www/lynx/files/patch-aa
@@ -1,35 +1,50 @@
---- makefile.in.orig Mon Sep 4 07:25:39 2006
-+++ makefile.in Fri Apr 13 16:35:28 2007
+--- makefile.in.orig Mon Sep 4 01:25:39 2006
++++ makefile.in Tue Jul 31 10:37:26 2007
@@ -366,7 +366,9 @@
else \
cp $(srcdir)/lynx.cfg $(SYSCONFDIR)/lynx.tmp ; \
fi'
- @echo Updating $(sysconfdir)/lynx.cfg to point to installed help-files
-+ @echo Updating $(srcdir)/lynx.cfg.default
++ @echo Updating $(srcdir)/lynx.cfg.sample
+ @cp $(srcdir)/lynx.cfg $(srcdir)/lynx.tmp
-+ @echo Updating $(srcdir)/lynx.cfg.default to point to installed help-files
++ @echo Updating $(srcdir)/lynx.cfg.sample to point to installed help-files
@ECHO_CC@sed -e '/^HELPFILE:http/s!^!#!' \
-e '/^#HELPFILE:file/s!#!!' \
$(SYSCONFDIR)/lynx.tmp | \
-@@ -374,9 +376,10 @@
+@@ -374,9 +376,11 @@
$(SHELL) $(scripts_dir)/cfg_path.sh lynx_doc $(helpdir) | \
sed -e '/^HELPFILE:file/s!$$!$(COMPRESS_EXT)!' \
-e '/^HELPFILE:file/s!$(COMPRESS_EXT)$(COMPRESS_EXT)$$!$(COMPRESS_EXT)!' \
- >$(SYSCONFDIR)/lynx.cfg
- chmod 644 $(SYSCONFDIR)/lynx.cfg
-+ >$(SYSCONFDIR)/lynx.cfg.default
-+ chmod 644 $(SYSCONFDIR)/lynx.cfg.default
++ >$(SYSCONFDIR)/lynx.cfg.sample
++ chmod 644 $(SYSCONFDIR)/lynx.cfg.sample
-rm -f $(SYSCONFDIR)/lynx.tmp
-+ -[ ! -f $(SYSCONFDIR)/lynx.cfg ] && $(INSTALL_DATA) $(SYSCONFDIR)/lynx.cfg.default $(SYSCONFDIR)/lynx.cfg
++ -[ ! -f $(SYSCONFDIR)/lynx.cfg ] && $(INSTALL_DATA) $(SYSCONFDIR)/lynx.cfg.sample $(SYSCONFDIR)/lynx.cfg
++ -[ ! -f $(SYSCONFDIR)/lynx.lss ] && $(INSTALL_DATA) $(SYSCONFDIR)/lynx.lss.sample $(SYSCONFDIR)/lynx.lss
LYHelp.h : help_files.sed LYHelp.hin
@echo Creating $@
-@@ -398,7 +401,7 @@
+@@ -398,18 +402,17 @@
$(SHELL) -c 'SHELL=$(SHELL) $(SHELL) $(scripts_dir)/cfg_defs.sh $(srcdir)'
install-cfg : $(SYSCONFDIR)
- @$(SHELL) $(scripts_dir)/install-cfg.sh "$(INSTALL_DATA)" $(srcdir)/lynx.cfg $(SYSCONFDIR)/lynx.cfg
-+ @$(SHELL) $(scripts_dir)/install-cfg.sh "$(INSTALL_DATA)" $(srcdir)/lynx.cfg $(SYSCONFDIR)/lynx.cfg.default
++ @$(SHELL) $(scripts_dir)/install-cfg.sh "$(INSTALL_DATA)" $(srcdir)/lynx.cfg $(SYSCONFDIR)/lynx.cfg.sample
install-lss : $(SYSCONFDIR)
- -mv -f $(SYSCONFDIR)/lynx.lss $(SYSCONFDIR)/lynx.oldlss
+- -mv -f $(SYSCONFDIR)/lynx.lss $(SYSCONFDIR)/lynx.oldlss
+- $(INSTALL_DATA) $(srcdir)/samples/lynx.lss $(SYSCONFDIR)/lynx.lss
++ @$(INSTALL_DATA) $(srcdir)/samples/lynx.lss $(SYSCONFDIR)/lynx.lss.sample
+
+ uninstall ::
+ @MSG_DIR_MAKE@ cd po && $(MAKE) CC="$(CC)" uninstall
+ -rm -f $(BINDIR)/lynx$x
+ -rm -f $(MANDIR)/lynx.1
+- -rm -f $(SYSCONFDIR)/lynx.cfg
+- -rm -f $(SYSCONFDIR)/lynx.lss
++ -rm -f $(SYSCONFDIR)/lynx.cfg.sample
++ -rm -f $(SYSCONFDIR)/lynx.lss.sample
+
+ uninstall \
+ uninstall-help ::
diff --git a/www/lynx/pkg-plist b/www/lynx/pkg-plist
index 7dbf46dd4437..f793633e82cc 100644
--- a/www/lynx/pkg-plist
+++ b/www/lynx/pkg-plist
@@ -1,8 +1,10 @@
bin/lynx
-@unexec if [ -f %D/etc/lynx.cfg ] && cmp -s %D/etc/lynx.cfg %D/etc/lynx.cfg.default; then rm -f %D/etc/lynx.cfg; fi
-etc/lynx.cfg.default
+@unexec if [ -f %D/etc/lynx.cfg ] && cmp -s %D/etc/lynx.cfg %D/etc/lynx.cfg.sample; then rm -f %D/etc/lynx.cfg; fi
+etc/lynx.cfg.sample
@exec if [ ! -f %D/etc/lynx.cfg ] ; then cp -p %D/%F %B/lynx.cfg; fi
-etc/lynx.lss
+@unexec if [ -f %D/etc/lynx.lss ] && cmp -s %D/etc/lynx.lss %D/etc/lynx.lss.sample; then rm -f %D/etc/lynx.lss; fi
+etc/lynx.lss.sample
+@exec if [ ! -f %D/etc/lynx.lss ] ; then cp -p %D/%F %B/lynx.lss; fi
@exec mkdir -p %D/share/lynx_help
%%DOCSDIR%%/CHANGES
%%DOCSDIR%%/COPYHEADER