aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2014-09-19 03:39:53 +0800
committerantoine <antoine@FreeBSD.org>2014-09-19 03:39:53 +0800
commit39ab158c53266f0221e69f292dd7df5f6c7c690b (patch)
tree6b6fa1bcfe1ee40cb96a2a06212272fde4dc0bd5 /www
parentfc01ca52e2bd4932e8298c44c803beb5bf4179e3 (diff)
downloadfreebsd-ports-gnome-39ab158c53266f0221e69f292dd7df5f6c7c690b.tar.gz
freebsd-ports-gnome-39ab158c53266f0221e69f292dd7df5f6c7c690b.tar.zst
freebsd-ports-gnome-39ab158c53266f0221e69f292dd7df5f6c7c690b.zip
Allow staging as a regular user
Diffstat (limited to 'www')
-rw-r--r--www/php-plurk-api/Makefile11
-rw-r--r--www/php-plurk-api/pkg-plist4
2 files changed, 5 insertions, 10 deletions
diff --git a/www/php-plurk-api/Makefile b/www/php-plurk-api/Makefile
index e43e121b6286..875ac1c1e7db 100644
--- a/www/php-plurk-api/Makefile
+++ b/www/php-plurk-api/Makefile
@@ -16,23 +16,14 @@ USE_PHP= json curl
USES= zip
WRKSRC= ${WRKDIR}/${PORTVERSION}
+PLIST_SUB= WWWOWN="${WWWOWN}" WWWGRP="${WWWGRP}"
SUB_LIST= PKGNAME=${PKGNAME}
SUB_FILES= pkg-message
do-install:
@cd ${WRKSRC} && ${COPYTREE_SHARE} . ${STAGEDIR}${WWWDIR}
- @${CHOWN} -R ${WWWOWN}:${WWWGRP} ${STAGEDIR}${WWWDIR}
- @${ECHO_CMD} '@exec ${CHOWN} -R ${WWWOWN}:${WWWGRP} ${WWWDIR}' >> ${TMPPLIST}
@${FIND} ${STAGEDIR}${WWWDIR} -type f -print0 | ${XARGS} -0 ${CHMOD} 644
- @${ECHO_CMD} '@exec ${FIND} ${WWWDIR} -type f -print0 | \
- ${XARGS} -0 ${CHMOD} 644' >> ${TMPPLIST}
@${FIND} ${STAGEDIR}${WWWDIR} -type d -print0 | ${XARGS} -0 ${CHMOD} 755
- @${ECHO_CMD} '@exec ${FIND} ${WWWDIR} -type d -print0 | \
- ${XARGS} -0 ${CHMOD} 755' >> ${TMPPLIST}
@${CHMOD} 755 ${STAGEDIR}${WWWDIR}/example.php
- @${ECHO_CMD} '@exec ${CHMOD} 755 ${WWWDIR}/example.php' >> ${TMPPLIST}
-
-post-install:
- @${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>
diff --git a/www/php-plurk-api/pkg-plist b/www/php-plurk-api/pkg-plist
index 586bcc68b6d2..a1a59f68c0cf 100644
--- a/www/php-plurk-api/pkg-plist
+++ b/www/php-plurk-api/pkg-plist
@@ -1,3 +1,5 @@
+@owner %%WWWOWN%%
+@group %%WWWGRP%%
%%WWWDIR%%/ChangeLog
%%WWWDIR%%/README
%%WWWDIR%%/config.php
@@ -29,3 +31,5 @@
@dirrm %%WWWDIR%%/documents/default
@dirrm %%WWWDIR%%/documents
@dirrm %%WWWDIR%%
+@owner root
+@group wheel