aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorpgollucci <pgollucci@FreeBSD.org>2009-05-26 06:44:46 +0800
committerpgollucci <pgollucci@FreeBSD.org>2009-05-26 06:44:46 +0800
commit3b22565691b1852c043226130f369a332f56479c (patch)
treea80e7a0010bd03fac1a0fd539f7d5338850c7395 /www
parent4f7e4c02ca1d3733105cf08e9ae24a16d507949d (diff)
downloadfreebsd-ports-gnome-3b22565691b1852c043226130f369a332f56479c.tar.gz
freebsd-ports-gnome-3b22565691b1852c043226130f369a332f56479c.tar.zst
freebsd-ports-gnome-3b22565691b1852c043226130f369a332f56479c.zip
- USE_APACHE=yes is deprecated
- Use SUB_FILES for pkg-message - Use WWWOWN - PREFIX -> LOCALBASE PR: ports/134447 Approved by: maintainer timeout (2 weeks) Submitted by: me
Diffstat (limited to 'www')
-rw-r--r--www/formication/Makefile18
-rw-r--r--www/formication/files/pkg-message.in (renamed from www/formication/pkg-message)0
2 files changed, 6 insertions, 12 deletions
diff --git a/www/formication/Makefile b/www/formication/Makefile
index 95e8639c7baa..64706671c012 100644
--- a/www/formication/Makefile
+++ b/www/formication/Makefile
@@ -15,34 +15,28 @@ DISTNAME= ${PORTNAME}
MAINTAINER= michael@ranner.eu
COMMENT= Formular processing tool written in perl
-CGI_UID?= www
-
-PKGMESSAGE= ${WRKDIR}/pkg-message
-USE_APACHE= yes
+USE_APACHE= 1.3
USE_PERL5_RUN= yes
NO_BUILD= yes
PORTDOCS= BLURB COPYING feedback.fcn feedback.html formication.txt
PLIST_FILES= www/cgi-bin/formication.pl
+SUB_FILES+= pkg-message
post-patch:
@${REINPLACE_CMD} -e "s,^#!/usr/local/bin/perl,#!${PERL},g" \
- -e "s,authorized_uid = 1031;,authorized_uid = ${CGI_UID};,g" \
+ -e "s,authorized_uid = 1031;,authorized_uid = ${WWWOWN};,g" \
${WRKSRC}/formication.pl
do-install:
- @${INSTALL_DATA} ${WRKSRC}/formication.pl ${PREFIX}/www/cgi-bin
+ @${INSTALL_DATA} ${WRKSRC}/formication.pl ${LOCALBASE}/www/cgi-bin
.if !defined(NOPORTDOCS)
- @${INSTALL} -d -o root -g wheel -m 0755 ${DOCSDIR}
+ ${MKDIR} ${DOCSDIR}/
. for i in ${PORTDOCS}
- @${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}/
. endfor
.endif
-pre-install:
- @${SED} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
- -e 's|%%DOCSDIR%%|${DOCSDIR}|g' <${.CURDIR}/pkg-message >${PKGMESSAGE}
-
post-install:
@${CAT} ${PKGMESSAGE}
diff --git a/www/formication/pkg-message b/www/formication/files/pkg-message.in
index 94ac65c25896..94ac65c25896 100644
--- a/www/formication/pkg-message
+++ b/www/formication/files/pkg-message.in