aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authoranholt <anholt@FreeBSD.org>2004-07-24 03:10:32 +0800
committeranholt <anholt@FreeBSD.org>2004-07-24 03:10:32 +0800
commit3c76fd7fad82c9f137407348028fde08754f2866 (patch)
tree9818557f7ca7be09aba8db3b18a8262f50280603 /www
parenta861bc861bc7251a2f2399f845d673f742a19ee1 (diff)
downloadfreebsd-ports-gnome-3c76fd7fad82c9f137407348028fde08754f2866.tar.gz
freebsd-ports-gnome-3c76fd7fad82c9f137407348028fde08754f2866.tar.zst
freebsd-ports-gnome-3c76fd7fad82c9f137407348028fde08754f2866.zip
- Add the X_WINDOW_SYSTEM={xorg,xfree86-4,xfree86-3} variable to bsd.port.mk,
and make XFREE86_VERSION map to it. XFREE86_VERSION is now deprecated. - Make xorg the default X_WINDOW_SYSTEM on -current. - Add several new X_*_PORT variables which point to various pieces of X11 based on the setting of X_WINDOW_SYSTEM, and make ports use them. - Add information to CHANGES about how to handle the transition. PR: ports/68763 Approved by: portmgr (marcus) Approved by: re (scottl)
Diffstat (limited to 'www')
-rw-r--r--www/amaya/Makefile2
-rw-r--r--www/larbin/Makefile13
2 files changed, 4 insertions, 11 deletions
diff --git a/www/amaya/Makefile b/www/amaya/Makefile
index 015721a06931..775a09f658bf 100644
--- a/www/amaya/Makefile
+++ b/www/amaya/Makefile
@@ -62,7 +62,7 @@ DISTFILES+= ${DICT:S/$/.tgz/g}
BROKEN= "Does not compile on alpha"
.endif
-.if ${XFREE86_VERSION} >= 4 && defined(WITH_OPENGL)
+.if ${X_WINDOW_SYSTEM:L} != xfree86-3 && defined(WITH_OPENGL)
LIB_DEPENDS+= gtkgl.5:${PORTSDIR}/x11-toolkits/gtkglarea
USE_GL= yes
CONFIGURE_ARGS+= --with-gl
diff --git a/www/larbin/Makefile b/www/larbin/Makefile
index 1b394d5d7213..dc61bb357ca1 100644
--- a/www/larbin/Makefile
+++ b/www/larbin/Makefile
@@ -15,7 +15,8 @@ MASTER_SITES= ftp://ftp.sourceforge.net/pub/sourceforge/larbin/ \
MAINTAINER= hmp@FreeBSD.org
COMMENT= A powerful HTTP crawler with an easy interface
-BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash2
+BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash2 \
+ makedepend:${X_IMAKE_PORT}
USE_GMAKE= yes
GNU_CONFIGURE= yes
@@ -23,14 +24,6 @@ USE_REINPLACE= yes
PATCH_WRKSRC= ${WRKSRC}/src
MAKE_ARGS= CXX=${CXX}
-.include <bsd.port.pre.mk>
-
-.if ${XFREE86_VERSION} == 3
-BUILD_DEPENDS+= makedepend:${PORTSDIR}/devel/imake
-.else
-BUILD_DEPENDS+= makedepend:${PORTSDIR}/devel/imake-4
-.endif
-
post-patch:
@${SED} -e 's,CC=,CC?=,' -e 's,CFLAGS=-O3,CFLAGS+=,' < \
${WRKSRC}/adns/Makefile > ${WRKSRC}/adns/Makefile.new
@@ -66,4 +59,4 @@ post-install:
@${ECHO} ""
@${ECHO} "====================================================================="
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>