aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2003-12-26 09:00:25 +0800
committerpav <pav@FreeBSD.org>2003-12-26 09:00:25 +0800
commit3e106e74e3ac15d7ef5437ddd1014a7c3928a37e (patch)
tree53b1b40c948c0aab9491dcd399b77622d2286f31 /www
parentcb4af9305374e401739db5c22733b9d6f9b97c5b (diff)
downloadfreebsd-ports-gnome-3e106e74e3ac15d7ef5437ddd1014a7c3928a37e.tar.gz
freebsd-ports-gnome-3e106e74e3ac15d7ef5437ddd1014a7c3928a37e.tar.zst
freebsd-ports-gnome-3e106e74e3ac15d7ef5437ddd1014a7c3928a37e.zip
Add emp, CGI application that creates a hierarchy of categorized links.
PR: ports/60031 Submitted by: Allan Bowhill <abowhill@blarg.net>
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/emp/Makefile30
-rw-r--r--www/emp/distinfo1
-rw-r--r--www/emp/pkg-descr5
-rw-r--r--www/emp/pkg-plist6
5 files changed, 43 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index d0fed9e693a5..8a1fc592cb24 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -76,6 +76,7 @@
SUBDIR += emacs-w3m
SUBDIR += emacs-w3m-emacs20
SUBDIR += emacs-w3m-xemacs21-mule
+ SUBDIR += emp
SUBDIR += epiphany
SUBDIR += erwn
SUBDIR += evg
diff --git a/www/emp/Makefile b/www/emp/Makefile
new file mode 100644
index 000000000000..a3cbb35c3ae8
--- /dev/null
+++ b/www/emp/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: emp
+# Date created: Oct 20, 2003
+# Whom: Allan Bowhill <abowhill@blarg.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= emp
+PORTVERSION= 0.92
+CATEGORIES= www
+MASTER_SITES= http://www.blarg.net/~abowhill/
+
+MAINTAINER= abowhill@blarg.net
+COMMENT= CGI program to deliver hierarchy of web links
+
+HAS_CONFIGURE= yes
+
+CGI_BIN= ${LOCALBASE}/www/cgi-bin
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/emp ${CGI_BIN}/emp.cgi
+ ${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/Samples/links.sample ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/Samples/emp.cfg ${EXAMPLESDIR}
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/README ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/www/emp/distinfo b/www/emp/distinfo
new file mode 100644
index 000000000000..423ff737ebe9
--- /dev/null
+++ b/www/emp/distinfo
@@ -0,0 +1 @@
+MD5 (emp-0.92.tar.gz) = 939d086193bda30bf9577356cb6de8d9
diff --git a/www/emp/pkg-descr b/www/emp/pkg-descr
new file mode 100644
index 000000000000..c283dfd9fe8c
--- /dev/null
+++ b/www/emp/pkg-descr
@@ -0,0 +1,5 @@
+EMP (Easy Maintenance Pages) is a heirarchical web delivery system.
+It is written in C++. It is small, fast and has a clean appearance.
+It makes a web site of categorized links that is easy to maintain.
+
+WWW: http://www.blarg.net/~abowhill
diff --git a/www/emp/pkg-plist b/www/emp/pkg-plist
new file mode 100644
index 000000000000..acfc605c4011
--- /dev/null
+++ b/www/emp/pkg-plist
@@ -0,0 +1,6 @@
+www/cgi-bin/emp.cgi
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%EXAMPLESDIR%%/links.sample
+%%EXAMPLESDIR%%/emp.cfg
+@dirrm %%EXAMPLESDIR%%
+%%PORTDOCS%%@dirrm %%DOCSDIR%%