aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2004-12-08 18:29:37 +0800
committerkrion <krion@FreeBSD.org>2004-12-08 18:29:37 +0800
commit40ead4c4bc8b5ff61eba936543ee9fdfacde6da5 (patch)
tree12bb390ec8be0c3d9239ab310affbaef4feecc53 /www
parent4c3fd4e29b1a1b1e8bf9831ab371adbbdb8b490e (diff)
downloadfreebsd-ports-gnome-40ead4c4bc8b5ff61eba936543ee9fdfacde6da5.tar.gz
freebsd-ports-gnome-40ead4c4bc8b5ff61eba936543ee9fdfacde6da5.tar.zst
freebsd-ports-gnome-40ead4c4bc8b5ff61eba936543ee9fdfacde6da5.zip
Handle OPTIONS more properly for oncoming bsd.port.mk changes.
Diffstat (limited to 'www')
-rw-r--r--www/lifetype/Makefile4
-rw-r--r--www/plog/Makefile4
2 files changed, 4 insertions, 4 deletions
diff --git a/www/lifetype/Makefile b/www/lifetype/Makefile
index 65cf7741b270..90ba930d0d65 100644
--- a/www/lifetype/Makefile
+++ b/www/lifetype/Makefile
@@ -28,7 +28,7 @@ OPTIONS= GD "With GD Support" on \
.include <bsd.port.pre.mk>
-.if defined(WITH_GD)
+.if !defined(WITHOUT_GD)
RUN_DEPENDS+= ${LOCALBASE}/lib/php/${PHP_EXT_DIR}/gd.so:${PORTSDIR}/${gd_DEPENDS}
.endif
@@ -36,7 +36,7 @@ RUN_DEPENDS+= ${LOCALBASE}/lib/php/${PHP_EXT_DIR}/gd.so:${PORTSDIR}/${gd_DEPENDS
RUN_DEPENDS+= ${LOCALBASE}/lib/php/${PHP_EXT_DIR}/imagick.so:${PORTSDIR}/${imagick_DEPENDS}
.endif
-.if !defined(WITH_GD) && !defined(WITH_IMAGICK)
+.if defined(WITHOUT_GD) && !defined(WITH_IMAGICK)
pre-patch:
@${ECHO_CMD} "Without GD or ImageMagick support. No thumbnails will be generated at all."
.endif
diff --git a/www/plog/Makefile b/www/plog/Makefile
index 65cf7741b270..90ba930d0d65 100644
--- a/www/plog/Makefile
+++ b/www/plog/Makefile
@@ -28,7 +28,7 @@ OPTIONS= GD "With GD Support" on \
.include <bsd.port.pre.mk>
-.if defined(WITH_GD)
+.if !defined(WITHOUT_GD)
RUN_DEPENDS+= ${LOCALBASE}/lib/php/${PHP_EXT_DIR}/gd.so:${PORTSDIR}/${gd_DEPENDS}
.endif
@@ -36,7 +36,7 @@ RUN_DEPENDS+= ${LOCALBASE}/lib/php/${PHP_EXT_DIR}/gd.so:${PORTSDIR}/${gd_DEPENDS
RUN_DEPENDS+= ${LOCALBASE}/lib/php/${PHP_EXT_DIR}/imagick.so:${PORTSDIR}/${imagick_DEPENDS}
.endif
-.if !defined(WITH_GD) && !defined(WITH_IMAGICK)
+.if defined(WITHOUT_GD) && !defined(WITH_IMAGICK)
pre-patch:
@${ECHO_CMD} "Without GD or ImageMagick support. No thumbnails will be generated at all."
.endif