aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorbeat <beat@FreeBSD.org>2014-02-17 06:30:03 +0800
committerbeat <beat@FreeBSD.org>2014-02-17 06:30:03 +0800
commit46c3336a8a34109f191d761c1f4d9907cb716bcf (patch)
tree360fc7db45f296268954d8ffc76ba23150690995 /www
parenta370b559910f84f802a1f062eaa6675ae5f6b7e3 (diff)
downloadfreebsd-ports-gnome-46c3336a8a34109f191d761c1f4d9907cb716bcf.tar.gz
freebsd-ports-gnome-46c3336a8a34109f191d761c1f4d9907cb716bcf.tar.zst
freebsd-ports-gnome-46c3336a8a34109f191d761c1f4d9907cb716bcf.zip
Update to 24.3.0
Submitted by: Jan Beich
Diffstat (limited to 'www')
-rw-r--r--www/libxul/Makefile5
-rw-r--r--www/libxul/distinfo4
-rw-r--r--www/libxul/files/patch-bug89339752
-rw-r--r--www/libxul/files/patch-bug96181648
-rw-r--r--www/libxul/files/patch-bug96234518
-rw-r--r--www/libxul/files/patch-bug97003113
6 files changed, 107 insertions, 33 deletions
diff --git a/www/libxul/Makefile b/www/libxul/Makefile
index 4625d31dea60..c6d7cb3fb4f2 100644
--- a/www/libxul/Makefile
+++ b/www/libxul/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= libxul
-DISTVERSION= 24.2.0
-PORTREVISION= 1
+DISTVERSION= 24.3.0
CATEGORIES?= www devel
MASTER_SITES= MOZILLA/firefox/releases/${DISTVERSION}esr/source \
https://ftp.mozilla.org/pub/mozilla.org/firefox/candidates/${DISTVERSION}esr-candidates/build1/source/
@@ -13,7 +12,7 @@ MAINTAINER?= gecko@FreeBSD.org
COMMENT?= Mozilla runtime package that can be used to bootstrap XUL+XPCOM apps
BUILD_DEPENDS= nspr>=4.10.2:${PORTSDIR}/devel/nspr \
- nss>=3.15:${PORTSDIR}/security/nss \
+ nss>=3.15.4:${PORTSDIR}/security/nss \
sqlite3>=3.7.17:${PORTSDIR}/databases/sqlite3 \
${PYTHON_PKGNAMEPREFIX}sqlite3>0:${PORTSDIR}/databases/py-sqlite3 \
cairo>=1.10.2_1,1:${PORTSDIR}/graphics/cairo \
diff --git a/www/libxul/distinfo b/www/libxul/distinfo
index 1279ff0a28a8..b8f85a402c3f 100644
--- a/www/libxul/distinfo
+++ b/www/libxul/distinfo
@@ -1,2 +1,2 @@
-SHA256 (firefox-24.2.0esr.source.tar.bz2) = 5a8aa526a0250e9faf2175ef610d63b2c91a5d01de7f9633b8781905dd2b9dcf
-SIZE (firefox-24.2.0esr.source.tar.bz2) = 119820009
+SHA256 (firefox-24.3.0esr.source.tar.bz2) = 0d38dd50beffff640cfea67fcf8f44bb95c3c927ccfa225f2b937b9a4ba262b9
+SIZE (firefox-24.3.0esr.source.tar.bz2) = 119391302
diff --git a/www/libxul/files/patch-bug893397 b/www/libxul/files/patch-bug893397
index 4d755c2ebb17..ab573204f4f4 100644
--- a/www/libxul/files/patch-bug893397
+++ b/www/libxul/files/patch-bug893397
@@ -2,7 +2,7 @@ diff --git configure.in configure.in
index 549ad06..2878d9f 100644
--- configure.in
+++ configure.in
-@@ -8491,7 +8491,7 @@ case "$OS_TARGET" in
+@@ -8091,7 +8091,7 @@ case "$OS_TARGET" in
NECKO_WIFI=1
fi
;;
@@ -15,9 +15,9 @@ diff --git netwerk/wifi/moz.build netwerk/wifi/moz.build
index 07b01de..11706af 100644
--- netwerk/wifi/moz.build
+++ netwerk/wifi/moz.build
-@@ -34,6 +34,10 @@ if CONFIG['OS_ARCH'] == 'Darwin':
- CMMSRCS += [
- 'osx_corewlan.mm',
+@@ -31,6 +31,10 @@ if CONFIG['OS_ARCH'] == 'Darwin':
+ CPP_SOURCES += [
+ 'nsWifiScannerMac.cpp',
]
+elif CONFIG['OS_ARCH'] == 'FreeBSD':
+ CPP_SOURCES += [
@@ -31,7 +31,7 @@ new file mode 100644
index 0000000..80d4cb6
--- /dev/null
+++ netwerk/wifi/nsWifiScannerFreeBSD.cpp
-@@ -0,0 +1,172 @@
+@@ -0,0 +1,168 @@
+/* This Source Code Form is subject to the terms of the Mozilla Public
+ * License, v. 2.0. If a copy of the MPL was not distributed with this
+ * file, You can obtain one at http://mozilla.org/MPL/2.0/. */
@@ -60,25 +60,19 @@ index 0000000..80d4cb6
+static nsresult
+FreeBSDGetAccessPointData(nsCOMArray<nsWifiAccessPoint> &accessPoints)
+{
-+ bool res = false;
-+ char *dupn = NULL;
-+ struct ifaddrs *ifal, *ifa;
-+ unsigned len;
-+
+ // get list of interfaces
++ struct ifaddrs *ifal;
+ if (getifaddrs(&ifal) < 0)
+ return NS_ERROR_FAILURE;
+
+ accessPoints.Clear();
+
+ // loop through the interfaces
++ nsresult rv = NS_ERROR_FAILURE;
++ struct ifaddrs *ifa;
++ char *dupn = NULL;
+ for (ifa = ifal; ifa; ifa = ifa->ifa_next) {
-+ int s;
+ struct ifreq ifr;
-+ struct ifmediareq ifmr;
-+ struct ieee80211req i802r;
-+ char iscanbuf[32*1024], *vsr;
-+
+ memset(&ifr, 0, sizeof(ifr));
+
+ // list can contain duplicates, so ignore those
@@ -91,10 +85,12 @@ index 0000000..80d4cb6
+ ifr.ifr_addr.sa_family = AF_LOCAL;
+
+ // open socket to interface
-+ if ((s = socket(ifr.ifr_addr.sa_family, SOCK_DGRAM, 0)) < 0)
++ int s = socket(ifr.ifr_addr.sa_family, SOCK_DGRAM, 0);
++ if (s < 0)
+ continue;
+
+ // clear interface media structure
++ struct ifmediareq ifmr;
+ (void) memset(&ifmr, 0, sizeof(ifmr));
+ (void) strncpy(ifmr.ifm_name, ifa->ifa_name, sizeof(ifmr.ifm_name));
+
@@ -111,6 +107,8 @@ index 0000000..80d4cb6
+ }
+
+ // perform WiFi scan
++ struct ieee80211req i802r;
++ char iscanbuf[32*1024];
+ (void) memset(&i802r, 0, sizeof(i802r));
+ (void) strncpy(i802r.i_name, ifa->ifa_name, sizeof(i802r.i_name));
+ i802r.i_type = IEEE80211_IOC_SCAN_RESULTS;
@@ -125,18 +123,15 @@ index 0000000..80d4cb6
+ close(s);
+
+ // loop through WiFi networks and build geoloc-lookup structure
-+ vsr = (char *) i802r.i_data;
-+ len = i802r.i_len;
++ char *vsr = (char *) i802r.i_data;
++ unsigned len = i802r.i_len;
+ while (len >= sizeof(struct ieee80211req_scan_result)) {
-+ struct ieee80211req_scan_result *isr;
-+ char *id;
-+ int idlen;
-+ char ssid[IEEE80211_NWID_LEN+1];
-+ nsWifiAccessPoint *ap;
-+
-+ isr = (struct ieee80211req_scan_result *) vsr;
++ struct ieee80211req_scan_result *isr =
++ (struct ieee80211req_scan_result *) vsr;
+
+ // determine size of this entry
++ char *id;
++ int idlen;
+ if (isr->isr_meshid_len) {
+ id = vsr + isr->isr_ie_off + isr->isr_ssid_len;
+ idlen = isr->isr_meshid_len;
@@ -147,14 +142,15 @@ index 0000000..80d4cb6
+ }
+
+ // copy network data
++ char ssid[IEEE80211_NWID_LEN+1];
+ strncpy(ssid, id, idlen);
+ ssid[idlen] = '\0';
-+ ap = new nsWifiAccessPoint();
++ nsWifiAccessPoint *ap = new nsWifiAccessPoint();
+ ap->setSSID(ssid, strlen(ssid));
+ ap->setMac(isr->isr_bssid);
+ ap->setSignal(isr->isr_rssi);
+ accessPoints.AppendObject(ap);
-+ res = true;
++ rv = NS_OK;
+
+ // log the data
+ LOG(( "FreeBSD access point: "
@@ -172,7 +168,7 @@ index 0000000..80d4cb6
+
+ freeifaddrs(ifal);
+
-+ return res ? NS_OK : NS_ERROR_FAILURE;
++ return rv;
+}
+
+nsresult
diff --git a/www/libxul/files/patch-bug961816 b/www/libxul/files/patch-bug961816
new file mode 100644
index 000000000000..322e73f952f6
--- /dev/null
+++ b/www/libxul/files/patch-bug961816
@@ -0,0 +1,48 @@
+diff --git config/system-headers config/system-headers
+index 8803150..ae38d68 100644
+--- config/system-headers
++++ config/system-headers
+@@ -1158,3 +1158,4 @@ unicode/unum.h
+ unicode/ustring.h
+ #endif
+ libutil.h
++unwind.h
+diff --git configure.in configure.in
+index f452a5e..a1ebbcc 100644
+--- configure.in
++++ configure.in
+@@ -7455,7 +7455,10 @@ dnl ========================================================
+ dnl = Support for gcc stack unwinding (from gcc 3.3)
+ dnl ========================================================
+ if test -z "$SKIP_LIBRARY_CHECKS"; then
++ AC_LANG_SAVE
++ AC_LANG_CPLUSPLUS
+ MOZ_CHECK_HEADER(unwind.h, AC_CHECK_FUNCS(_Unwind_Backtrace))
++ AC_LANG_RESTORE
+ fi
+
+ dnl ========================================================
+diff --git config/system-headers config/system-headers
+index 8803150..ae38d68 100644
+--- js/src/config/system-headers
++++ js/src/config/system-headers
+@@ -1158,3 +1158,4 @@ unicode/unum.h
+ unicode/ustring.h
+ #endif
+ libutil.h
++unwind.h
+diff --git configure.in configure.in
+index f452a5e..a1ebbcc 100644
+--- js/src/configure.in
++++ js/src/configure.in
+@@ -7455,7 +7455,10 @@ dnl ========================================================
+ dnl = Support for gcc stack unwinding (from gcc 3.3)
+ dnl ========================================================
+ if test -z "$SKIP_LIBRARY_CHECKS"; then
++ AC_LANG_SAVE
++ AC_LANG_CPLUSPLUS
+ MOZ_CHECK_HEADER(unwind.h, AC_CHECK_FUNCS(_Unwind_Backtrace))
++ AC_LANG_RESTORE
+ fi
+
+ dnl ========================================================
diff --git a/www/libxul/files/patch-bug962345 b/www/libxul/files/patch-bug962345
new file mode 100644
index 000000000000..a465c93a51d1
--- /dev/null
+++ b/www/libxul/files/patch-bug962345
@@ -0,0 +1,18 @@
+diff --git config/system-headers config/system-headers
+index 8803150..ae38d68 100644
+--- config/system-headers
++++ config/system-headers
+@@ -1159,3 +1159,4 @@ unicode/ustring.h
+ #endif
+ libutil.h
+ unwind.h
++cairo-qt.h
+diff --git config/system-headers config/system-headers
+index 8803150..ae38d68 100644
+--- js/src/config/system-headers
++++ js/src/config/system-headers
+@@ -1159,3 +1159,4 @@ unicode/ustring.h
+ #endif
+ libutil.h
+ unwind.h
++cairo-qt.h
diff --git a/www/libxul/files/patch-bug970031 b/www/libxul/files/patch-bug970031
new file mode 100644
index 000000000000..bfb5f099eb85
--- /dev/null
+++ b/www/libxul/files/patch-bug970031
@@ -0,0 +1,13 @@
+diff --git xpcom/reflect/xptcall/src/md/unix/moz.build xpcom/reflect/xptcall/src/md/unix/moz.build
+index 5f88066..bd2a94f 100644
+--- xpcom/reflect/xptcall/src/md/unix/moz.build
++++ xpcom/reflect/xptcall/src/md/unix/moz.build
+@@ -235,7 +235,7 @@ if CONFIG['OS_ARCH'] == 'OpenBSD' and CO
+ 'xptcstubs_sparc_openbsd.cpp',
+ ]
+
+-if CONFIG['OS_ARCH'] == 'OpenBSD' and CONFIG['OS_TEST'] == 'sparc64':
++if CONFIG['OS_ARCH'] in ('OpenBSD', 'FreeBSD') and CONFIG['OS_TEST'] == 'sparc64':
+ CPP_SOURCES += [
+ 'xptcinvoke_sparc64_openbsd.cpp',
+ 'xptcstubs_sparc64_openbsd.cpp',