aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorwen <wen@FreeBSD.org>2013-05-20 14:11:46 +0800
committerwen <wen@FreeBSD.org>2013-05-20 14:11:46 +0800
commit4ffec032ac4c1b2c461ebe124b1f07c142e5c839 (patch)
tree2c2f6408c0235a12a02397ea25ac102b37a97665 /www
parent47733f7838a10fee2255209ecbef1fdb5eb8ea8f (diff)
downloadfreebsd-ports-gnome-4ffec032ac4c1b2c461ebe124b1f07c142e5c839.tar.gz
freebsd-ports-gnome-4ffec032ac4c1b2c461ebe124b1f07c142e5c839.tar.zst
freebsd-ports-gnome-4ffec032ac4c1b2c461ebe124b1f07c142e5c839.zip
- Repocopy www/moodle24 --> www/moodle25
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/moodle25/Makefile85
-rw-r--r--www/moodle25/distinfo2
-rw-r--r--www/moodle25/files/pkg-message.in61
-rw-r--r--www/moodle25/pkg-descr7
5 files changed, 156 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 86289eaf390b..6b323fe42a55 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -555,6 +555,7 @@
SUBDIR += moodle22
SUBDIR += moodle23
SUBDIR += moodle24
+ SUBDIR += moodle25
SUBDIR += moonshine
SUBDIR += mozplugger
SUBDIR += multisort
diff --git a/www/moodle25/Makefile b/www/moodle25/Makefile
new file mode 100644
index 000000000000..f189a08cc800
--- /dev/null
+++ b/www/moodle25/Makefile
@@ -0,0 +1,85 @@
+# Created by: Javier Martin Rueda <jmrueda@diatel.upm.es>
+# $FreeBSD$
+
+PORTNAME= moodle
+PORTVERSION= 2.5
+CATEGORIES= www
+MASTER_SITES= SF/moodle/Moodle/stable25/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= wen@FreeBSD.org
+COMMENT= Course management system based on social constructionism
+
+BUILD_DEPENDS= ${PHPBASE}/lib/php/${PHP_EXT_DIR}/intl.so:${PORTSDIR}/devel/pecl-intl
+RUN_DEPENDS= ${PHPBASE}/lib/php/${PHP_EXT_DIR}/intl.so:${PORTSDIR}/devel/pecl-intl
+
+CONFLICTS= moodle-1.*.* moodle-2.2.* moodle-2.3.* moodle-2.4.*
+LATEST_LINK= moodle25
+
+USE_PHP= session gd pcre mbstring iconv tokenizer curl xml xmlrpc ctype \
+ soap openssl simplexml spl dom json zip zlib hash
+WRKSRC= ${WRKDIR}/moodle
+
+OPTIONS_DEFINE= MYSQL PGSQL MSSQL LDAP MIMETEX
+OPTIONS_DEFAULT=MYSQL
+MSSQL_DESC= MS SQL Server support
+MIMETEX_DESC= mimeTeX filter functionality support
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MMYSQL}
+USE_PHP+= mysqli
+.endif
+
+.if ${PORT_OPTIONS:MPGSQL}
+USE_PHP+= pgsql
+.endif
+
+.if ${PORT_OPTIONS:MMSSQL}
+USE_PHP+= mssql
+.endif
+
+.if ${PORT_OPTIONS:MLDAP}
+USE_PHP+= ldap
+.endif
+
+.if ${PORT_OPTIONS:MMIMETEX}
+RUN_DEPENDS+= ${LOCALBASE}/www/mimetex/cgi-bin/mimetex.cgi:${PORTSDIR}/www/mimetex
+.endif
+
+NO_BUILD= yes
+PLIST= ${WRKDIR}/plist
+SUB_FILES= pkg-message
+SUB_LIST= MOODLEDIR=${MOODLEDIR} \
+ MOODLEDATADIR=${MOODLEDATADIR}
+
+MOODLEDIR?= www/moodle
+MOODLEDATADIR?= moodledata
+
+pre-install:
+ @${FIND} -s -d ${WRKSRC} -type f | ${SED} "s?${WRKSRC}?${MOODLEDIR}?g" >${PLIST}
+ @${FIND} -s -d ${WRKSRC} -type d | ${SED} "s?${WRKSRC}?@dirrm ${MOODLEDIR}?g" >> ${PLIST}
+ @${ECHO} @dirrm ${MOODLEDATADIR} >> ${PLIST}
+
+do-install:
+ @cd ${WRKSRC} && ${COPYTREE_SHARE} . ${PREFIX}/${MOODLEDIR}
+ @${CHOWN} -R ${WWWOWN}:${WWWGRP} ${PREFIX}/${MOODLEDIR}
+ @${ECHO_CMD} '@exec ${CHOWN} -R ${WWWOWN}:${WWWGRP} ${PREFIX}/${MOODLEDIR}' \
+ >> ${TMPPLIST}
+ ${CHMOD} -R 755 ${PREFIX}/${MOODLEDIR}
+ @${ECHO_CMD} '@exec ${CHMOD} -R 755 ${PREFIX}/${MOODLEDIR}' >> ${TMPPLIST}
+
+ @${INSTALL} -d ${PREFIX}/${MOODLEDATADIR}
+ @${CHOWN} -R ${WWWOWN}:${WWWGRP} ${PREFIX}/${MOODLEDATADIR}
+ @${ECHO_CMD} '@exec ${CHOWN} -R ${WWWOWN}:${WWWGRP} ${PREFIX}/${MOODLEDATADIR}' \
+ >> ${TMPPLIST}
+ ${CHMOD} 755 ${PREFIX}/${MOODLEDATADIR}
+ @${ECHO_CMD} '@exec ${CHMOD} 755 ${PREFIX}/${MOODLEDATADIR}' >> ${TMPPLIST}
+.if ${PORT_OPTIONS:MIMETEX}
+ ${LN} -sf ${PREFIX}/www/mimetex/cgi-bin/mimetex.cgi ${PREFIX}/${MOODLEDIR}/filter/tex/mimetex.freebsd
+.endif
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/www/moodle25/distinfo b/www/moodle25/distinfo
new file mode 100644
index 000000000000..eef7605553db
--- /dev/null
+++ b/www/moodle25/distinfo
@@ -0,0 +1,2 @@
+SHA256 (moodle-2.5.tgz) = 0feae5c0254effd369b6713b2e5177d1952dd921f298fa00d08cde3672fc53ac
+SIZE (moodle-2.5.tgz) = 31758353
diff --git a/www/moodle25/files/pkg-message.in b/www/moodle25/files/pkg-message.in
new file mode 100644
index 000000000000..9380c51f6361
--- /dev/null
+++ b/www/moodle25/files/pkg-message.in
@@ -0,0 +1,61 @@
+POST-INSTALL CONFIGURATION FOR MOODLE
+=====================================
+
+1) Create a user and a database for Moodle to store all
+ its tables in (or choose an existing database).
+ It doesn't matter what the database or user names are,
+ as this will be configured in a later step.
+ NOTE: this package assumes that either the phpX-pgsql,
+ phpX-mysql, or phpX-mssql packages are installed.
+
+2) Add the following to your Apache configuration, and
+ restart the server:
+
+ ### Add the AcceptPathInfo directive only for Apache 2.0.30 or later.
+ Alias /moodle %%PREFIX%%/%%MOODLEDIR%%/
+ AcceptPathInfo On
+ <Directory %%PREFIX%%/%%MOODLEDIR%%>
+ AllowOverride None
+ Order Allow,Deny
+ Allow from all
+ </Directory>
+ <Directory %%PREFIX%%/%%MOODLEDATADIR%%>
+ AllowOverride None
+ Order Allow,Deny
+ Deny from all
+ </Directory>
+
+3) Visit your Moodle site with a browser (i.e.,
+ http://your.server.com/moodle/), and you should
+ be taken to the install.php script, which will lead
+ you through creating a config.php file and then
+ setting up Moodle, creating an admin account, etc.
+
+ At one step, you will get a message saying that the
+ installer script was not able to automatically create
+ the config.php file. Just download it and copy it to
+ %%PREFIX%%/%%MOODLEDIR%%/config.php. Beware that it
+ will contain the database password in cleartext, so
+ set up whatever file permissions you deem more adequate.
+ For instance, user=root, group=www, mask=640.
+
+4) Set up a cron task to invoke the file admin/cron.php
+ every five minutes or so. For instance:
+ */5 * * * * fetch http://your.server.com/moodle/admin/cron.php
+
+For more information, see the INSTALL DOCUMENTATION:
+
+ http://docs.moodle.org/en/Installing_Moodle
+
+It may be worth reading the installation docs even if Moodle seems
+to be working at first, to ensure your PHP settings and database
+configuration will allow Moodle to operate properly.
+
+If you are upgrading from an earlier version of Moodle, check out
+possible additional steps at:
+
+ http://docs.moodle.org/en/Upgrading
+ http://docs.moodle.org/en/Upgrading_to_Moodle_2.0
+
+If you have real trouble, please visit the Moodle course
+"Using Moodle" on moodle.org.
diff --git a/www/moodle25/pkg-descr b/www/moodle25/pkg-descr
new file mode 100644
index 000000000000..fe30e0d25bab
--- /dev/null
+++ b/www/moodle25/pkg-descr
@@ -0,0 +1,7 @@
+Moodle is a course management system (CMS) - a free, Open Source software
+package designed using sound pedagogical principles, to help educators
+create effective online learning communities. You can use it on any
+computer you have handy (including webhosts), yet it can scale from a
+single-teacher site to a 40,000-student University.
+
+WWW: http://www.moodle.org/