aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorscrappy <scrappy@FreeBSD.org>2004-08-27 03:33:26 +0800
committerscrappy <scrappy@FreeBSD.org>2004-08-27 03:33:26 +0800
commit5c4b194d38bd579e0221d7e58260c19d6cf9c9b4 (patch)
treec475bf625f3c12bdc2a4949f17b1af11cdb95bca /www
parent4a88faa8fd33db52f3a855f058745567c33b90ea (diff)
downloadfreebsd-ports-gnome-5c4b194d38bd579e0221d7e58260c19d6cf9c9b4.tar.gz
freebsd-ports-gnome-5c4b194d38bd579e0221d7e58260c19d6cf9c9b4.tar.zst
freebsd-ports-gnome-5c4b194d38bd579e0221d7e58260c19d6cf9c9b4.zip
Run Maypole sub-requests as components
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-Maypole-Component/Makefile21
-rw-r--r--www/p5-Maypole-Component/distinfo2
-rw-r--r--www/p5-Maypole-Component/pkg-descr3
-rw-r--r--www/p5-Maypole-Component/pkg-plist4
5 files changed, 31 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index fdb1f84783c4..353b0fe5c236 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -495,6 +495,7 @@
SUBDIR += p5-MasonX-Request-WithApacheSession
SUBDIR += p5-Maypole
SUBDIR += p5-Maypole-Authentication-UserSessionCookie
+ SUBDIR += p5-Maypole-Component
SUBDIR += p5-PHP-Session
SUBDIR += p5-POE-Component-Server-HTTP
SUBDIR += p5-ParallelUA
diff --git a/www/p5-Maypole-Component/Makefile b/www/p5-Maypole-Component/Makefile
new file mode 100644
index 000000000000..87080adc522f
--- /dev/null
+++ b/www/p5-Maypole-Component/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: p5-Maypole-Component
+# Date created: Aug 26 2004
+# Whom: Marc G. Fournier
+#
+# $FreeBSD$
+
+PORTNAME= Maypole-Component
+PORTVERSION= 0.03
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../by-authors/id/S/SI/SIMON/
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= scrappy@FreeBSD.org
+COMMENT= Run Maypole sub-requests as components
+
+PERL_CONFIGURE= yes
+
+MAN3= Maypole::Component.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-Maypole-Component/distinfo b/www/p5-Maypole-Component/distinfo
new file mode 100644
index 000000000000..14b41877d1b1
--- /dev/null
+++ b/www/p5-Maypole-Component/distinfo
@@ -0,0 +1,2 @@
+MD5 (Maypole-Component-0.03.tar.gz) = d9edcf1c3d75f5a864b739632b789584
+SIZE (Maypole-Component-0.03.tar.gz) = 3668
diff --git a/www/p5-Maypole-Component/pkg-descr b/www/p5-Maypole-Component/pkg-descr
new file mode 100644
index 000000000000..0ab5c5ba6907
--- /dev/null
+++ b/www/p5-Maypole-Component/pkg-descr
@@ -0,0 +1,3 @@
+Run Maypole sub-requests as components
+
+WWW: http://search.cpan.org/dist/Maypole-Component
diff --git a/www/p5-Maypole-Component/pkg-plist b/www/p5-Maypole-Component/pkg-plist
new file mode 100644
index 000000000000..989f3b335e8c
--- /dev/null
+++ b/www/p5-Maypole-Component/pkg-plist
@@ -0,0 +1,4 @@
+%%SITE_PERL%%/Maypole/Component.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Maypole/Component/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Maypole
+@unexec rmdir %D/%%SITE_PERL%%/Maypole 2>/dev/null || true