aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorkoobs <koobs@FreeBSD.org>2014-08-23 22:03:26 +0800
committerkoobs <koobs@FreeBSD.org>2014-08-23 22:03:26 +0800
commit5cc66f200b39cfeb3b4e52c347a04ca715e0c6a8 (patch)
treeda1b23817a23d4eac045315e953fd1af109157b4 /www
parentb117a5a869f4a8fd64f853421821f2f31066b8d3 (diff)
downloadfreebsd-ports-gnome-5cc66f200b39cfeb3b4e52c347a04ca715e0c6a8.tar.gz
freebsd-ports-gnome-5cc66f200b39cfeb3b4e52c347a04ca715e0c6a8.tar.zst
freebsd-ports-gnome-5cc66f200b39cfeb3b4e52c347a04ca715e0c6a8.zip
[NEW] www/geeknote: Command line client for Evernote
Geeknote is a command line client for Evernote. Features: * Create notes in your Evernote account * Create tags, notebooks * Use Evernote search in console with different filters * Edit notes in console using any editor: nano, vim, emacs, mcedit * Sync your local files, directories with Evernote * Use Evernote with cron or any scripts WWW: http://www.geeknote.me
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/geeknote/Makefile30
-rw-r--r--www/geeknote/distinfo2
-rw-r--r--www/geeknote/pkg-descr12
-rw-r--r--www/geeknote/pkg-plist1
5 files changed, 46 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 843c44d00f41..c0dd7a1c964d 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -232,6 +232,7 @@
SUBDIR += gecko-mediaplayer
SUBDIR += gecko-sharp20
SUBDIR += geeklog
+ SUBDIR += geeknote
SUBDIR += geneweb
SUBDIR += geolizer
SUBDIR += geronimo
diff --git a/www/geeknote/Makefile b/www/geeknote/Makefile
new file mode 100644
index 000000000000..2862d1de9830
--- /dev/null
+++ b/www/geeknote/Makefile
@@ -0,0 +1,30 @@
+# Created by: Kubilay Kocak <koobs@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= geeknote
+DISTVERSION= 0.2a
+CATEGORIES= www python
+
+MAINTAINER= koobs@FreeBSD.org
+COMMENT= Command line client for Evernote
+
+LICENSE= GPLv2
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}evernote>=1.17:${PORTSDIR}/www/py-evernote \
+ ${PYTHON_PKGNAMEPREFIX}html2text>0:${PORTSDIR}/textproc/py-html2text \
+ ${PYTHON_PKGNAMEPREFIX}sqlalchemy>0:${PORTSDIR}/databases/py-sqlalchemy \
+ ${PYTHON_PKGNAMEPREFIX}markdown2>0:${PORTSDIR}/textproc/py-markdown2 \
+ ${PYTHON_PKGNAMEPREFIX}beautifulsoup>=4.0:${PORTSDIR}/www/py-beautifulsoup \
+ ${PYTHON_PKGNAMEPREFIX}thrift>0:${PORTSDIR}/devel/py-thrift
+
+USES= dos2unix python:-2.7
+USE_GITHUB= yes
+USE_PYTHON= autoplist distutils
+GH_ACCOUNT= VitaliyRodnenko
+GH_COMMIT= 192a0c5
+GH_TAGNAME= ${GH_COMMIT}
+
+regression-test: build
+ @cd ${WRKSRC} && ${PYTHON_CMD} ${PYDISTUTILS_SETUP} test
+
+.include <bsd.port.mk>
diff --git a/www/geeknote/distinfo b/www/geeknote/distinfo
new file mode 100644
index 000000000000..78dae5036ff5
--- /dev/null
+++ b/www/geeknote/distinfo
@@ -0,0 +1,2 @@
+SHA256 (geeknote-0.2a.tar.gz) = e6040c420f39e92910a5135d477f0093e1ff5ebcdd8ea330e35e65f5b568bcd7
+SIZE (geeknote-0.2a.tar.gz) = 31970
diff --git a/www/geeknote/pkg-descr b/www/geeknote/pkg-descr
new file mode 100644
index 000000000000..eae2e64bb816
--- /dev/null
+++ b/www/geeknote/pkg-descr
@@ -0,0 +1,12 @@
+Geeknote is a command line client for Evernote.
+
+Features:
+
+ * Create notes in your Evernote account
+ * Create tags, notebooks
+ * Use Evernote search in console with different filters
+ * Edit notes in console using any editor: nano, vim, emacs, mcedit
+ * Sync your local files, directories with Evernote
+ * Use Evernote with cron or any scripts
+
+WWW: http://www.geeknote.me
diff --git a/www/geeknote/pkg-plist b/www/geeknote/pkg-plist
new file mode 100644
index 000000000000..8fb5cc4556d5
--- /dev/null
+++ b/www/geeknote/pkg-plist
@@ -0,0 +1 @@
+@comment $FreeBSD$