aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2016-10-21 23:21:13 +0800
committermat <mat@FreeBSD.org>2016-10-21 23:21:13 +0800
commit60e51bda11dcc0742419f2a459990d0d81cb07d8 (patch)
treea5029ff30555b3a7ee0621f4dd5aacb832fde1d8 /www
parent3432585b4743642027fc2b3af5eac2780fc2c4cd (diff)
downloadfreebsd-ports-gnome-60e51bda11dcc0742419f2a459990d0d81cb07d8.tar.gz
freebsd-ports-gnome-60e51bda11dcc0742419f2a459990d0d81cb07d8.tar.zst
freebsd-ports-gnome-60e51bda11dcc0742419f2a459990d0d81cb07d8.zip
Use USES=pathfix where applicable.
PR: 213195 Submitted by: mat Exp-run by: antoine Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D8093
Diffstat (limited to 'www')
-rw-r--r--www/libhtp-suricata/Makefile1
-rw-r--r--www/mod_webauth/Makefile4
-rw-r--r--www/nghttp2/Makefile1
-rw-r--r--www/trafficserver/Makefile2
-rw-r--r--www/trafficserver/files/patch-tools_Makefile.in11
-rw-r--r--www/varnish4/Makefile4
-rw-r--r--www/webkit-gtk2/Makefile5
-rw-r--r--www/webkit-gtk3/Makefile5
-rw-r--r--www/webkit-sharp/Makefile1
-rw-r--r--www/yaws/Makefile1
10 files changed, 7 insertions, 28 deletions
diff --git a/www/libhtp-suricata/Makefile b/www/libhtp-suricata/Makefile
index 680277f1a8ae..089683882626 100644
--- a/www/libhtp-suricata/Makefile
+++ b/www/libhtp-suricata/Makefile
@@ -18,7 +18,6 @@ USE_LDCONFIG= yes
CONFLICTS_INSTALL= libhtp-[0-9]*
-PATHFIX_MAKEFILEIN= Makefile.am
INSTALL_TARGET= install-strip
.include <bsd.port.mk>
diff --git a/www/mod_webauth/Makefile b/www/mod_webauth/Makefile
index ee4fb78377bc..22f29c96ae96 100644
--- a/www/mod_webauth/Makefile
+++ b/www/mod_webauth/Makefile
@@ -13,7 +13,7 @@ COMMENT= Apache module for authenticating users with Kerberos v5
LIB_DEPENDS= libcurl.so:ftp/curl \
libsasl2.so:security/cyrus-sasl2
-USES= libtool pkgconfig ssl
+USES= libtool pathfix pkgconfig ssl
USE_APACHE= 22+
USE_OPENLDAP= yes
USE_LDCONFIG= yes
@@ -25,8 +25,6 @@ LDFLAGS+= -L${LOCALBASE}/lib
INSTALL_TARGET= install-strip
post-patch:
- @${REINPLACE_CMD} -e 's|libdir)/pkgconfig|prefix)/libdata/pkgconfig|' \
- ${WRKSRC}/Makefile.in ${WRKSRC}/Makefile.am
@${REINPLACE_CMD} -e '/typedef int sig_atomic_t/d' \
${WRKSRC}/portable/system.h
diff --git a/www/nghttp2/Makefile b/www/nghttp2/Makefile
index 0a3a1030fb44..05f1b8b0b83b 100644
--- a/www/nghttp2/Makefile
+++ b/www/nghttp2/Makefile
@@ -28,7 +28,6 @@ CONFIGURE_ENV= OPENSSL_CFLAGS="-I${OPENSSLINC}" \
ZLIB_LIBS="-L${LIBDIR} -lz"
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
-PATHFIX_MAKEFILEIN= Makefile.am
USE_CXXSTD= c++11
USE_LDCONFIG= yes
USES= autoreconf compiler:c++11-lib gmake libtool localbase pathfix pkgconfig ssl
diff --git a/www/trafficserver/Makefile b/www/trafficserver/Makefile
index 1f9c6b3241c6..5ebc29d231a1 100644
--- a/www/trafficserver/Makefile
+++ b/www/trafficserver/Makefile
@@ -18,7 +18,7 @@ LIB_DEPENDS= libcurl.so:ftp/curl \
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
-USES= cpe execinfo gmake libtool perl5 pkgconfig sqlite ssl tar:bzip2 tcl
+USES= cpe execinfo gmake libtool pathfix perl5 pkgconfig sqlite ssl tar:bzip2 tcl
CPE_VENDOR= apache
CPE_PRODUCT= traffic_server
USE_PERL5= build run
diff --git a/www/trafficserver/files/patch-tools_Makefile.in b/www/trafficserver/files/patch-tools_Makefile.in
deleted file mode 100644
index 482621cec7c1..000000000000
--- a/www/trafficserver/files/patch-tools_Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- tools/Makefile.in.orig 2015-06-30 04:11:56 UTC
-+++ tools/Makefile.in
-@@ -614,7 +614,7 @@ valuesh = @valuesh@
- waith = @waith@
- zlibh = @zlibh@
- bin_SCRIPTS = tsxs tspush
--pkgconfigdir = $(libdir)/pkgconfig
-+pkgconfigdir = $(prefix)/libdata/pkgconfig
- pkgconfig_DATA = trafficserver.pc
- AM_LDFLAGS = @EXTRA_CXX_LDFLAGS@ @LIBTOOL_LINK_FLAGS@
- AM_CPPFLAGS = $(iocore_include_dirs) \
diff --git a/www/varnish4/Makefile b/www/varnish4/Makefile
index b15cead63d01..904c794852ba 100644
--- a/www/varnish4/Makefile
+++ b/www/varnish4/Makefile
@@ -17,7 +17,7 @@ LIB_DEPENDS= libpcre.so:devel/pcre
CONFLICTS= varnish-2.* varnish-3.*
BROKEN_arm= does not configure
-USES= autoreconf cpe gmake libedit libtool pkgconfig python:2,build \
+USES= autoreconf cpe gmake libedit libtool pathfix pkgconfig python:2,build \
readline shebangfix
SHEBANG_FILES= lib/libvcc/vmodtool.py
CPE_VENDOR= varnish-cache
@@ -39,8 +39,6 @@ EXTRA_PATCHES+= ${FILESDIR}/no-inet6.patch
.endif
post-patch:
- @${REINPLACE_CMD} -e 's|\$$(libdir)/pkgconfig|\$$(prefix)/libdata/pkgconfig|' \
- ${WRKSRC}/Makefile.am
.if defined(BAD_TESTS)
${RM} ${BAD_TESTS:C|.+|${WRKSRC}/bin/varnishtest/tests/\0.vtc|}
.endif
diff --git a/www/webkit-gtk2/Makefile b/www/webkit-gtk2/Makefile
index c828c0707911..5c4d86e28f24 100644
--- a/www/webkit-gtk2/Makefile
+++ b/www/webkit-gtk2/Makefile
@@ -29,7 +29,8 @@ PORTSCOUT= limit:^2\.4\.
USE_GSTREAMER1= yes
USE_XORG= xt xdamage xcomposite
USES= bison compiler:c++11-lib gettext gmake gperf libtool localbase \
- perl5 pkgconfig shebangfix sqlite tar:xz
+ pathfix perl5 pkgconfig shebangfix sqlite tar:xz
+PATHFIX_MAKEFILEIN= GNUmakefile.in
USE_RUBY= yes
RUBY_NO_RUN_DEPENDS=yes
USE_GNOME= cairo gtk20 introspection:build libxslt
@@ -100,8 +101,6 @@ post-patch:
# Since ruby 2.2 there is no ruby symlink
@${REINPLACE_CMD} -e 's|ruby|${RUBY_NAME}|g' \
${WRKSRC}/configure
- @${FIND} ${WRKSRC} -name GNUmakefile.in | ${XARGS} ${REINPLACE_CMD} -e \
- 's|[(]libdir[)]/pkgconfig|(prefix)/libdata/pkgconfig|g'
post-install:
${INSTALL_PROGRAM} ${WRKSRC}/Programs/GtkLauncher \
diff --git a/www/webkit-gtk3/Makefile b/www/webkit-gtk3/Makefile
index 36d615d82e9c..88263a29ff89 100644
--- a/www/webkit-gtk3/Makefile
+++ b/www/webkit-gtk3/Makefile
@@ -29,7 +29,8 @@ PORTSCOUT= limit:^2\.4\.
USE_GSTREAMER1= yes
USE_XORG= xt xdamage xcomposite
USES= bison compiler:c++11-lib gettext gmake gperf libtool localbase \
- perl5 pkgconfig shebangfix sqlite tar:xz
+ pathfix perl5 pkgconfig shebangfix sqlite tar:xz
+PATHFIX_MAKEFILEIN= GNUmakefile.in
USE_RUBY= yes
RUBY_NO_RUN_DEPENDS=yes
USE_GNOME= cairo gtk20 gtk30 introspection:build libxslt
@@ -107,8 +108,6 @@ post-patch:
# Since ruby 2.2 there is no ruby symlink
@${REINPLACE_CMD} -e 's|ruby|${RUBY_NAME}|g' \
${WRKSRC}/configure
- @${FIND} ${WRKSRC} -name GNUmakefile.in | ${XARGS} ${REINPLACE_CMD} -e \
- 's|[(]libdir[)]/pkgconfig|(prefix)/libdata/pkgconfig|g'
post-install:
${INSTALL_PROGRAM} ${WRKSRC}/Programs/GtkLauncher \
diff --git a/www/webkit-sharp/Makefile b/www/webkit-sharp/Makefile
index 07e9c962d50d..d7b9129b6128 100644
--- a/www/webkit-sharp/Makefile
+++ b/www/webkit-sharp/Makefile
@@ -19,6 +19,5 @@ PLIST_SUB+= ASSEMBLY_VERSION=1.1.15
GNU_CONFIGURE= yes
USES= autoreconf gmake mono pathfix pkgconfig
USE_GNOME= gtksharp20
-PATHFIX_MAKEFILEIN= Makefile.am
.include <bsd.port.mk>
diff --git a/www/yaws/Makefile b/www/yaws/Makefile
index 8a7f30716d2c..f9266b20f164 100644
--- a/www/yaws/Makefile
+++ b/www/yaws/Makefile
@@ -29,7 +29,6 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --localstatedir=/var
CONFIGURE_ENV= wwwdir=${WWWDIR} yawsdir=${APPDIR}
INSTALL_TARGET= install-strip
-PATHFIX_MAKEFILEIN=Makefile.am
.include <bsd.port.options.mk>