aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorwen <wen@FreeBSD.org>2012-10-07 15:19:37 +0800
committerwen <wen@FreeBSD.org>2012-10-07 15:19:37 +0800
commit62d6b118a56900fc99316866af16e2321f42fdc2 (patch)
tree729e5a8955bfb46ba051c9e52d5adfbfef34e766 /www
parent1451bdffe0e6e4ff1a02c8fdd25f8f4549c3861d (diff)
downloadfreebsd-ports-gnome-62d6b118a56900fc99316866af16e2321f42fdc2.tar.gz
freebsd-ports-gnome-62d6b118a56900fc99316866af16e2321f42fdc2.tar.zst
freebsd-ports-gnome-62d6b118a56900fc99316866af16e2321f42fdc2.zip
- Convert to new Makefile format
- Convert to new options framework
Diffstat (limited to 'www')
-rw-r--r--www/mediawiki/Makefile52
1 files changed, 26 insertions, 26 deletions
diff --git a/www/mediawiki/Makefile b/www/mediawiki/Makefile
index 089dd14f17d8..c779fca3848f 100644
--- a/www/mediawiki/Makefile
+++ b/www/mediawiki/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: www/mediawiki
-# Date created: February 1st 2005
-# Whom: Gerrit Beine <tux@pinguru.net>
-#
+# Created by: Gerrit Beine <tux@pinguru.net>
# $FreeBSD$
-#
PORTNAME= mediawiki
PORTVERSION= 1.19.2
@@ -19,47 +15,51 @@ CONFLICTS= mediawiki-1.1[0-8].*
FETCH_ARGS= -pr
USE_PHP= ctype iconv mbstring pcre session xml zlib readline dom
-IGNORE_WITH_PHP= 4
+IGNORE_WITH_PHP=4
WANT_PHP_WEB= yes
MEDIAWIKIDIR?= www/mediawiki
NO_BUILD= yes
-OPTIONS= PGSQL "Use PostgreSQL (instead of MySQL)" off \
- SQLITE "Use SQLite (instead of MySQL)" off \
- LDAP "Use LDAP authentication" off \
- MEMCACHED "Use memcached" off \
- APC "Use pecl-APC(Mediawiki recommended)" on \
- EACCEL "Use eAccelerator (instead of pecl-APC)" off \
- IMAGICK "Use ImageMagick" off
+OPTIONS_DEFINE= MYSQL PGSQL SQLITE LDAP MEMCACHED APC EACCEL IMAGICK
+OPTIONS_DEFAULT=MYSQL APC
-.include <bsd.port.pre.mk>
+MEMCACHED_DESCR=use memcached
+APC_DESCR= use pecl-APC(Mediawiki recommended)
+EACCEL_DESCR= use eAccelerator (instead of pecl-APC)
+IMAGICK_DESCR= use ImageMagick
-.if defined(WITH_PGSQL)
-USE_PHP+= pgsql
-.elif defined(WITH_SQLITE)
-USE_PHP+= sqlite
-.else
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MMYSQL}
USE_MYSQL= server
USE_PHP+= mysql
.endif
-.if defined(WITH_LDAP)
+.if ${PORT_OPTIONS:MPGSQL}
+USE_PHP+= pgsql
+.endif
+
+.if ${PORT_OPTIONS:MSQLITE}
+USE_PHP+= sqlite
+.endif
+
+.if ${PORT_OPTIONS:MLDAP}
USE_PHP+= ldap
.endif
-.if defined(WITH_MEMCACHED)
+.if ${PORT_OPTIONS:MMEMCACHED}
RUN_DEPENDS= memcached:${PORTSDIR}/databases/memcached
.endif
-.if defined(WITH_IMAGICK)
+.if ${PORT_OPTIONS:MIMAGICK}
RUN_DEPENDS+= ${LOCALBASE}/lib/php/${PHP_EXT_DIR}/imagick.so:${PORTSDIR}/graphics/pecl-imagick
.endif
-.if defined(WITH_APC) || defined(WITH_EACCEL)||defined(WITH_XCACHE)
-.if defined(WITH_EACCEL)
+.if ${PORT_OPTIONS:MAPC} || ${PORTS_OPTIONS:MEACCEL} || ${PORTS_OPTIONS:MXCACHE}
+.if ${PORT_OPTIONS:MEACCEL}
RUN_DEPENDS+= ${LOCALBASE}/lib/php/${PHP_EXT_DIR}/eaccelerator.so:${PORTSDIR}/www/eaccelerator
-.elif defined(WITH_XCACHE)
+.elif ${PORT_OPTIONS:MXCACHE}
RUN_DEPENDS+= ${LOCALBASE}/lib/php/${PHP_EXT_DIR}/xcache.so:${PORTSDIR}/www/xcache
.else
RUN_DEPENDS+= ${LOCALBASE}/lib/php/${PHP_EXT_DIR}/apc.so:${PORTSDIR}/www/pecl-APC
@@ -78,4 +78,4 @@ post-install:
| ${SED} -ne 's,^${WRKSRC},@dirrm ${MEDIAWIKIDIR},p' >> ${TMPPLIST}
@${SED} -e 's|%%MEDIAWIKIDIR%%|${PREFIX}/${MEDIAWIKIDIR}|' ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>