aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2005-09-27 01:14:52 +0800
committermarcus <marcus@FreeBSD.org>2005-09-27 01:14:52 +0800
commit6341bed56064fa35a85ca9f86206c9dba6feca26 (patch)
treedcbb0d917079c5ac6d7a306e0114b071774e2641 /www
parent1af05fdb957cae4d1b43f08e555d400069466138 (diff)
downloadfreebsd-ports-gnome-6341bed56064fa35a85ca9f86206c9dba6feca26.tar.gz
freebsd-ports-gnome-6341bed56064fa35a85ca9f86206c9dba6feca26.tar.zst
freebsd-ports-gnome-6341bed56064fa35a85ca9f86206c9dba6feca26.zip
* Respect ${GMAKE} to fix a build problem on FreeBSD 4.X [1]
* Make sure we look in ${LOCALBASE} for headers and libs to get i18n support working PR: 86575 [1]
Diffstat (limited to 'www')
-rw-r--r--www/mplayer-plugin/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/www/mplayer-plugin/Makefile b/www/mplayer-plugin/Makefile
index 4686c017302c..1b44b854cb7c 100644
--- a/www/mplayer-plugin/Makefile
+++ b/www/mplayer-plugin/Makefile
@@ -7,6 +7,7 @@
PORTNAME= mplayerplug-in
PORTVERSION= 3.11
+PORTREVISION= 1
CATEGORIES= www multimedia
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= mplayerplug-in
@@ -33,8 +34,8 @@ PLUGINSFILES= mplayerplug-in.so mplayerplug-in.xpt mplayerplug-in-wmp.so \
mplayerplug-in-qt.so mplayerplug-in-rm.so mplayerplug-in-gmp.so
GNU_CONFIGURE= yes
CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ENV= CPPFLAGS="-I${X11BASE}/include -DBSD" \
- LDFLAGS="-L${X11BASE}/lib"
+CONFIGURE_ENV= CPPFLAGS="-I${X11BASE}/include -I${LOCALBASE}/include -DBSD" \
+ LDFLAGS="-L${X11BASE}/lib -L${LOCALBASE}/lib"
.if !defined(WITH_MOZILLA)
HEADERS_SUFX=
@@ -70,7 +71,8 @@ pre-everything::
@${ECHO_MSG} ""
post-patch:
- @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' \
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
+ s|make|${GMAKE}|g' \
${WRKSRC}/Makefile.in
.if defined(WITH_MOZILLA) && ${WITH_MOZILLA}=="firefox"
@${REINPLACE_CMD} -e 's|mozilla-|firefox-|g' ${WRKSRC}/configure