aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorclement <clement@FreeBSD.org>2005-05-22 22:51:54 +0800
committerclement <clement@FreeBSD.org>2005-05-22 22:51:54 +0800
commit743eae920497d9f2d1bd8c4cf217079e5d2fa0f8 (patch)
treeffd8aaa5657afd3678f44974383885bc0cadf778 /www
parentbef472cb4492be097f130b0a5113466b02dd3889 (diff)
downloadfreebsd-ports-gnome-743eae920497d9f2d1bd8c4cf217079e5d2fa0f8.tar.gz
freebsd-ports-gnome-743eae920497d9f2d1bd8c4cf217079e5d2fa0f8.tar.zst
freebsd-ports-gnome-743eae920497d9f2d1bd8c4cf217079e5d2fa0f8.zip
- Fix weird logic for detection apache13 with ipv6
Noticed by: Tarc <tarc@po.cs.msu.su> PR: ports/78451 pointy hat to: clement
Diffstat (limited to 'www')
-rw-r--r--www/mod_perl/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/www/mod_perl/Makefile b/www/mod_perl/Makefile
index c668940069ed..462e1ab203a5 100644
--- a/www/mod_perl/Makefile
+++ b/www/mod_perl/Makefile
@@ -40,8 +40,13 @@ MAN3= Apache.3 Apache::Constants.3 Apache::ExtUtils.3 \
Apache::PerlSections.3 cgi_to_mod_perl.3 \
mod_perl_cvs.3 mod_perl_method_handlers.3 mod_perl_traps.3 \
mod_perl_tuning.3
+.if defined(APACHE_PORT)
+. if ${APACHE_PORT:Mipv6} != ""
+WITH_APACHE_IPV6= YES
+. endif
+.endif
-.if defined(WITH_APACHE_IPV6) && ${APACHE_PORT:Mipv6}
+.if defined(WITH_APACHE_IPV6)
CFLAGS+= -DAPACHE6
.endif