aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2014-01-29 15:59:00 +0800
committermiwi <miwi@FreeBSD.org>2014-01-29 15:59:00 +0800
commit7a36662c7b467960b8c5858a057b9738ee9fa697 (patch)
tree367fbdcf2caa5b460154afabff273c0e67ce1746 /www
parentfa7604e01549c4eb1e788dd0831ccb8fa8bbefd0 (diff)
downloadfreebsd-ports-gnome-7a36662c7b467960b8c5858a057b9738ee9fa697.tar.gz
freebsd-ports-gnome-7a36662c7b467960b8c5858a057b9738ee9fa697.tar.zst
freebsd-ports-gnome-7a36662c7b467960b8c5858a057b9738ee9fa697.zip
- Stage support
Diffstat (limited to 'www')
-rw-r--r--www/cadaver/Makefile5
-rw-r--r--www/p5-Amon2/Makefile27
-rw-r--r--www/p5-Amon2/pkg-plist25
-rw-r--r--www/p5-WWW-Shorten-Bitly/Makefile4
-rw-r--r--www/p5-WWW-Shorten-Bitly/pkg-plist2
5 files changed, 29 insertions, 34 deletions
diff --git a/www/cadaver/Makefile b/www/cadaver/Makefile
index d20e34a900bb..db8ff802e23e 100644
--- a/www/cadaver/Makefile
+++ b/www/cadaver/Makefile
@@ -17,13 +17,12 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-netrc
ALL_TARGET= cadaver
-MAN1= cadaver.1
-PLIST_FILES= bin/cadaver
+PLIST_FILES= bin/cadaver \
+ man/man1/cadaver.1.gz
# Neither expat nor libneon are needed at all, but the configure
# script breaks if it can not find the Makefile* in them. Exclude
# them to be sure, a stray .h is not included instead of what's
-NO_STAGE= yes
# found under PREFIX (installed by the neon port):
EXTRACT_AFTER_ARGS= \
--exclude '${PORTNAME}-${PORTVERSION}/lib/expat/*.[ch]' \
diff --git a/www/p5-Amon2/Makefile b/www/p5-Amon2/Makefile
index e721fe0a6b0e..1ca1dd26ef2b 100644
--- a/www/p5-Amon2/Makefile
+++ b/www/p5-Amon2/Makefile
@@ -24,31 +24,4 @@ TEST_DEPENDS= \
USES= perl5
USE_PERL5= modbuild
-MAN1= amon2-setup.pl.1
-MAN3= Amon2.3 \
- Amon2::Config::Simple.3 \
- Amon2::Declare.3 \
- Amon2::Plugin::Web::CSRFDefender.3 \
- Amon2::Plugin::Web::FillInFormLite.3 \
- Amon2::Plugin::Web::HTTPSession.3 \
- Amon2::Plugin::Web::JSON.3 \
- Amon2::Plugin::Web::NoCache.3 \
- Amon2::Plugin::Web::PlackSession.3 \
- Amon2::Plugin::Web::Streaming.3 \
- Amon2::Plugin::Web::WebSocket.3 \
- Amon2::Setup::Flavor.3 \
- Amon2::Setup::Flavor::Basic.3 \
- Amon2::Setup::Flavor::Large.3 \
- Amon2::Setup::Flavor::Minimum.3 \
- Amon2::Trigger.3 \
- Amon2::Util.3 \
- Amon2::Web.3 \
- Amon2::Web::Dispatcher::Lite.3 \
- Amon2::Web::Dispatcher::RouterSimple.3 \
- Amon2::Web::Request.3 \
- Amon2::Web::Response.3 \
- Amon2::Web::Response::Callback.3 \
- Amon2::Web::WebSocket.3
-
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/www/p5-Amon2/pkg-plist b/www/p5-Amon2/pkg-plist
index 413ef95de338..d12cd30f1301 100644
--- a/www/p5-Amon2/pkg-plist
+++ b/www/p5-Amon2/pkg-plist
@@ -1,4 +1,29 @@
bin/amon2-setup.pl
+%%PERL5_MAN3%%/Amon2.3.gz
+%%PERL5_MAN3%%/Amon2::Config::Simple.3.gz
+%%PERL5_MAN3%%/Amon2::Declare.3.gz
+%%PERL5_MAN3%%/Amon2::Plugin::Web::CSRFDefender.3.gz
+%%PERL5_MAN3%%/Amon2::Plugin::Web::FillInFormLite.3.gz
+%%PERL5_MAN3%%/Amon2::Plugin::Web::HTTPSession.3.gz
+%%PERL5_MAN3%%/Amon2::Plugin::Web::JSON.3.gz
+%%PERL5_MAN3%%/Amon2::Plugin::Web::NoCache.3.gz
+%%PERL5_MAN3%%/Amon2::Plugin::Web::PlackSession.3.gz
+%%PERL5_MAN3%%/Amon2::Plugin::Web::Streaming.3.gz
+%%PERL5_MAN3%%/Amon2::Plugin::Web::WebSocket.3.gz
+%%PERL5_MAN3%%/Amon2::Setup::Flavor.3.gz
+%%PERL5_MAN3%%/Amon2::Setup::Flavor::Basic.3.gz
+%%PERL5_MAN3%%/Amon2::Setup::Flavor::Large.3.gz
+%%PERL5_MAN3%%/Amon2::Setup::Flavor::Minimum.3.gz
+%%PERL5_MAN3%%/Amon2::Trigger.3.gz
+%%PERL5_MAN3%%/Amon2::Util.3.gz
+%%PERL5_MAN3%%/Amon2::Web.3.gz
+%%PERL5_MAN3%%/Amon2::Web::Dispatcher::Lite.3.gz
+%%PERL5_MAN3%%/Amon2::Web::Dispatcher::RouterSimple.3.gz
+%%PERL5_MAN3%%/Amon2::Web::Request.3.gz
+%%PERL5_MAN3%%/Amon2::Web::Response.3.gz
+%%PERL5_MAN3%%/Amon2::Web::Response::Callback.3.gz
+%%PERL5_MAN3%%/Amon2::Web::WebSocket.3.gz
+man/man1/amon2-setup.pl.1.gz
%%SITE_PERL%%/Amon2.pm
%%SITE_PERL%%/Amon2/Config/Simple.pm
%%SITE_PERL%%/Amon2/ContextGuard.pm
diff --git a/www/p5-WWW-Shorten-Bitly/Makefile b/www/p5-WWW-Shorten-Bitly/Makefile
index 8070dc092d97..dc403bca3d8e 100644
--- a/www/p5-WWW-Shorten-Bitly/Makefile
+++ b/www/p5-WWW-Shorten-Bitly/Makefile
@@ -18,8 +18,4 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
USES= perl5
USE_PERL5= configure
-MAN1= bitly_url.1
-MAN3= WWW::Shorten::Bitly.3
-
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/www/p5-WWW-Shorten-Bitly/pkg-plist b/www/p5-WWW-Shorten-Bitly/pkg-plist
index c702f21c0c0d..dfdfacdee5db 100644
--- a/www/p5-WWW-Shorten-Bitly/pkg-plist
+++ b/www/p5-WWW-Shorten-Bitly/pkg-plist
@@ -1,4 +1,6 @@
bin/bitly_url
+%%PERL5_MAN3%%/WWW::Shorten::Bitly.3.gz
+man/man1/bitly_url.1.gz
%%SITE_PERL%%/WWW/Shorten/Bitly.pm
%%SITE_PERL%%/%%PERL_ARCH%%/auto/WWW/Shorten/Bitly/.packlist
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/WWW/Shorten/Bitly