aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorbrnrd <brnrd@FreeBSD.org>2016-07-02 18:29:47 +0800
committerbrnrd <brnrd@FreeBSD.org>2016-07-02 18:29:47 +0800
commit7af89cd91929b1200d3e5d9957619d07759abbe2 (patch)
treed8198c81cc62327ef5838fbcf0c449c4133b0b2b /www
parent4c89e591b82aff2726c238b0b46586ed460a44bb (diff)
downloadfreebsd-ports-gnome-7af89cd91929b1200d3e5d9957619d07759abbe2.tar.gz
freebsd-ports-gnome-7af89cd91929b1200d3e5d9957619d07759abbe2.tar.zst
freebsd-ports-gnome-7af89cd91929b1200d3e5d9957619d07759abbe2.zip
www/links-hacked: Fix build without RAND_egd
- Add patch for building without EGD (OpenSSL 1.1/LibreSSL) - Move from USE_OPENSSL to USES=ssl PR: 198766
Diffstat (limited to 'www')
-rw-r--r--www/links-hacked/Makefile3
-rw-r--r--www/links-hacked/files/patch-https.c14
2 files changed, 15 insertions, 2 deletions
diff --git a/www/links-hacked/Makefile b/www/links-hacked/Makefile
index 53394e329a5b..a8b0c60e7b5e 100644
--- a/www/links-hacked/Makefile
+++ b/www/links-hacked/Makefile
@@ -12,8 +12,7 @@ COMMENT= Hacked version of a Links WWW browser
LICENSE= GPLv2
-USES= autoreconf execinfo
-USE_OPENSSL= yes
+USES= autoreconf execinfo ssl
USE_CSTD= gnu89
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-ssl --without-pmshell --without-atheos --without-fb
diff --git a/www/links-hacked/files/patch-https.c b/www/links-hacked/files/patch-https.c
new file mode 100644
index 000000000000..8703e89f1dce
--- /dev/null
+++ b/www/links-hacked/files/patch-https.c
@@ -0,0 +1,14 @@
+--- https.c.orig 2008-06-07 07:41:41 UTC
++++ https.c
+@@ -15,7 +15,10 @@ SSL *getSSL(void)
+ char f_randfile[PATH_MAX];
+
+ if (!context) {
+- if (RAND_egd(RAND_file_name(f_randfile, sizeof(f_randfile)))<0){
++#ifndef OPENSSL_NO_EGD
++ if (RAND_egd(RAND_file_name(f_randfile, sizeof(f_randfile)))<0)
++#endif
++ {
+ /* Not an EGD, so read and write to it */
+ if (RAND_load_file(f_randfile, -1))
+ RAND_write_file(f_randfile);