aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorclement <clement@FreeBSD.org>2003-12-19 00:22:57 +0800
committerclement <clement@FreeBSD.org>2003-12-19 00:22:57 +0800
commit7b9319a6f011578e797b82d853b6bb78a832a254 (patch)
tree5c3f94e525a220a5f83f30107e68a91a439f8338 /www
parente4addd5d597b3a178632cdc599c984cb09584277 (diff)
downloadfreebsd-ports-gnome-7b9319a6f011578e797b82d853b6bb78a832a254.tar.gz
freebsd-ports-gnome-7b9319a6f011578e797b82d853b6bb78a832a254.tar.zst
freebsd-ports-gnome-7b9319a6f011578e797b82d853b6bb78a832a254.zip
- Add CONFLICTS with apache-contrib-1.*
Approved by: erwin (mentor)
Diffstat (limited to 'www')
-rw-r--r--www/mod_auth_external/Makefile2
-rw-r--r--www/mod_bandwidth/Makefile2
-rw-r--r--www/mod_cvs/Makefile2
-rw-r--r--www/mod_fastcgi/Makefile2
-rw-r--r--www/mod_layout/Makefile2
-rw-r--r--www/mod_put/Makefile2
-rw-r--r--www/mod_roaming/Makefile2
-rw-r--r--www/mod_ticket/Makefile2
8 files changed, 16 insertions, 0 deletions
diff --git a/www/mod_auth_external/Makefile b/www/mod_auth_external/Makefile
index b3c49f004ecc..455e51382940 100644
--- a/www/mod_auth_external/Makefile
+++ b/www/mod_auth_external/Makefile
@@ -18,6 +18,8 @@ USE_APACHE= yes
DOCDIR= ${PREFIX}/share/doc/${PORTNAME}
DOCS= AUTHENTICATORS CHANGES INSTALL README TODO
+CONFLICTS= apache-contrib-1.*
+
do-build:
@cd ${WRKSRC} && ${APXS} -c mod_auth_external.c
diff --git a/www/mod_bandwidth/Makefile b/www/mod_bandwidth/Makefile
index 25c0868cdfdc..48db876d535d 100644
--- a/www/mod_bandwidth/Makefile
+++ b/www/mod_bandwidth/Makefile
@@ -20,6 +20,8 @@ COMMENT= Bandwidth management module for the Apache webserver
USE_APACHE= YES
USE_PERL5= YES
+CONFLICTS= apache-contrib-1.*
+
do-build:
@(cd ${WRKSRC} && ${APXS} -c ${PORTNAME}.c)
diff --git a/www/mod_cvs/Makefile b/www/mod_cvs/Makefile
index 4b64eccda49f..8bcd1b53e82a 100644
--- a/www/mod_cvs/Makefile
+++ b/www/mod_cvs/Makefile
@@ -16,6 +16,8 @@ MASTER_SITE_SUBDIR= petef
MAINTAINER= petef@FreeBSD.org
COMMENT= A module that makes Apache CVS aware
+CONFLICTS= apache-contrib-1.*
+
USE_APACHE= yes
USE_REINPLACE= yes
MAKE_ARGS+= APXS="${APXS}"
diff --git a/www/mod_fastcgi/Makefile b/www/mod_fastcgi/Makefile
index e0adbc1e2852..ff1cbba9d5d0 100644
--- a/www/mod_fastcgi/Makefile
+++ b/www/mod_fastcgi/Makefile
@@ -16,6 +16,8 @@ COMMENT= A fast-cgi module for Apache
BUILD_DEPENDS= ${APXS}:${PORTSDIR}/${APACHE_PORT}
+CONFLICTS= apache-contrib-1.*
+
.if defined(WITH_APACHE2)
MAKEFILE= Makefile.AP2
USE_REINPLACE= YES
diff --git a/www/mod_layout/Makefile b/www/mod_layout/Makefile
index f7dfb9c31deb..16bcf06f959f 100644
--- a/www/mod_layout/Makefile
+++ b/www/mod_layout/Makefile
@@ -16,6 +16,8 @@ COMMENT= Apache module to wrap served pages with a header and/or footer
USE_APACHE= yes
USE_REINPLACE= yes
+CONFLICTS= mod_layout-4.* apache-contrib-1.*
+
CFLAGS+= -fPIC
post-patch:
diff --git a/www/mod_put/Makefile b/www/mod_put/Makefile
index 65386294bf07..db75e786f0a3 100644
--- a/www/mod_put/Makefile
+++ b/www/mod_put/Makefile
@@ -17,6 +17,8 @@ COMMENT= An Apache module that provides PUT and DELETE methods
USE_APACHE= yes
DIST_SUBDIR= ${PORTNAME}-${PORTVERSION}
+CONFLICTS= apache-contrib-1.*
+
do-build:
cd ${WRKSRC} && ${LOCALBASE}/sbin/apxs -c ${PORTNAME}.c
diff --git a/www/mod_roaming/Makefile b/www/mod_roaming/Makefile
index 4c8a4adaadf5..4349a6e588c0 100644
--- a/www/mod_roaming/Makefile
+++ b/www/mod_roaming/Makefile
@@ -17,6 +17,8 @@ COMMENT= An Apache module that works as a Netscape Roaming Access server
USE_APACHE= yes
DOCS= CHANGES INSTALL LICENSE README
+CONFLICTS= apache-contrib-1.*
+
do-build:
@cd ${WRKSRC} && \
${APXS} -c mod_roaming.c
diff --git a/www/mod_ticket/Makefile b/www/mod_ticket/Makefile
index 2f48bdb85524..15facf8e9b64 100644
--- a/www/mod_ticket/Makefile
+++ b/www/mod_ticket/Makefile
@@ -18,6 +18,8 @@ COMMENT= Apache module for a digitally signed ticket in URL
USE_APACHE= yes
+CONFLICTS= apache-contrib-1.*
+
do-extract:
${MKDIR} ${WRKSRC}
${CP} ${DISTDIR}/${DISTFILES} ${WRKSRC}