aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorcpm <cpm@FreeBSD.org>2017-10-01 05:11:24 +0800
committercpm <cpm@FreeBSD.org>2017-10-01 05:11:24 +0800
commit7d8367e460750ba88bf7bd601509214b08dd0726 (patch)
treec727cbfc41a89bea132e0160add1102547671640 /www
parent08b7070ca4e104aa15d17b182c53ba1a1356588d (diff)
downloadfreebsd-ports-gnome-7d8367e460750ba88bf7bd601509214b08dd0726.tar.gz
freebsd-ports-gnome-7d8367e460750ba88bf7bd601509214b08dd0726.tar.zst
freebsd-ports-gnome-7d8367e460750ba88bf7bd601509214b08dd0726.zip
www/go-www: Update to 1.1.1
- Now capable of creating valid certificates by passing ACME letsencrypt * option -s "valid-domain.tld" will create a valid certificate (listen on port 443) * if using -s "localhost" it will create a self-signed certificate - Update comment and WWW in pkg-descr PR: 222236 Submitted by: Nicolas Embriz <nbari@tequila.io> (maintainer)
Diffstat (limited to 'www')
-rw-r--r--www/go-www/Makefile22
-rw-r--r--www/go-www/distinfo10
-rw-r--r--www/go-www/pkg-descr6
3 files changed, 18 insertions, 20 deletions
diff --git a/www/go-www/Makefile b/www/go-www/Makefile
index 76f22c706072..7f7fcbf009f4 100644
--- a/www/go-www/Makefile
+++ b/www/go-www/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= www
-PORTVERSION= 0.3.1
+PORTVERSION= 1.1.1
CATEGORIES= www
PKGNAMEPREFIX= go-
@@ -15,26 +15,24 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
USES= go
USE_GITHUB= yes
-GH_ACCOUNT= nbari:DEFAULT,violetear
-GH_PROJECT= violetear:violetear
-GH_TAGNAME= 2.2.0:violetear
-
-GO_PKGNAME= github.com/${GH_ACCOUNT}/${GH_PROJECT}
+GH_ACCOUNT= nbari:DEFAULT
+GH_TUPLE= golang:crypto:847319b:crypto/src/golang.org/x/crypto
+GH_SUBDIR= src/github.com/nbari/${PORTNAME}
STRIP= # stripping can break go binaries
PLIST_FILES= bin/www
post-patch:
- @${LN} -sf ${WRKDIR}/${GH_PROJECT_violetear}-${GH_TAGNAME_violetear} \
- ${GO_WRKDIR_SRC}/github.com/${GH_ACCOUNT_violetear}/${GH_PROJECT_violetear}
+ @${MKDIR} ${WRKSRC}/src/golang.org
+ @${LN} -sf ${LOCALBASE}/share/go/src/golang.org/x ${WRKSRC}/src/golang.org/x
do-build:
- @(cd ${GO_WRKSRC} && \
- ${SETENV} ${BUILD_ENV} GOPATH=${WRKDIR} go build -ldflags \
- "-X main.version=${PORTVERSION}" -o www cmd/www/main.go)
+ @cd ${WRKSRC}/src/github.com/${GH_ACCOUNT}/${GH_PROJECT}; \
+ ${SETENV} ${BUILD_ENV} GOPATH=${WRKSRC} go build -ldflags \
+ "-s -w" -o www;
do-install:
- ${INSTALL_PROGRAM} ${GO_WRKSRC}/www ${STAGEDIR}${PREFIX}/bin/www
+ ${INSTALL_PROGRAM} ${WRKSRC}/www ${STAGEDIR}${PREFIX}/bin/www
.include <bsd.port.mk>
diff --git a/www/go-www/distinfo b/www/go-www/distinfo
index 5b4b649e5402..af1bc04c93c2 100644
--- a/www/go-www/distinfo
+++ b/www/go-www/distinfo
@@ -1,5 +1,5 @@
-TIMESTAMP = 1486283285
-SHA256 (nbari-www-0.3.1_GH0.tar.gz) = 322612b8ad3167df0a6bf84b283db958f670d6f0e4770376ae24fc4ea39d9f68
-SIZE (nbari-www-0.3.1_GH0.tar.gz) = 3633
-SHA256 (nbari-violetear-2.2.0_GH0.tar.gz) = a71a2355548ae5adef5578552dc522c1a6174f9ac88b36db25c8bba1c39ab01e
-SIZE (nbari-violetear-2.2.0_GH0.tar.gz) = 14408
+TIMESTAMP = 1506548170
+SHA256 (nbari-www-1.1.1_GH0.tar.gz) = eea1a8beb69556d984eed63967c569c7bace2add3752a94241de0def5df012eb
+SIZE (nbari-www-1.1.1_GH0.tar.gz) = 4211
+SHA256 (golang-crypto-847319b_GH0.tar.gz) = f471dac9d970154c00dba9b9772752f0feb368713ee1b11418d22f11ba6fd5df
+SIZE (golang-crypto-847319b_GH0.tar.gz) = 1432733
diff --git a/www/go-www/pkg-descr b/www/go-www/pkg-descr
index ca4be27d2177..7c4a1c6a199c 100644
--- a/www/go-www/pkg-descr
+++ b/www/go-www/pkg-descr
@@ -1,8 +1,8 @@
www is a static web server, useful for sharing and testing the contents of a
-directory via HTTP.
+directory via HTTP or HTTPS with a valid certificate.
www will start a web server listening on port 8000 and use as document root
the directory where the command was called. Different document root may be
-specified as also the port and use of SSL, more info using the -h option.
+specified as also the port and use of TLS, more info using the -h option.
-WWW: https://github.com/nbari/www
+WWW: https://go-www.com