aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorosa <osa@FreeBSD.org>2014-09-19 09:27:24 +0800
committerosa <osa@FreeBSD.org>2014-09-19 09:27:24 +0800
commit8158d7d60e56cea76129ecebe20e286d0c2383fc (patch)
treeeac7acf4c0a0cd2b8edd331e204ea1e89a28ac80 /www
parent8d5d611d5c8244a8f82210fc8154130cda86dba3 (diff)
downloadfreebsd-ports-gnome-8158d7d60e56cea76129ecebe20e286d0c2383fc.tar.gz
freebsd-ports-gnome-8158d7d60e56cea76129ecebe20e286d0c2383fc.tar.zst
freebsd-ports-gnome-8158d7d60e56cea76129ecebe20e286d0c2383fc.zip
Update third-party rtmp module from 1.1.4 to 1.1.5.
Fix compilation issue (1). Do not bump PORTREVISION. Obtained from: https://github.com/arut/nginx-rtmp-module/commit/dd5f2aa117c617e1f0fde26f8fd58903be2d85e8.patch (1)
Diffstat (limited to 'www')
-rw-r--r--www/nginx-devel/Makefile4
-rw-r--r--www/nginx-devel/distinfo4
-rw-r--r--www/nginx-devel/files/extra-patch-arut-rtmp-module78
-rw-r--r--www/nginx/Makefile3
-rw-r--r--www/nginx/distinfo4
-rw-r--r--www/nginx/files/extra-patch-arut-rtmp-module78
6 files changed, 164 insertions, 7 deletions
diff --git a/www/nginx-devel/Makefile b/www/nginx-devel/Makefile
index eae86ee3efab..5e9770e461c7 100644
--- a/www/nginx-devel/Makefile
+++ b/www/nginx-devel/Makefile
@@ -687,11 +687,11 @@ CONFIGURE_ARGS+=--add-module=${WRKDIR}/openresty-redis2-nginx-module-${GIT_REDIS
.endif
.if ${PORT_OPTIONS:MRTMP}
-IGNORE= RTMP: update require
-NGINX_RTMP_VERSION= 1.1.4
+NGINX_RTMP_VERSION= 1.1.5
MASTER_SITES+= https://github.com/arut/nginx-rtmp-module/archive/v${NGINX_RTMP_VERSION}/:rtmp
DISTFILES+= rtmp-nginx-module-v${NGINX_RTMP_VERSION}.tar.gz:rtmp
CONFIGURE_ARGS+=--add-module=${WRKDIR}/nginx-rtmp-module-${NGINX_RTMP_VERSION}
+EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-arut-rtmp-module
.endif
.if ${PORT_OPTIONS:MSET_MISC}
diff --git a/www/nginx-devel/distinfo b/www/nginx-devel/distinfo
index e1d9f176f5d4..9ab5007ac335 100644
--- a/www/nginx-devel/distinfo
+++ b/www/nginx-devel/distinfo
@@ -84,8 +84,8 @@ SHA256 (openresty-redis2-nginx-module-v0.10-0-g78a7622.tar.gz) = 76606bf3b548b07
SIZE (openresty-redis2-nginx-module-v0.10-0-g78a7622.tar.gz) = 29850
SHA256 (alibaba-nginx-footer-filter-1.2.2-0-g3572184.tar.gz) = 48a23f879416c0d8da5795c419b94f1ffa42ee06602545f494db4d9aba646e8f
SIZE (alibaba-nginx-footer-filter-1.2.2-0-g3572184.tar.gz) = 3934
-SHA256 (rtmp-nginx-module-v1.1.4.tar.gz) = 076efef9698076fa23622e093cfb3959e4d14fcd6e9dcdf0b8e6d9154c720dc9
-SIZE (rtmp-nginx-module-v1.1.4.tar.gz) = 517774
+SHA256 (rtmp-nginx-module-v1.1.5.tar.gz) = 990467fed853b8eecd9b1b10050e2406071d705896be452539be8eced24adf4a
+SIZE (rtmp-nginx-module-v1.1.5.tar.gz) = 519507
SHA256 (openresty-set-misc-nginx-module-v0.24-0-g36fd035.tar.gz) = 5475877d67a952beaf0b726b96d0c9abf48ccfc27367a6bebb5738e04d054a76
SIZE (openresty-set-misc-nginx-module-v0.24-0-g36fd035.tar.gz) = 40390
SHA256 (nginx-sflow-module-0.9.7.tar.gz) = 508d15a43059abab08281bfa66d2dd520e2e7635d0b17043549bb331c8755b76
diff --git a/www/nginx-devel/files/extra-patch-arut-rtmp-module b/www/nginx-devel/files/extra-patch-arut-rtmp-module
new file mode 100644
index 000000000000..8f356b4afaf4
--- /dev/null
+++ b/www/nginx-devel/files/extra-patch-arut-rtmp-module
@@ -0,0 +1,78 @@
+diff --git a/ngx_rtmp.c b/ngx_rtmp.c
+index c079c90..e525a93 100644
+--- ../nginx-rtmp-module-1.1.5/ngx_rtmp.c.orig
++++ ../nginx-rtmp-module-1.1.5/ngx_rtmp.c
+@@ -31,7 +31,11 @@ static char * ngx_rtmp_merge_applications(ngx_conf_t *cf,
+ ngx_uint_t ctx_index);
+
+
++#if (nginx_version >= 1007005)
++ngx_thread_volatile ngx_queue_t ngx_rtmp_init_queue;
++#else
+ ngx_thread_volatile ngx_event_t *ngx_rtmp_init_queue;
++#endif
+
+
+ ngx_uint_t ngx_rtmp_max_module;
+diff --git a/ngx_rtmp.h b/ngx_rtmp.h
+index d3648f7..b87e99e 100644
+--- ../nginx-rtmp-module-1.1.5/ngx_rtmp.h
++++ ../nginx-rtmp-module-1.1.5/ngx_rtmp.h
+@@ -12,6 +12,7 @@
+ #include <ngx_core.h>
+ #include <ngx_event.h>
+ #include <ngx_event_connect.h>
++#include <nginx.h>
+
+ #include "ngx_rtmp_amf.h"
+ #include "ngx_rtmp_bandwidth.h"
+@@ -198,7 +199,11 @@ typedef struct {
+ ngx_str_t *addr_text;
+ int connected;
+
++#if (nginx_version >= 1007005)
++ ngx_queue_t posted_dry_events;
++#else
+ ngx_event_t *posted_dry_events;
++#endif
+
+ /* client buffer time in msec */
+ uint32_t buflen;
+@@ -602,7 +607,11 @@ extern ngx_rtmp_bandwidth_t ngx_rtmp_bw_in;
+
+
+ extern ngx_uint_t ngx_rtmp_naccepted;
++#if (nginx_version >= 1007005)
++extern ngx_thread_volatile ngx_queue_t ngx_rtmp_init_queue;
++#else
+ extern ngx_thread_volatile ngx_event_t *ngx_rtmp_init_queue;
++#endif
+
+ extern ngx_uint_t ngx_rtmp_max_module;
+ extern ngx_module_t ngx_rtmp_core_module;
+diff --git a/ngx_rtmp_play_module.c b/ngx_rtmp_play_module.c
+index acaa46c..f6ea6c3 100644
+--- ../nginx-rtmp-module-1.1.5/ngx_rtmp_play_module.c
++++ ../nginx-rtmp-module-1.1.5/ngx_rtmp_play_module.c
+@@ -6,6 +6,7 @@
+
+ #include <ngx_config.h>
+ #include <ngx_core.h>
++#include <nginx.h>
+ #include "ngx_rtmp_play_module.h"
+ #include "ngx_rtmp_cmd_module.h"
+ #include "ngx_rtmp_netcall_module.h"
+@@ -430,7 +431,12 @@ ngx_rtmp_play_do_stop(ngx_rtmp_session_t *s)
+ ngx_del_timer(&ctx->send_evt);
+ }
+
+- if (ctx->send_evt.prev) {
++#if (nginx_version >= 1007005)
++ if (ctx->send_evt.posted)
++#else
++ if (ctx->send_evt.prev)
++#endif
++ {
+ ngx_delete_posted_event((&ctx->send_evt));
+ }
+
diff --git a/www/nginx/Makefile b/www/nginx/Makefile
index 812291c4b206..4a35bef1182b 100644
--- a/www/nginx/Makefile
+++ b/www/nginx/Makefile
@@ -699,10 +699,11 @@ CONFIGURE_ARGS+=--add-module=${WRKDIR}/openresty-redis2-nginx-module-${GIT_REDIS
.endif
.if ${PORT_OPTIONS:MRTMP}
-NGINX_RTMP_VERSION= 1.1.4
+NGINX_RTMP_VERSION= 1.1.5
MASTER_SITES+= https://github.com/arut/nginx-rtmp-module/archive/v${NGINX_RTMP_VERSION}/:rtmp
DISTFILES+= rtmp-nginx-module-v${NGINX_RTMP_VERSION}.tar.gz:rtmp
CONFIGURE_ARGS+=--add-module=${WRKDIR}/nginx-rtmp-module-${NGINX_RTMP_VERSION}
+EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-arut-rtmp-module
.endif
.if ${PORT_OPTIONS:MSET_MISC}
diff --git a/www/nginx/distinfo b/www/nginx/distinfo
index ba355b868fc1..3f8fa63c8453 100644
--- a/www/nginx/distinfo
+++ b/www/nginx/distinfo
@@ -86,8 +86,8 @@ SHA256 (openresty-redis2-nginx-module-v0.10-0-g78a7622.tar.gz) = 76606bf3b548b07
SIZE (openresty-redis2-nginx-module-v0.10-0-g78a7622.tar.gz) = 29850
SHA256 (alibaba-nginx-footer-filter-1.2.2-0-g3572184.tar.gz) = 48a23f879416c0d8da5795c419b94f1ffa42ee06602545f494db4d9aba646e8f
SIZE (alibaba-nginx-footer-filter-1.2.2-0-g3572184.tar.gz) = 3934
-SHA256 (rtmp-nginx-module-v1.1.4.tar.gz) = 076efef9698076fa23622e093cfb3959e4d14fcd6e9dcdf0b8e6d9154c720dc9
-SIZE (rtmp-nginx-module-v1.1.4.tar.gz) = 517774
+SHA256 (rtmp-nginx-module-v1.1.5.tar.gz) = 990467fed853b8eecd9b1b10050e2406071d705896be452539be8eced24adf4a
+SIZE (rtmp-nginx-module-v1.1.5.tar.gz) = 519507
SHA256 (openresty-set-misc-nginx-module-v0.24-0-g36fd035.tar.gz) = 5475877d67a952beaf0b726b96d0c9abf48ccfc27367a6bebb5738e04d054a76
SIZE (openresty-set-misc-nginx-module-v0.24-0-g36fd035.tar.gz) = 40390
SHA256 (nginx-sflow-module-0.9.7.tar.gz) = 508d15a43059abab08281bfa66d2dd520e2e7635d0b17043549bb331c8755b76
diff --git a/www/nginx/files/extra-patch-arut-rtmp-module b/www/nginx/files/extra-patch-arut-rtmp-module
new file mode 100644
index 000000000000..8f356b4afaf4
--- /dev/null
+++ b/www/nginx/files/extra-patch-arut-rtmp-module
@@ -0,0 +1,78 @@
+diff --git a/ngx_rtmp.c b/ngx_rtmp.c
+index c079c90..e525a93 100644
+--- ../nginx-rtmp-module-1.1.5/ngx_rtmp.c.orig
++++ ../nginx-rtmp-module-1.1.5/ngx_rtmp.c
+@@ -31,7 +31,11 @@ static char * ngx_rtmp_merge_applications(ngx_conf_t *cf,
+ ngx_uint_t ctx_index);
+
+
++#if (nginx_version >= 1007005)
++ngx_thread_volatile ngx_queue_t ngx_rtmp_init_queue;
++#else
+ ngx_thread_volatile ngx_event_t *ngx_rtmp_init_queue;
++#endif
+
+
+ ngx_uint_t ngx_rtmp_max_module;
+diff --git a/ngx_rtmp.h b/ngx_rtmp.h
+index d3648f7..b87e99e 100644
+--- ../nginx-rtmp-module-1.1.5/ngx_rtmp.h
++++ ../nginx-rtmp-module-1.1.5/ngx_rtmp.h
+@@ -12,6 +12,7 @@
+ #include <ngx_core.h>
+ #include <ngx_event.h>
+ #include <ngx_event_connect.h>
++#include <nginx.h>
+
+ #include "ngx_rtmp_amf.h"
+ #include "ngx_rtmp_bandwidth.h"
+@@ -198,7 +199,11 @@ typedef struct {
+ ngx_str_t *addr_text;
+ int connected;
+
++#if (nginx_version >= 1007005)
++ ngx_queue_t posted_dry_events;
++#else
+ ngx_event_t *posted_dry_events;
++#endif
+
+ /* client buffer time in msec */
+ uint32_t buflen;
+@@ -602,7 +607,11 @@ extern ngx_rtmp_bandwidth_t ngx_rtmp_bw_in;
+
+
+ extern ngx_uint_t ngx_rtmp_naccepted;
++#if (nginx_version >= 1007005)
++extern ngx_thread_volatile ngx_queue_t ngx_rtmp_init_queue;
++#else
+ extern ngx_thread_volatile ngx_event_t *ngx_rtmp_init_queue;
++#endif
+
+ extern ngx_uint_t ngx_rtmp_max_module;
+ extern ngx_module_t ngx_rtmp_core_module;
+diff --git a/ngx_rtmp_play_module.c b/ngx_rtmp_play_module.c
+index acaa46c..f6ea6c3 100644
+--- ../nginx-rtmp-module-1.1.5/ngx_rtmp_play_module.c
++++ ../nginx-rtmp-module-1.1.5/ngx_rtmp_play_module.c
+@@ -6,6 +6,7 @@
+
+ #include <ngx_config.h>
+ #include <ngx_core.h>
++#include <nginx.h>
+ #include "ngx_rtmp_play_module.h"
+ #include "ngx_rtmp_cmd_module.h"
+ #include "ngx_rtmp_netcall_module.h"
+@@ -430,7 +431,12 @@ ngx_rtmp_play_do_stop(ngx_rtmp_session_t *s)
+ ngx_del_timer(&ctx->send_evt);
+ }
+
+- if (ctx->send_evt.prev) {
++#if (nginx_version >= 1007005)
++ if (ctx->send_evt.posted)
++#else
++ if (ctx->send_evt.prev)
++#endif
++ {
+ ngx_delete_posted_event((&ctx->send_evt));
+ }
+