aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorolivierd <olivierd@FreeBSD.org>2014-08-23 21:17:14 +0800
committerolivierd <olivierd@FreeBSD.org>2014-08-23 21:17:14 +0800
commit8804a8dcd4fdcba629f4908d07562eef07d5b228 (patch)
tree25d634b09be5362524e6fba2a7fef89d0a7964f6 /www
parent56045d3fdf8f5ce87a5522b3c5dbaab9d02332b6 (diff)
downloadfreebsd-ports-gnome-8804a8dcd4fdcba629f4908d07562eef07d5b228.tar.gz
freebsd-ports-gnome-8804a8dcd4fdcba629f4908d07562eef07d5b228.tar.zst
freebsd-ports-gnome-8804a8dcd4fdcba629f4908d07562eef07d5b228.zip
- Update to 1.4.0
- Switch to USES= python - Add LICENSE_FILE
Diffstat (limited to 'www')
-rw-r--r--www/py-bjoern/Makefile8
-rw-r--r--www/py-bjoern/distinfo4
-rw-r--r--www/py-bjoern/files/patch-bjoern__server.c14
3 files changed, 20 insertions, 6 deletions
diff --git a/www/py-bjoern/Makefile b/www/py-bjoern/Makefile
index cc36e50bc0ea..6fe24e4678d7 100644
--- a/www/py-bjoern/Makefile
+++ b/www/py-bjoern/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= bjoern
-PORTVERSION= 1.3.4
+PORTVERSION= 1.4.0
CATEGORIES= www python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -11,12 +11,12 @@ MAINTAINER= olivierd@FreeBSD.org
COMMENT= Fast Python WSGI server
LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libev.so:${PORTSDIR}/devel/libev
-USE_PYTHON= 2
-USE_PYDISTUTILS= yes
-PYDISTUTILS_AUTOPLIST= yes
+USES= python:2
+USE_PYTHON= distutils autoplist
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib -lc
diff --git a/www/py-bjoern/distinfo b/www/py-bjoern/distinfo
index 8f7431ccede2..fbdb487e1fba 100644
--- a/www/py-bjoern/distinfo
+++ b/www/py-bjoern/distinfo
@@ -1,2 +1,2 @@
-SHA256 (bjoern-1.3.4.tar.gz) = b3c175a326b7baff92739f384cda47644f71940acce89b049cf3a8fbc90d13cd
-SIZE (bjoern-1.3.4.tar.gz) = 26322
+SHA256 (bjoern-1.4.0.tar.gz) = eea48ebd63b8a545f65801d8f3568ac0e5c17c8d80eaa537e463ee38f98d678e
+SIZE (bjoern-1.4.0.tar.gz) = 25985
diff --git a/www/py-bjoern/files/patch-bjoern__server.c b/www/py-bjoern/files/patch-bjoern__server.c
new file mode 100644
index 000000000000..0d69b3392c28
--- /dev/null
+++ b/www/py-bjoern/files/patch-bjoern__server.c
@@ -0,0 +1,14 @@
+--- ./bjoern/server.c.orig 2013-12-08 21:38:42.000000000 +0000
++++ ./bjoern/server.c 2014-08-23 14:45:32.000000000 +0000
+@@ -1,6 +1,11 @@
+ #ifdef WANT_SIGINT_HANDLING
+ # include <sys/signal.h>
+ #endif
++#if defined __FreeBSD__
++#include <netinet/in.h> /* struct sockaddr_in */
++#include <sys/types.h>
++#include <sys/socket.h>
++#endif
+ #include <arpa/inet.h>
+ #include <fcntl.h>
+ #include <ev.h>