aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2017-04-04 17:38:15 +0800
committersunpoet <sunpoet@FreeBSD.org>2017-04-04 17:38:15 +0800
commit9059a2e8c7f52696c26fb4bd93f0e87c7dfbecdf (patch)
tree9324ab9189978c0e008e27b71ce33114c2b4c0a8 /www
parenta6aead19c1469dbc40c645290f120f1e7f1e228c (diff)
downloadfreebsd-ports-gnome-9059a2e8c7f52696c26fb4bd93f0e87c7dfbecdf.tar.gz
freebsd-ports-gnome-9059a2e8c7f52696c26fb4bd93f0e87c7dfbecdf.tar.zst
freebsd-ports-gnome-9059a2e8c7f52696c26fb4bd93f0e87c7dfbecdf.zip
Add xapian-omega12 1.2.24 (copied from xapian-omega)
- Update LIB_DEPENDS - Add CONFLICTS_INSTALL - Convert to options target helper - Update WWW - Bump PORTREVISION for dependent ports
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/ikiwiki/Makefile5
-rw-r--r--www/xapian-omega12/Makefile59
-rw-r--r--www/xapian-omega12/distinfo3
-rw-r--r--www/xapian-omega12/pkg-descr5
-rw-r--r--www/xapian-omega12/pkg-plist9
6 files changed, 80 insertions, 2 deletions
diff --git a/www/Makefile b/www/Makefile
index 8b686b344207..d5d528502b76 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -2371,6 +2371,7 @@
SUBDIR += www6to4
SUBDIR += wwwoffle
SUBDIR += xapian-omega
+ SUBDIR += xapian-omega12
SUBDIR += xaraya
SUBDIR += xcache
SUBDIR += xfce4-smartbookmark-plugin
diff --git a/www/ikiwiki/Makefile b/www/ikiwiki/Makefile
index 9f81f27c592b..18ea2027c3d9 100644
--- a/www/ikiwiki/Makefile
+++ b/www/ikiwiki/Makefile
@@ -3,6 +3,7 @@
PORTNAME= ikiwiki
PORTVERSION= 3.20170111
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= DEBIAN_POOL \
LOCAL/mat/${PORTNAME}
@@ -54,8 +55,8 @@ MULTI_DESC= Install Text::MultiMarkdown
PO4A_RUN_DEPENDS= po4a>=0.39:textproc/po4a
PO4A_BUILD_DEPENDS= po4a>=0.39:textproc/po4a
SEARCH_RUN_DEPENDS= p5-Digest-SHA1>=0:security/p5-Digest-SHA1 \
- p5-Search-Xapian>=0:databases/p5-Search-Xapian \
- ${LOCALBASE}/www/xapian-omega/cgi-bin/omega:www/xapian-omega
+ p5-Search-Xapian12>=0:databases/p5-Search-Xapian12 \
+ ${LOCALBASE}/www/xapian-omega/cgi-bin/omega:www/xapian-omega12
MULTI_RUN_DEPENDS= p5-Text-MultiMarkdown>=0:textproc/p5-Text-MultiMarkdown
PORTDOCS= CHANGELOG NEWS README
diff --git a/www/xapian-omega12/Makefile b/www/xapian-omega12/Makefile
new file mode 100644
index 000000000000..6fe4f3210d0c
--- /dev/null
+++ b/www/xapian-omega12/Makefile
@@ -0,0 +1,59 @@
+# Created by: Henrik Brix Andersen <brix@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= xapian-omega
+PORTVERSION= 1.2.24
+CATEGORIES= www
+MASTER_SITES= http://oligarchy.co.uk/xapian/${PORTVERSION}/ \
+ LOCAL/sunpoet
+PKGNAMESUFFIX= 12
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= CGI search application built on Xapian
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LIB_DEPENDS= libpcre.so:devel/pcre \
+ libxapian.so:databases/xapian-core12
+
+CONFLICTS_INSTALL= xapian-omega-
+
+OPTIONS_DEFINE= DOCS EXAMPLES ICONV
+OPTIONS_DEFAULT=ICONV
+ICONV_DESC= Enable iconv character set conversion support
+
+PORTSCOUT= limitw:1,even
+
+CONFIGURE_ARGS= --datarootdir=${DATADIR} --docdir=${DOCSDIR}
+CONFIGURE_ENV= PCRE_CONFIG=${LOCALBASE}/bin/pcre-config \
+ XAPIAN_CONFIG=${LOCALBASE}/bin/xapian-config
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+USES= libtool localbase perl5 shebangfix tar:xz
+
+MORE_PORTDOCS= AUTHORS ChangeLog NEWS README TODO
+PORTDATA= *
+PORTDOCS= *
+PORTEXAMPLES= omega.conf
+
+SHEBANG_FILES= dbi2omega htdig2omega mbox2omega
+
+ICONV_CONFIGURE_ON= ac_cv_search_iconv=${ICONV_LIB}
+ICONV_CONFIGURE_WITH= iconv
+ICONV_USES= iconv
+
+post-patch:
+ @${REINPLACE_CMD} \
+ -e '/^dist_sysconf_DATA = /d' \
+ -e '/^pkglibbindir = / s| = .*$$| = ${WWWDIR}/cgi-bin|' \
+ ${WRKSRC}/Makefile.in
+
+post-install-DOCS-on:
+ cd ${WRKSRC}/ && ${INSTALL_DATA} ${MORE_PORTDOCS} ${STAGEDIR}${DOCSDIR}/
+
+post-install-EXAMPLES-on:
+ ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}/
+ cd ${WRKSRC}/ && ${INSTALL_DATA} ${PORTEXAMPLES} ${STAGEDIR}${EXAMPLESDIR}/
+
+.include <bsd.port.mk>
diff --git a/www/xapian-omega12/distinfo b/www/xapian-omega12/distinfo
new file mode 100644
index 000000000000..6b6185b660da
--- /dev/null
+++ b/www/xapian-omega12/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1475135073
+SHA256 (xapian-omega-1.2.24.tar.xz) = 45fca431b812ddacbd592b522389474317af386b3ab554908edd36fc5918da53
+SIZE (xapian-omega-1.2.24.tar.xz) = 438104
diff --git a/www/xapian-omega12/pkg-descr b/www/xapian-omega12/pkg-descr
new file mode 100644
index 000000000000..7133ba9a62fe
--- /dev/null
+++ b/www/xapian-omega12/pkg-descr
@@ -0,0 +1,5 @@
+This package contains two index building utilities (omindex and scriptindex) and
+a CGI search application (omega). These use the Xapian search library to
+provide a search over a collection of documents.
+
+WWW: https://xapian.org/
diff --git a/www/xapian-omega12/pkg-plist b/www/xapian-omega12/pkg-plist
new file mode 100644
index 000000000000..6f96a45f18f1
--- /dev/null
+++ b/www/xapian-omega12/pkg-plist
@@ -0,0 +1,9 @@
+bin/dbi2omega
+bin/htdig2omega
+bin/mbox2omega
+bin/omindex
+bin/scriptindex
+man/man1/omindex.1.gz
+man/man1/scriptindex.1.gz
+%%WWWDIR%%/cgi-bin/omega
+%%WWWDIR%%/cgi-bin/outlookmsg2html