aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authornivit <nivit@FreeBSD.org>2014-07-12 07:16:20 +0800
committernivit <nivit@FreeBSD.org>2014-07-12 07:16:20 +0800
commit99ae77da88b1006537516971748e7532c8371b43 (patch)
treeac9108b3b40eef9c3b1c752be3c31a43b4ba80f5 /www
parent1e5cd6a3f1d570ab1cd3adf2fa83c374f15bb0ed (diff)
downloadfreebsd-ports-gnome-99ae77da88b1006537516971748e7532c8371b43.tar.gz
freebsd-ports-gnome-99ae77da88b1006537516971748e7532c8371b43.tar.zst
freebsd-ports-gnome-99ae77da88b1006537516971748e7532c8371b43.zip
- Fix build on 8.X and 9.X, where make(1) does not support
the @ modifier PR: 191765 Submitted by: Dan Lukes <dan@obluda.cz>
Diffstat (limited to 'www')
-rw-r--r--www/apache-forrest/Makefile11
1 files changed, 7 insertions, 4 deletions
diff --git a/www/apache-forrest/Makefile b/www/apache-forrest/Makefile
index 9768614dbf1c..6ee1fc6b6bb8 100644
--- a/www/apache-forrest/Makefile
+++ b/www/apache-forrest/Makefile
@@ -16,9 +16,12 @@ COMMENT= Tool for rapid development of small sites
ANT= ${STAGEDIR}${DATADIR}/tools/ant/bin/ant
ANT_TARGET= local-deploy
-IGNORE_FILES= KEYS README.txt .gitignore *.bak *.bat \
- *.orig forrest ant index.html
-IGNORE_FILES:= ${IGNORE_FILES:@f@-and ! -name ${f}@}
+IGNORE_FILES= ! -name *\.bak -and ! -name *\.bat \
+ -and ! -name *\.orig -and ! -name .gitignore \
+ -and ! -name KEYS -and ! -name README.txt \
+ -and ! -name ant -and ! -name forrest \
+ -and ! -name index.html
+
INSTALL_WRKSRC= ${WRKSRC}/build
JAVA_VERSION= 1.6+
@@ -42,7 +45,7 @@ post-patch:
do-install:
@cd ${WRKSRC}; \
- ${COPYTREE_SHARE} . ${STAGEDIR}${DATADIR} '${IGNORE_FILES:[2..-1]}'
+ ${COPYTREE_SHARE} . ${STAGEDIR}${DATADIR} '${IGNORE_FILES}'
@${INSTALL_SCRIPT} ${WRKSRC}/bin/forrest ${STAGEDIR}${DATADIR}/bin/forrest
@${INSTALL_SCRIPT} ${WRKSRC}/tools/ant/bin/ant ${STAGEDIR}${DATADIR}/tools/ant/bin/ant
@${LN} -sf ../${DATADIR_REL}/bin/forrest ${STAGEDIR}${PREFIX}/bin/forrest