aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2011-12-21 05:41:42 +0800
committerpawel <pawel@FreeBSD.org>2011-12-21 05:41:42 +0800
commit9a4c0e8404f8504b2276ece4f5d51acc46d2a81d (patch)
tree5896099eb8e1e2b9777d16b73e29551c948c0ad5 /www
parent7341a43bf509e2637e91afca88bd249134dfb65e (diff)
downloadfreebsd-ports-gnome-9a4c0e8404f8504b2276ece4f5d51acc46d2a81d.tar.gz
freebsd-ports-gnome-9a4c0e8404f8504b2276ece4f5d51acc46d2a81d.tar.zst
freebsd-ports-gnome-9a4c0e8404f8504b2276ece4f5d51acc46d2a81d.zip
Volta is a high performance, low resource URI rewriter for use with the
Squid caching proxy server (http://www.squid-cache.org) With it, you can dynamically alter URI requests that pass through Squid based on various criteria. It uses a state machine to parse URIs and rules, and a constant database to store and access those rules. WWW: http://projects.martini.nu/volta/ PR: ports/162935 Submitted by: Mahlon E. Smith
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/volta/Makefile47
-rw-r--r--www/volta/distinfo2
-rw-r--r--www/volta/files/pkg-message.in10
-rw-r--r--www/volta/pkg-descr9
5 files changed, 69 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index c4af77c20878..99a2bdef641b 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1900,6 +1900,7 @@
SUBDIR += vee
SUBDIR += videocache
SUBDIR += visitors
+ SUBDIR += volta
SUBDIR += vtiger
SUBDIR += vtiger-customerportal
SUBDIR += w3m
diff --git a/www/volta/Makefile b/www/volta/Makefile
new file mode 100644
index 000000000000..674971790f13
--- /dev/null
+++ b/www/volta/Makefile
@@ -0,0 +1,47 @@
+# New ports collection makefile for: volta
+# Date created: 28 November 2011
+# Whom: mahlon
+#
+# $FreeBSD$
+#
+
+PORTNAME= volta
+DISTVERSION= 0.0.1
+CATEGORIES= www
+MASTER_SITES= http://dl.dropbox.com/u/7234177/Releases/ \
+ http://projects.martini.nu/volta/chrome/site/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= mahlon@martini.nu
+COMMENT= A high performance, low resource URI rewriter for Squid
+
+LICENSE= BSD
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= cdb:${PORTSDIR}/databases/tinycdb
+
+USE_GMAKE= yes
+ALL_TARGET= ${PORTNAME}
+NO_INSTALL= yes
+
+CFLAGS+= -I${PREFIX}/include
+LDFLAGS+= -L${PREFIX}/lib
+
+PLIST_FILES= bin/volta
+PORTDOCS= README INSTALL LICENSE ChangeLog
+SUB_FILES= pkg-message
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/INSTALL ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/LICENSE ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/ChangeLog ${DOCSDIR}
+.endif
+ ${INSTALL_PROGRAM} ${WRKSRC}/volta ${PREFIX}/bin
+ @${ECHO_CMD} ""
+ @${CAT} ${PKGMESSAGE}
+ @${ECHO_CMD} ""
+
+.include <bsd.port.mk>
diff --git a/www/volta/distinfo b/www/volta/distinfo
new file mode 100644
index 000000000000..23ee67e70b09
--- /dev/null
+++ b/www/volta/distinfo
@@ -0,0 +1,2 @@
+SHA256 (volta-0.0.1.tgz) = 27646819ea1cf86f12a2e1cf3974d118c045df81f4f6ebbf003de8f4782c4e7f
+SIZE (volta-0.0.1.tgz) = 24212
diff --git a/www/volta/files/pkg-message.in b/www/volta/files/pkg-message.in
new file mode 100644
index 000000000000..580426ab6704
--- /dev/null
+++ b/www/volta/files/pkg-message.in
@@ -0,0 +1,10 @@
+To get volta up and running, you'll still need to do two things:
+
+ - Enable url rewriting from within the squid configuration file.
+
+ url_rewrite_children 10
+ url_rewrite_program %%PREFIX%%/bin/volta -f %%PREFIX%%/etc/volta.db
+
+ - Create a volta rule database! For detailed instructions, please
+ reference %%DATADIR%%/README, or volta's website at:
+ http://projects.martini.nu/volta/
diff --git a/www/volta/pkg-descr b/www/volta/pkg-descr
new file mode 100644
index 000000000000..1f60d0bf6ea1
--- /dev/null
+++ b/www/volta/pkg-descr
@@ -0,0 +1,9 @@
+Volta is a high performance, low resource URI rewriter for use with the
+Squid caching proxy server (http://www.squid-cache.org) With it, you
+can dynamically alter URI requests that pass through Squid based on
+various criteria.
+
+It uses a state machine to parse URIs and rules, and a constant database
+to store and access those rules.
+
+WWW: http://projects.martini.nu/volta/