aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authoryuri <yuri@FreeBSD.org>2017-12-23 12:54:42 +0800
committeryuri <yuri@FreeBSD.org>2017-12-23 12:54:42 +0800
commita3e6a86cb1df0afd1bb9cbf0dcd9aa197d00bddb (patch)
tree5912cfca2724e416cc81498827b27ecdb95e5200 /www
parent53aa018d53d972e18eec1ccbd908431c8acde57d (diff)
downloadfreebsd-ports-gnome-a3e6a86cb1df0afd1bb9cbf0dcd9aa197d00bddb.tar.gz
freebsd-ports-gnome-a3e6a86cb1df0afd1bb9cbf0dcd9aa197d00bddb.tar.zst
freebsd-ports-gnome-a3e6a86cb1df0afd1bb9cbf0dcd9aa197d00bddb.zip
New port: www/py-cheroot: Highly-optimized, pure-python HTTP server
PR: 222193 Submitted by: Keith Gaughan <k@stereochro.me> Approved by: adamw (mentor) Differential Revision: https://reviews.freebsd.org/D13593
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/py-cheroot/Makefile24
-rw-r--r--www/py-cheroot/distinfo3
-rw-r--r--www/py-cheroot/pkg-descr3
4 files changed, 31 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 373fcbc819da..e42dcd7ecb85 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1551,6 +1551,7 @@
SUBDIR += py-buku
SUBDIR += py-cachecontrol
SUBDIR += py-caldav
+ SUBDIR += py-cheroot
SUBDIR += py-cherrypy
SUBDIR += py-cherrypy-old
SUBDIR += py-clientform
diff --git a/www/py-cheroot/Makefile b/www/py-cheroot/Makefile
new file mode 100644
index 000000000000..98071ecce764
--- /dev/null
+++ b/www/py-cheroot/Makefile
@@ -0,0 +1,24 @@
+# Created by: Keith Gaughan <k@stereochro.me>
+# $FreeBSD$
+
+PORTNAME= cheroot
+DISTVERSION= 6.0.0
+CATEGORIES= www python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= k@stereochro.me
+COMMENT= Highly-optimized, pure-python HTTP server
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE.md
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools_scm>=1.15.0:devel/py-setuptools_scm@${FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>=1.11.0:devel/py-six@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}more-itertools>=2.6:devel/py-more-itertools@${FLAVOR}
+
+USES= python
+USE_PYTHON= distutils autoplist
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/www/py-cheroot/distinfo b/www/py-cheroot/distinfo
new file mode 100644
index 000000000000..ce9f24e68a17
--- /dev/null
+++ b/www/py-cheroot/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1513882382
+SHA256 (cheroot-6.0.0.tar.gz) = ba474e5149b03fabc2bba2d0b490b4d95443894d45b1430b799dccea3b3f4683
+SIZE (cheroot-6.0.0.tar.gz) = 62763
diff --git a/www/py-cheroot/pkg-descr b/www/py-cheroot/pkg-descr
new file mode 100644
index 000000000000..14a71773c733
--- /dev/null
+++ b/www/py-cheroot/pkg-descr
@@ -0,0 +1,3 @@
+Cheroot is a highly-optimized, pure-Python HTTP server used by CherryPy.
+
+WWW: https://github.com/cherrypy/cheroot