aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authordes <des@FreeBSD.org>2002-03-31 21:08:50 +0800
committerdes <des@FreeBSD.org>2002-03-31 21:08:50 +0800
commita833f054e23805a0a5ba6ed936962d76bc481c18 (patch)
treeb80bad45e1ca16a219caf765a6ca7a1a83825eb3 /www
parentbc11d0349fb17275b930059df57ff7af094da9c7 (diff)
downloadfreebsd-ports-gnome-a833f054e23805a0a5ba6ed936962d76bc481c18.tar.gz
freebsd-ports-gnome-a833f054e23805a0a5ba6ed936962d76bc481c18.tar.zst
freebsd-ports-gnome-a833f054e23805a0a5ba6ed936962d76bc481c18.zip
Use USE_LINUX instead of an explicit dependency on emulators/linux_base.
Submitted by: petef
Diffstat (limited to 'www')
-rw-r--r--www/linux-opera-devel/Makefile4
-rw-r--r--www/linux-opera/Makefile4
-rw-r--r--www/linux-opera7/Makefile4
3 files changed, 6 insertions, 6 deletions
diff --git a/www/linux-opera-devel/Makefile b/www/linux-opera-devel/Makefile
index 68d2460cbc55..5d0f2718e148 100644
--- a/www/linux-opera-devel/Makefile
+++ b/www/linux-opera-devel/Makefile
@@ -16,10 +16,10 @@ DISTNAME= ${PORTNAME}-${OPERAVERSION}.1-static-qt.i386
MAINTAINER= des@FreeBSD.org
-RUN_DEPENDS= ${LINUXBASE}/lib/ld.so:${PORTSDIR}/emulators/linux_base \
- ${LINUXBASE}/usr/X11R6/lib/libXm.so.2:${PORTSDIR}/x11-toolkits/linux-openmotif \
+RUN_DEPENDS= ${LINUXBASE}/usr/X11R6/lib/libXm.so.2:${PORTSDIR}/x11-toolkits/linux-openmotif \
${LINUXBASE}/usr/lib/libpng.so.2:${PORTSDIR}/graphics/linux-png
+USE_LINUX= yes
ONLY_FOR_ARCHS= i386
NO_BUILD= yes
diff --git a/www/linux-opera/Makefile b/www/linux-opera/Makefile
index 68d2460cbc55..5d0f2718e148 100644
--- a/www/linux-opera/Makefile
+++ b/www/linux-opera/Makefile
@@ -16,10 +16,10 @@ DISTNAME= ${PORTNAME}-${OPERAVERSION}.1-static-qt.i386
MAINTAINER= des@FreeBSD.org
-RUN_DEPENDS= ${LINUXBASE}/lib/ld.so:${PORTSDIR}/emulators/linux_base \
- ${LINUXBASE}/usr/X11R6/lib/libXm.so.2:${PORTSDIR}/x11-toolkits/linux-openmotif \
+RUN_DEPENDS= ${LINUXBASE}/usr/X11R6/lib/libXm.so.2:${PORTSDIR}/x11-toolkits/linux-openmotif \
${LINUXBASE}/usr/lib/libpng.so.2:${PORTSDIR}/graphics/linux-png
+USE_LINUX= yes
ONLY_FOR_ARCHS= i386
NO_BUILD= yes
diff --git a/www/linux-opera7/Makefile b/www/linux-opera7/Makefile
index 68d2460cbc55..5d0f2718e148 100644
--- a/www/linux-opera7/Makefile
+++ b/www/linux-opera7/Makefile
@@ -16,10 +16,10 @@ DISTNAME= ${PORTNAME}-${OPERAVERSION}.1-static-qt.i386
MAINTAINER= des@FreeBSD.org
-RUN_DEPENDS= ${LINUXBASE}/lib/ld.so:${PORTSDIR}/emulators/linux_base \
- ${LINUXBASE}/usr/X11R6/lib/libXm.so.2:${PORTSDIR}/x11-toolkits/linux-openmotif \
+RUN_DEPENDS= ${LINUXBASE}/usr/X11R6/lib/libXm.so.2:${PORTSDIR}/x11-toolkits/linux-openmotif \
${LINUXBASE}/usr/lib/libpng.so.2:${PORTSDIR}/graphics/linux-png
+USE_LINUX= yes
ONLY_FOR_ARCHS= i386
NO_BUILD= yes