aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2011-03-10 00:42:38 +0800
committermiwi <miwi@FreeBSD.org>2011-03-10 00:42:38 +0800
commitbeb1a2ba224495569565383fd84c71663ac87c65 (patch)
treef2985de7ed39938f3b81cd525799cc69112344b4 /www
parent2123b8d04d3ad6a333a2a608ace6389924968858 (diff)
downloadfreebsd-ports-gnome-beb1a2ba224495569565383fd84c71663ac87c65.tar.gz
freebsd-ports-gnome-beb1a2ba224495569565383fd84c71663ac87c65.tar.zst
freebsd-ports-gnome-beb1a2ba224495569565383fd84c71663ac87c65.zip
Plack::Middleware::Expires is Apache's mod_expires for Plack. This
middleware controls the setting of Expires HTTP header and the max-age directive of the Cache-Control HTTP header in server responses. Note: Expires works only for successful response and If exists Expires HTTP header already, this middleware does not override. WWW: http://search.cpan.org/dist/Plack-Middleware-Expires/ PR: ports/154476 Submitted by: Gea-Suan Lin <gslin at gslin.org>
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-Plack-Middleware-Expires/Makefile31
-rw-r--r--www/p5-Plack-Middleware-Expires/distinfo2
-rw-r--r--www/p5-Plack-Middleware-Expires/pkg-descr7
-rw-r--r--www/p5-Plack-Middleware-Expires/pkg-plist8
5 files changed, 49 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 7d1cd0d23091..351cad993b9e 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1145,6 +1145,7 @@
SUBDIR += p5-Plack-Middleware-ConsoleLogger
SUBDIR += p5-Plack-Middleware-Debug
SUBDIR += p5-Plack-Middleware-Deflater
+ SUBDIR += p5-Plack-Middleware-Expires
SUBDIR += p5-Plack-Middleware-File-Sass
SUBDIR += p5-Plack-Middleware-Header
SUBDIR += p5-Plack-Middleware-IEnosniff
diff --git a/www/p5-Plack-Middleware-Expires/Makefile b/www/p5-Plack-Middleware-Expires/Makefile
new file mode 100644
index 000000000000..13406eb4766e
--- /dev/null
+++ b/www/p5-Plack-Middleware-Expires/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: p5-Plack-Middleware-Expires
+# Date created: 2011-02-03
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Plack-Middleware-Expires
+PORTVERSION= 0.03
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Perl module mod_expires for Plack
+
+RUN_DEPENDS= p5-Plack>=0.9937:${PORTSDIR}/www/p5-Plack \
+ p5-Try-Tiny>=0.06:${PORTSDIR}/lang/p5-Try-Tiny \
+ p5-libwww>=0:${PORTSDIR}/www/p5-libwww
+
+PERL_CONFIGURE= yes
+
+MAN3= Plack::Middleware::Expires.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 501001
+RUN_DEPENDS+= p5-parent>=0:${PORTSDIR}/devel/p5-parent
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/www/p5-Plack-Middleware-Expires/distinfo b/www/p5-Plack-Middleware-Expires/distinfo
new file mode 100644
index 000000000000..ab3188a64b37
--- /dev/null
+++ b/www/p5-Plack-Middleware-Expires/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Plack-Middleware-Expires-0.03.tar.gz) = cede38e91339cc0fc8d6188a0bd1f4f5d0dccf76c7f92047981461c9e9488545
+SIZE (Plack-Middleware-Expires-0.03.tar.gz) = 26665
diff --git a/www/p5-Plack-Middleware-Expires/pkg-descr b/www/p5-Plack-Middleware-Expires/pkg-descr
new file mode 100644
index 000000000000..981cedc3b41c
--- /dev/null
+++ b/www/p5-Plack-Middleware-Expires/pkg-descr
@@ -0,0 +1,7 @@
+Plack::Middleware::Expires is Apache's mod_expires for Plack. This
+middleware controls the setting of Expires HTTP header and the max-age
+directive of the Cache-Control HTTP header in server responses. Note:
+Expires works only for successful response and If exists Expires HTTP
+header already, this middleware does not override.
+
+WWW: http://search.cpan.org/dist/Plack-Middleware-Expires/
diff --git a/www/p5-Plack-Middleware-Expires/pkg-plist b/www/p5-Plack-Middleware-Expires/pkg-plist
new file mode 100644
index 000000000000..2dc60a5a2565
--- /dev/null
+++ b/www/p5-Plack-Middleware-Expires/pkg-plist
@@ -0,0 +1,8 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Plack/Middleware/Expires/.packlist
+%%SITE_PERL%%/Plack/Middleware/Expires.pm
+@dirrmtry %%SITE_PERL%%/Plack/Middleware
+@dirrmtry %%SITE_PERL%%/Plack
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Plack/Middleware/Expires
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Plack/Middleware
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Plack