aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2004-10-13 20:02:12 +0800
committerpav <pav@FreeBSD.org>2004-10-13 20:02:12 +0800
commitbef533d1901d96a1493431e2d23493a249512dd4 (patch)
treed7dd1c8e3c93efa3654f1b857f237d192c6fa0f4 /www
parentbc089ea557db02f7a628ec0f34100ebb4ab41d24 (diff)
downloadfreebsd-ports-gnome-bef533d1901d96a1493431e2d23493a249512dd4.tar.gz
freebsd-ports-gnome-bef533d1901d96a1493431e2d23493a249512dd4.tar.zst
freebsd-ports-gnome-bef533d1901d96a1493431e2d23493a249512dd4.zip
Add zope-mimetypesregistry, a Zope product for mime types information
handling. PR: ports/72576 Submitted by: Filippo Natali <filippo@widestore.net>
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/zope-mimetypesregistry/Makefile55
-rw-r--r--www/zope-mimetypesregistry/distinfo2
-rw-r--r--www/zope-mimetypesregistry/pkg-descr10
4 files changed, 68 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 8b22e912bc50..645b19859933 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -737,6 +737,7 @@
SUBDIR += zope-groupuserfolder
SUBDIR += zope-guf
SUBDIR += zope-i18nlayer
+ SUBDIR += zope-mimetypesregistry
SUBDIR += zope-mindmapbbs
SUBDIR += zope-mysqluserfolder
SUBDIR += zope-parsedxml
diff --git a/www/zope-mimetypesregistry/Makefile b/www/zope-mimetypesregistry/Makefile
new file mode 100644
index 000000000000..60a260ee2308
--- /dev/null
+++ b/www/zope-mimetypesregistry/Makefile
@@ -0,0 +1,55 @@
+# New ports collection makefile for: zope-mimetypesregistry
+# Date created: 06 Oct 2004
+# Whom: Filippo Natali
+#
+# $FreeBSD$
+#
+
+PORTNAME= mimetypesregistry
+PORTVERSION= 1.3.2
+CATEGORIES= www zope
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= archetypes
+PKGNAMEPREFIX= zope-
+DISTNAME= MimetypesRegistry-${PORTVERSION}-4
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= filippo@widestore.net
+COMMENT= MimetypesRegistry product for Zope/CMF
+
+RUN_DEPENDS= ${LOCALBASE}/${SZOPEBASEDIR}/${ZOPEPRODUCTDIR}/CMFDefault/__init__.py:${PORTSDIR}/www/zope-cmf
+
+USE_PYTHON= yes
+USE_ZOPE= yes
+DIST_SUBDIR= zope
+
+ZOPEPRODUCTNAME= MimetypesRegistry
+
+WRKSRC= ${WRKDIR}/${ZOPEPRODUCTNAME}
+PLIST= ${WRKDIR}/pkg-plist
+
+do-build:
+ -@${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py ${WRKSRC}
+
+pre-install:
+ @${RM} -f ${PLIST}
+ @${TOUCH} ${PLIST}
+ @cd ${WRKDIR} && \
+ for f in `${FIND} ${ZOPEPRODUCTNAME} -type f`; do \
+ ${ECHO_CMD} %%ZOPEPRODUCTDIR%%/$${f} >> ${PLIST}; \
+ done; \
+ for d in `${FIND} -d ${ZOPEPRODUCTNAME} -type d`; do \
+ ${ECHO_CMD} @dirrm %%ZOPEPRODUCTDIR%%/$${d} >> ${PLIST}; \
+ done; \
+
+do-install:
+ @${MKDIR} ${ZOPEBASEDIR}/${ZOPEPRODUCTDIR}/
+ @${CHMOD} -R og+rX ${WRKSRC}/
+ @${CP} -R ${WRKSRC} ${ZOPEBASEDIR}/${ZOPEPRODUCTDIR}/
+
+post-install:
+.if !defined(BATCH)
+ @${ECHO} Restart Zope to complete installation of ${PORTNAME}
+.endif
+
+.include <bsd.port.mk>
diff --git a/www/zope-mimetypesregistry/distinfo b/www/zope-mimetypesregistry/distinfo
new file mode 100644
index 000000000000..2d7da2c4e29f
--- /dev/null
+++ b/www/zope-mimetypesregistry/distinfo
@@ -0,0 +1,2 @@
+MD5 (zope/MimetypesRegistry-1.3.2-4.tgz) = 055d4aeacc4bbe28dacb058e98558475
+SIZE (zope/MimetypesRegistry-1.3.2-4.tgz) = 69242
diff --git a/www/zope-mimetypesregistry/pkg-descr b/www/zope-mimetypesregistry/pkg-descr
new file mode 100644
index 000000000000..4924f82d10da
--- /dev/null
+++ b/www/zope-mimetypesregistry/pkg-descr
@@ -0,0 +1,10 @@
+Mimetypes Registry
+
+This Zope product provides a new tool for the CMF in order to make MIME
+types based transformations on the portal contents, and so an easy to way to
+plugin some new transformations for previously unsupported content types. The
+provided tool is:
+
+ * mimetypes_registry (the mimetypes tool) : handle mime types information
+
+WWW: http://sourceforge.net/projects/archetypes