aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2014-10-05 22:43:15 +0800
committerantoine <antoine@FreeBSD.org>2014-10-05 22:43:15 +0800
commitc9ff05a04c9bc54239f69d4bb9e52d8bf0e0f7cb (patch)
tree93dd14c5cd3938ea9f8f954687d08a9c36c9be2e /www
parent8d2c061b7c02836400768609b4aabaad756391e1 (diff)
downloadfreebsd-ports-gnome-c9ff05a04c9bc54239f69d4bb9e52d8bf0e0f7cb.tar.gz
freebsd-ports-gnome-c9ff05a04c9bc54239f69d4bb9e52d8bf0e0f7cb.tar.zst
freebsd-ports-gnome-c9ff05a04c9bc54239f69d4bb9e52d8bf0e0f7cb.zip
New port: www/py-flask-sockets
Elegant WebSockets for your Flask apps. WWW: https://github.com/kennethreitz/flask-sockets
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/py-flask-sockets/Makefile22
-rw-r--r--www/py-flask-sockets/distinfo2
-rw-r--r--www/py-flask-sockets/pkg-descr3
4 files changed, 28 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 3f3468cb67f2..84b038a797d9 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1529,6 +1529,7 @@
SUBDIR += py-flask-admin
SUBDIR += py-flask-cache
SUBDIR += py-flask-flatpages
+ SUBDIR += py-flask-sockets
SUBDIR += py-flask-uploads
SUBDIR += py-flexget
SUBDIR += py-flup
diff --git a/www/py-flask-sockets/Makefile b/www/py-flask-sockets/Makefile
new file mode 100644
index 000000000000..e962f6d19296
--- /dev/null
+++ b/www/py-flask-sockets/Makefile
@@ -0,0 +1,22 @@
+# Created by: antoine@FreeBSD.org
+# $FreeBSD$
+
+PORTNAME= Flask-Sockets
+PORTVERSION= 0.1
+CATEGORIES= www python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= antoine@FreeBSD.org
+COMMENT= Elegant WebSockets for your Flask apps
+
+LICENSE= MIT
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}Flask>=0:${PORTSDIR}/www/py-flask \
+ ${PYTHON_PKGNAMEPREFIX}gevent>=0:${PORTSDIR}/devel/py-gevent \
+ ${PYTHON_PKGNAMEPREFIX}gevent-websocket>=0:${PORTSDIR}/www/py-gevent-websocket
+
+USES= python
+USE_PYTHON= distutils autoplist
+
+.include <bsd.port.mk>
diff --git a/www/py-flask-sockets/distinfo b/www/py-flask-sockets/distinfo
new file mode 100644
index 000000000000..39eae4035edd
--- /dev/null
+++ b/www/py-flask-sockets/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Flask-Sockets-0.1.tar.gz) = 7991074577623a0e1e3ecdfcbf0d59a7b426b224db8b522f3917969c6c37a97b
+SIZE (Flask-Sockets-0.1.tar.gz) = 2471
diff --git a/www/py-flask-sockets/pkg-descr b/www/py-flask-sockets/pkg-descr
new file mode 100644
index 000000000000..6d4cd19ba7c5
--- /dev/null
+++ b/www/py-flask-sockets/pkg-descr
@@ -0,0 +1,3 @@
+Elegant WebSockets for your Flask apps.
+
+WWW: https://github.com/kennethreitz/flask-sockets