aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorasami <asami@FreeBSD.org>2000-04-14 21:29:03 +0800
committerasami <asami@FreeBSD.org>2000-04-14 21:29:03 +0800
commitd83fdfe5b6bc814f09abd330920e4edd06b35c91 (patch)
tree9d7632d1684441e5ddc5f64f56249034ee98f30c /www
parent35d4dd0563b990be5e2233ed2a22a268fce9160f (diff)
downloadfreebsd-ports-gnome-d83fdfe5b6bc814f09abd330920e4edd06b35c91.tar.gz
freebsd-ports-gnome-d83fdfe5b6bc814f09abd330920e4edd06b35c91.tar.zst
freebsd-ports-gnome-d83fdfe5b6bc814f09abd330920e4edd06b35c91.zip
Make sure PORTNAME/PORTVERSION are defined before inclusion of pre.mk.
There might be some better solutions but this should at least make them work for now.
Diffstat (limited to 'www')
-rw-r--r--www/bsdi-netscape47-communicator/Makefile3
-rw-r--r--www/bsdi-netscape47-navigator/Makefile3
-rw-r--r--www/netscape47-communicator/Makefile3
-rw-r--r--www/netscape47-navigator/Makefile3
4 files changed, 12 insertions, 0 deletions
diff --git a/www/bsdi-netscape47-communicator/Makefile b/www/bsdi-netscape47-communicator/Makefile
index e7a06b870bde..361526dc5b3a 100644
--- a/www/bsdi-netscape47-communicator/Makefile
+++ b/www/bsdi-netscape47-communicator/Makefile
@@ -5,6 +5,9 @@
# $FreeBSD$
#
+PORTNAME= netscape-${BROWSER_ARC}
+PORTVERSION= ${BROWSER_VER}
+
.if !defined(PRE_MK_INCLUDED)
.include <bsd.port.pre.mk>
.endif
diff --git a/www/bsdi-netscape47-navigator/Makefile b/www/bsdi-netscape47-navigator/Makefile
index 43c32b1762af..f0c2df7fb014 100644
--- a/www/bsdi-netscape47-navigator/Makefile
+++ b/www/bsdi-netscape47-navigator/Makefile
@@ -5,6 +5,9 @@
# $FreeBSD$
#
+PORTNAME= netscape-${BROWSER_ARC}
+PORTVERSION= ${BROWSER_VER}
+
.include <bsd.port.pre.mk>
.if ${ARCH} == "i386"
diff --git a/www/netscape47-communicator/Makefile b/www/netscape47-communicator/Makefile
index e7a06b870bde..361526dc5b3a 100644
--- a/www/netscape47-communicator/Makefile
+++ b/www/netscape47-communicator/Makefile
@@ -5,6 +5,9 @@
# $FreeBSD$
#
+PORTNAME= netscape-${BROWSER_ARC}
+PORTVERSION= ${BROWSER_VER}
+
.if !defined(PRE_MK_INCLUDED)
.include <bsd.port.pre.mk>
.endif
diff --git a/www/netscape47-navigator/Makefile b/www/netscape47-navigator/Makefile
index 43c32b1762af..f0c2df7fb014 100644
--- a/www/netscape47-navigator/Makefile
+++ b/www/netscape47-navigator/Makefile
@@ -5,6 +5,9 @@
# $FreeBSD$
#
+PORTNAME= netscape-${BROWSER_ARC}
+PORTVERSION= ${BROWSER_VER}
+
.include <bsd.port.pre.mk>
.if ${ARCH} == "i386"