aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2005-12-18 03:54:49 +0800
committerpav <pav@FreeBSD.org>2005-12-18 03:54:49 +0800
commitd8cd7d61a507e8e41d262e029e47e5925eb93544 (patch)
treebd4ffc9ec3ccd504cd0c1123cdab72b4989e0159 /www
parenta5d9d14705b6b3725c06a6b0278aa65df2279159 (diff)
downloadfreebsd-ports-gnome-d8cd7d61a507e8e41d262e029e47e5925eb93544.tar.gz
freebsd-ports-gnome-d8cd7d61a507e8e41d262e029e47e5925eb93544.tar.zst
freebsd-ports-gnome-d8cd7d61a507e8e41d262e029e47e5925eb93544.zip
- Make apache dependency optional
PR: ports/90513 Submitted by: Freddie Cash <fcash@sd73.bc.ca> (maintainer)
Diffstat (limited to 'www')
-rw-r--r--www/dansguardian/Makefile14
1 files changed, 9 insertions, 5 deletions
diff --git a/www/dansguardian/Makefile b/www/dansguardian/Makefile
index ba1a02a3dab4..bb61dc7e57fb 100644
--- a/www/dansguardian/Makefile
+++ b/www/dansguardian/Makefile
@@ -7,6 +7,7 @@
PORTNAME= dansguardian
PORTVERSION= 2.8.0.6
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= # empty, see below
DISTNAME= ${PORTNAME}-${PORTVERSION}.source
@@ -14,8 +15,7 @@ DISTNAME= ${PORTNAME}-${PORTVERSION}.source
MAINTAINER= fcash@sd73.bc.ca
COMMENT= A fast, feature-rich web content filter for Squid proxy servers
-RUN_DEPENDS= ${LOCALBASE}/sbin/squid:${PORTSDIR}/www/squid \
- ${LOCALBASE}/sbin/httpd:${PORTSDIR}/www/apache13
+RUN_DEPENDS= ${LOCALBASE}/sbin/squid:${PORTSDIR}/www/squid
USE_RC_SUBR= yes
RC_SCRIPTS_SUB= PREFIX=${PREFIX} RC_SUBR=${RC_SUBR}
@@ -36,15 +36,15 @@ CONFIGURE_ARGS= --bindir=/sbin/ \
MAN8= dansguardian.8
NOMANCOMPRESSED= yes
-OPTIONS= DG_GCC3 "Compile using GCC 3.3 on FreeBSD 4.x." off \
- DG_PHRASELISTS "Install new phraselists. (Overwrites existing.)" off
+OPTIONS= DG_APACHE "Enable Apache support." on \
+ DG_PHRASELISTS "Install new phraselists over the old ones." off
DG_URL= http://dansguardian.org/index.php?page=copyright2
CONFDIR= ${PREFIX}/etc/dansguardian
NO_CDROM= "Commercial download is restricted. Check ${DG_URL} for more info"
NO_PACKAGE= "Redistribution is restricted. Check ${DG_URL} for more info"
-RESTRICTED= ${NO_PACKAGE}
+RESTRICTED= "${NO_PACKAGE}"
.include <bsd.port.pre.mk>
@@ -55,6 +55,10 @@ CONFIGURE_ARGS+= --gccver=3
CONFIGURE_ARGS+= --gccver=2
.endif
+.if !defined(WITHOUT_DG_APACHE)
+USE_APACHE= 1.3+
+.endif
+
# User needs to manually download the distfile
.if !(exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX})) && !defined(PACKAGE_BUILDING)
IGNORE="Commercial source download is restricted. Please visit and read ${DG_URL} and download ${DISTNAME}${EXTRACT_SUFX} into ${DISTDIR} before running make"