aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorak <ak@FreeBSD.org>2014-01-27 16:22:55 +0800
committerak <ak@FreeBSD.org>2014-01-27 16:22:55 +0800
commite169fc07a0a4790395068a4a4b1f0a80c3b47ea8 (patch)
tree4f912c4d50f7a7481894d0d2146d7b97eba2600e /www
parent391ea3f1a9e58952936f236bdd759553da567f0b (diff)
downloadfreebsd-ports-gnome-e169fc07a0a4790395068a4a4b1f0a80c3b47ea8.tar.gz
freebsd-ports-gnome-e169fc07a0a4790395068a4a4b1f0a80c3b47ea8.tar.zst
freebsd-ports-gnome-e169fc07a0a4790395068a4a4b1f0a80c3b47ea8.zip
- Support STAGEDIR [1]
- Use options helpers - Rewrap overly long line in pkg-descr, remove gratuitous whitespaces at the end of the line PR: ports/186148 (based on) [1] Submitted by: Olivier Cochard-Labbé <olivier@cochard.me> (maintainer) [1]
Diffstat (limited to 'www')
-rw-r--r--www/shellinabox/Makefile35
-rw-r--r--www/shellinabox/pkg-descr6
-rw-r--r--www/shellinabox/pkg-plist8
3 files changed, 18 insertions, 31 deletions
diff --git a/www/shellinabox/Makefile b/www/shellinabox/Makefile
index 54c9581b226e..7022d0e8e718 100644
--- a/www/shellinabox/Makefile
+++ b/www/shellinabox/Makefile
@@ -3,7 +3,7 @@
PORTNAME= shellinabox
PORTVERSION= 2.14
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= www
MASTER_SITES= GOOGLE_CODE
@@ -12,7 +12,7 @@ COMMENT= Publish command line shell through AJAX interface
LICENSE= GPLv2
-OPTIONS_DEFINE= CORES DOCS NOLOGIN
+OPTIONS_DEFINE= CORES NOLOGIN
CORES_DESC= Patch shellinaboxd to enable core dumps
NOLOGIN_DESC= Login through ssh (not through login)
@@ -26,27 +26,16 @@ USE_RC_SUBR= shellinaboxd
USERS?= shellinabox
GROUPS?= shellinabox
-MAN1= shellinaboxd.1
-
-PORTDOCS= AUTHORS ChangeLog INSTALL README COPYING GPL-2 NEWS TODO
-
PKGDEINSTALL= ${WRKDIR}/pkg-deinstall
SUB_FILES= pkg-deinstall
SUB_LIST= USERS=${USERS} GROUPS=${GROUPS}
-NO_STAGE= yes
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MNOLOGIN}
-CONFIGURE_ARGS+=--disable-login
-.endif
+NOLOGIN_CONFIGURE_ON= --disable-login
-.include <bsd.port.pre.mk>
+BROKEN_powerpc= Does not load on powerpc
-.if ${ARCH} == "powerpc"
-BROKEN= Does not load on powerpc
-.endif
+.include <bsd.port.options.mk>
post-patch:
.if ${PORT_OPTIONS:MCORES}
@@ -57,16 +46,10 @@ post-patch:
.endif
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/shellinaboxd ${PREFIX}/bin/
+ ${INSTALL_PROGRAM} ${WRKSRC}/shellinaboxd ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/shellinaboxd.1 ${STAGEDIR}${MAN1PREFIX}/man/man1
post-install:
-.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}/
- cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}/
-.endif
- ${MKDIR} ${ETCDIR}/
- ${CHMOD} 700 ${ETCDIR}/
- ${CHOWN} ${USERS}:${GROUPS} ${ETCDIR}/
- ${INSTALL_MAN} ${WRKSRC}/shellinaboxd.1 ${MANPREFIX}/man/man1/
+ @${MKDIR} ${STAGEDIR}${ETCDIR}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/shellinabox/pkg-descr b/www/shellinabox/pkg-descr
index f8c128085793..522775e10fdd 100644
--- a/www/shellinabox/pkg-descr
+++ b/www/shellinabox/pkg-descr
@@ -1,4 +1,4 @@
-Shell In A Box is a web server that can export arbitary command line tools to a
-web based terminal emulator
+Shell In A Box is a web server that can export arbitary command line tools
+to a web based terminal emulator.
-WWW: http://code.google.com/p/shellinabox/
+WWW: http://code.google.com/p/shellinabox/
diff --git a/www/shellinabox/pkg-plist b/www/shellinabox/pkg-plist
index 15ac7cfb00ed..8733521e4ebd 100644
--- a/www/shellinabox/pkg-plist
+++ b/www/shellinabox/pkg-plist
@@ -1,5 +1,9 @@
bin/shellinaboxd
+etc/rc.d/shellinaboxd
+man/man1/shellinaboxd.1.gz
+@mode 700
+@owner shellinabox
+@group shellinabox
@exec mkdir -p %D/etc/shellinabox
-@exec chmod 777 %D/etc/shellinabox
-@exec chown nobody %D/etc/shellinabox
@dirrmtry etc/shellinabox
+@mode