aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorbeat <beat@FreeBSD.org>2011-03-03 00:32:43 +0800
committerbeat <beat@FreeBSD.org>2011-03-03 00:32:43 +0800
commite1dbbd626a05b8e12ea4acd59144d289e5e378eb (patch)
treeecb1851d93f8644a2561ce5e851123d047806416 /www
parent539bc97ca1b8cd5606511104221385183b907385 (diff)
downloadfreebsd-ports-gnome-e1dbbd626a05b8e12ea4acd59144d289e5e378eb.tar.gz
freebsd-ports-gnome-e1dbbd626a05b8e12ea4acd59144d289e5e378eb.tar.zst
freebsd-ports-gnome-e1dbbd626a05b8e12ea4acd59144d289e5e378eb.zip
- Update to 1.9.2.14
- Add support for powerpc64 [1] Submitted by: andreast@ [1] Security: http://www.vuxml.org/freebsd/45f102cd-4456-11e0-9580-4061862b8c22.html
Diffstat (limited to 'www')
-rw-r--r--www/libxul/Makefile11
-rw-r--r--www/libxul/distinfo4
-rw-r--r--www/libxul/files/patch-js-ctypes-libffi-configure12
-rw-r--r--www/libxul/files/patch-security_nss_lib_freebl_mpi_mpcpucache.c44
-rw-r--r--www/libxul/files/patch-xpcom_reflect_xptcall_src_md_unix_Makefile.in17
5 files changed, 83 insertions, 5 deletions
diff --git a/www/libxul/Makefile b/www/libxul/Makefile
index f24ca665e630..b945eb265ff4 100644
--- a/www/libxul/Makefile
+++ b/www/libxul/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= libxul
-DISTVERSION= 1.9.2.13
+DISTVERSION= 1.9.2.14
CATEGORIES?= www devel
MASTER_SITES= ${MASTER_SITE_MOZILLA}
MASTER_SITE_SUBDIR= xulrunner/releases/${DISTVERSION}/source
@@ -60,6 +60,15 @@ EXTRA_PATCHES= ${FILESDIR}/releng6_pulseaudio
EXTRA_PATCHES= ${FILESDIR}/libsydney_oss
.endif
+.if ${ARCH} == powerpc64
+.if ${OSVERSION} < 900033
+BROKEN= Needs binutils 2.17.50 to build
+.else
+CONFIGURE_ENV+= UNAME_m="powerpc64"
+CFLAGS+= -mminimal-toc
+.endif
+.endif
+
.if defined(WITHOUT_DBUS)
MOZ_OPTIONS+= --disable-dbus --disable-libnotify
.else
diff --git a/www/libxul/distinfo b/www/libxul/distinfo
index 03e22741db2b..bc9e1f7ede07 100644
--- a/www/libxul/distinfo
+++ b/www/libxul/distinfo
@@ -1,2 +1,2 @@
-SHA256 (xulrunner-1.9.2.13.source.tar.bz2) = a9e0a30b209c000ed8c77826e733a5cab3e0bf89b837b196461a23cd87ae3ce9
-SIZE (xulrunner-1.9.2.13.source.tar.bz2) = 51359622
+SHA256 (xulrunner-1.9.2.14.source.tar.bz2) = 2eb49f749a60d88692e5421e58fc1c255d111bb1e45c66c569f81bf48481f004
+SIZE (xulrunner-1.9.2.14.source.tar.bz2) = 51560419
diff --git a/www/libxul/files/patch-js-ctypes-libffi-configure b/www/libxul/files/patch-js-ctypes-libffi-configure
new file mode 100644
index 000000000000..3f6b66e1d628
--- /dev/null
+++ b/www/libxul/files/patch-js-ctypes-libffi-configure
@@ -0,0 +1,12 @@
+--- js/ctypes/libffi/configure.orig 2010-07-22 23:54:58.000000000 +0200
++++ js/ctypes/libffi/configure 2010-08-05 07:34:44.000000000 +0200
+@@ -21033,6 +21033,9 @@
+ powerpc-*-aix* | rs6000-*-aix*)
+ TARGET=POWERPC_AIX; TARGETDIR=powerpc
+ ;;
++ powerpc64-*-freebsd*)
++ TARGET=POWERPC; TARGETDIR=powerpc
++ ;;
+ powerpc-*-freebsd*)
+ TARGET=POWERPC_FREEBSD; TARGETDIR=powerpc
+ ;;
diff --git a/www/libxul/files/patch-security_nss_lib_freebl_mpi_mpcpucache.c b/www/libxul/files/patch-security_nss_lib_freebl_mpi_mpcpucache.c
new file mode 100644
index 000000000000..b579fc5b4995
--- /dev/null
+++ b/www/libxul/files/patch-security_nss_lib_freebl_mpi_mpcpucache.c
@@ -0,0 +1,44 @@
+--- security/nss/lib/freebl/mpi/mpcpucache.c.orig 2011-02-26 18:44:42.000000000 +0100
++++ security/nss/lib/freebl/mpi/mpcpucache.c 2011-02-26 18:46:41.000000000 +0100
+@@ -733,6 +733,33 @@
+ #endif
+
+ #if defined(__ppc64__)
++#if defined(__FreeBSD__)
++#include <sys/stddef.h>
++#include <sys/sysctl.h>
++
++#include <machine/cpu.h>
++#include <machine/md_var.h>
++
++unsigned long
++s_mpi_getProcessorLineSize()
++{
++ static int cacheline_size = 0;
++ static int cachemib[] = { CTL_MACHDEP, CPU_CACHELINE };
++ int clen;
++
++ if (cacheline_size > 0)
++ return cacheline_size;
++
++ clen = sizeof(cacheline_size);
++ if (sysctl(cachemib, sizeof(cachemib) / sizeof(cachemib[0]),
++ &cacheline_size, &clen, NULL, 0) < 0 || !cacheline_size)
++ return 128; /* guess */
++
++ return cacheline_size;
++}
++#else /* __FreeBSD__ */
++
++
+ /*
+ * Sigh, The PPC has some really nice features to help us determine cache
+ * size, since it had lots of direct control functions to do so. The POWER
+@@ -786,6 +813,7 @@
+ return 0;
+ }
+
++#endif /* __FreeBSD__ */
+ #define MPI_GET_PROCESSOR_LINE_SIZE_DEFINED 1
+ #endif
+
diff --git a/www/libxul/files/patch-xpcom_reflect_xptcall_src_md_unix_Makefile.in b/www/libxul/files/patch-xpcom_reflect_xptcall_src_md_unix_Makefile.in
index 244af2e49204..124e86202838 100644
--- a/www/libxul/files/patch-xpcom_reflect_xptcall_src_md_unix_Makefile.in
+++ b/www/libxul/files/patch-xpcom_reflect_xptcall_src_md_unix_Makefile.in
@@ -1,5 +1,5 @@
---- xpcom/reflect/xptcall/src/md/unix/Makefile.in.orig 2009-09-16 04:41:25.000000000 +0200
-+++ xpcom/reflect/xptcall/src/md/unix/Makefile.in 2009-10-03 21:30:21.000000000 +0200
+--- xpcom/reflect/xptcall/src/md/unix/Makefile.in.orig 2010-04-02 16:03:13.000000000 +0000
++++ xpcom/reflect/xptcall/src/md/unix/Makefile.in 2010-06-06 19:19:44.000000000 +0000
@@ -73,6 +73,9 @@
DEFINES += -DKEEP_STACK_16_BYTE_ALIGNED
CPPSRCS := xptcinvoke_unixish_x86.cpp xptcstubs_unixish_x86.cpp
@@ -56,6 +56,19 @@
CPPSRCS := xptcinvoke_ppc_linux.cpp xptcstubs_ppc_linux.cpp
ASFILES := xptcinvoke_asm_ppc_linux.s xptcstubs_asm_ppc_linux.s
AS := $(CC) -c -x assembler-with-cpp
+@@ -331,9 +340,9 @@
+ #
+ # Linux/PPC64
+ #
+-ifeq ($(OS_ARCH)$(OS_TEST),Linuxpowerpc64)
+-CPPSRCS := xptcinvoke_ppc64_linux.cpp xptcstubs_ppc64_linux.cpp
+-ASFILES := xptcinvoke_asm_ppc64_linux.s xptcstubs_asm_ppc64_linux.s
++ifneq (,$(filter Linuxpowerpc64 FreeBSDpowerpc64,$(OS_ARCH)$(OS_TEST)))
++CPPSRCS := xptcinvoke_ppc64_linux.cpp xptcstubs_ppc64_linux.cpp
++ASFILES := xptcinvoke_asm_ppc64_linux.s xptcstubs_asm_ppc64_linux.s
+ AS := $(CC) -c -x assembler-with-cpp
+ endif
+
@@ -400,6 +409,15 @@
ASFILES := xptcinvoke_asm_sparc_netbsd.s xptcstubs_asm_sparc_netbsd.s
endif